aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/matchbox-panel-hacks
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/matchbox-panel-hacks
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/matchbox-panel-hacks')
-rw-r--r--recipes/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop7
-rwxr-xr-xrecipes/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh8
-rw-r--r--recipes/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.pngbin0 -> 1651 bytes
-rw-r--r--recipes/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb25
4 files changed, 40 insertions, 0 deletions
diff --git a/recipes/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop b/recipes/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop
new file mode 100644
index 0000000000..512e3771e4
--- /dev/null
+++ b/recipes/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Screen Rotator
+Comment=Panel based Rotation tool.
+Exec=mb-applet-launcher -na -l --title "Screen Rotator" /usr/share/pixmaps/xrandr.png xrandr-panelapp.sh
+Type=PanelApp
+Icon=xrandr.png
+Categories=Panel;Utility;MB
diff --git a/recipes/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh b/recipes/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh
new file mode 100755
index 0000000000..fbf88d6d08
--- /dev/null
+++ b/recipes/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+if [ -n "$(xrandr | grep default | grep 'left\ (')" ] ; then
+ xrandr -o normal
+ xmodmap /etc/X11/xmodmap-portrait
+else
+ xrandr -o left
+ xmodmap /etc/X11/xmodmap-left
+fi
diff --git a/recipes/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.png b/recipes/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.png
new file mode 100644
index 0000000000..08cd476e8a
--- /dev/null
+++ b/recipes/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.png
Binary files differ
diff --git a/recipes/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb b/recipes/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
new file mode 100644
index 0000000000..2fd7926707
--- /dev/null
+++ b/recipes/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Simple dockapps created with monolaunch and shell script"
+LICENSE = "MIT"
+SECTION = "x11/wm"
+PRIORITY = "optional"
+
+DEPENDS = "matchbox xmodmap"
+
+PR = "r7"
+
+SRC_URI = "file://xrandr-panelapp.sh \
+ file://xrandr-panelapp.desktop \
+ file://xrandr.png"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/applications
+ install -d ${D}${datadir}/pixmaps
+ install -m 0755 ${WORKDIR}/xrandr-panelapp.sh ${D}${bindir}/
+ install -m 0644 ${WORKDIR}/xrandr-panelapp.desktop ${D}${datadir}/applications/
+ install -m 0644 ${WORKDIR}/xrandr.png ${D}${datadir}/pixmaps/
+}
+
+#The package contains ashellscript, a .desktop file and a png
+PACKAGE_ARCH = "all"
+