aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mediatomb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/mediatomb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/mediatomb')
-rw-r--r--recipes/mediatomb/files/curl.diff20
-rw-r--r--recipes/mediatomb/files/inotify.diff45
-rw-r--r--recipes/mediatomb/mediatomb_0.11.0.bb35
-rw-r--r--recipes/mediatomb/mediatomb_0.8+0.9.0-pre.bb32
-rw-r--r--recipes/mediatomb/mediatomb_0.9.0.bb30
-rw-r--r--recipes/mediatomb/mediatomb_0.9.1.bb30
-rw-r--r--recipes/mediatomb/mediatomb_svn.bb33
7 files changed, 225 insertions, 0 deletions
diff --git a/recipes/mediatomb/files/curl.diff b/recipes/mediatomb/files/curl.diff
new file mode 100644
index 0000000000..f34c9fc26e
--- /dev/null
+++ b/recipes/mediatomb/files/curl.diff
@@ -0,0 +1,20 @@
+--- /tmp/url.cc 2008-09-14 20:40:33.000000000 +0200
++++ mediatomb-0.11.0/src/url.cc 2008-09-14 20:40:49.523198000 +0200
+@@ -24,7 +24,7 @@
+ version 2 along with MediaTomb; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
+
+- $Id: url.cc 1714 2008-03-01 17:33:21Z lww $
++ $Id$
+ */
+
+ /// \file url.cc
+@@ -75,7 +75,7 @@
+
+ if (only_header)
+ {
+- curl_easy_setopt(curl_handle, CURLOPT_NOBODY);
++ curl_easy_setopt(curl_handle, CURLOPT_NOBODY, 1);
+ curl_easy_setopt(curl_handle, CURLOPT_HEADERFUNCTION, URL::dl);
+ curl_easy_setopt(curl_handle, CURLOPT_HEADERDATA,
+ (void *)buffer.getPtr());
diff --git a/recipes/mediatomb/files/inotify.diff b/recipes/mediatomb/files/inotify.diff
new file mode 100644
index 0000000000..8c14fc99cc
--- /dev/null
+++ b/recipes/mediatomb/files/inotify.diff
@@ -0,0 +1,45 @@
+--- /tmp/configure.ac 2008-09-14 20:31:20.000000000 +0200
++++ mediatomb-0.11.0/configure.ac 2008-09-14 20:32:23.043198000 +0200
+@@ -2888,41 +2888,7 @@
+ fi
+ fi
+
+-if test "x$INOTIFY_EN" != xno; then
+-dnl The check below was inspired by configure.ac from the inotify tools
+-dnl package, see the "Acknowledgements" section in our README file for more
+-dnl information.
+- CXXFLAGS="$CXXFLAGS $INOTIFY_CXXFLAGS"
+- AC_MSG_CHECKING([whether sys/inotify.h works])
+- AC_RUN_IFELSE(
+- AC_LANG_PROGRAM([[#include <sys/inotify.h>]],
+- [[return (-1 == inotify_init());]]
+- ),
+- [
+- AC_MSG_RESULT([yes]);
+- AC_DEFINE([SYS_INOTIFY_H_OK],[1],[sys/inotify.h exists and works on this system])],
+- [
+- AC_MSG_RESULT([no, using own inotify headers])
+- AC_MSG_CHECKING([whether inotify-nosys.h works on this system])
+- AC_RUN_IFELSE(
+- AC_LANG_PROGRAM([[#include "src/inotify-nosys.h"]],
+- [[return (-1 == inotify_init());]]
+- ),
+- [
+- AC_MSG_RESULT([yes]);
+- INOTIFY_OK=yes
+- ],
+- [
+- if test "x$INOTIFY_EN" != xyes; then
+- AC_MSG_RESULT([no, disabling inotify support])
+- else
+- AC_MSG_RESULT([no])
+- fi
+- INOTIFY_OK=missing
+- ])
+-
+- ])
+-fi
++INOTIFY_OK=yes
+
+ if test "x$INOTIFY_OK" = xyes; then
+ AC_DEFINE([HAVE_INOTIFY], [1], [inotify presence])
diff --git a/recipes/mediatomb/mediatomb_0.11.0.bb b/recipes/mediatomb/mediatomb_0.11.0.bb
new file mode 100644
index 0000000000..f529a55065
--- /dev/null
+++ b/recipes/mediatomb/mediatomb_0.11.0.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "MediaTomb - UPnP AV MediaServer for Linux"
+HOMEPAGE = "http://mediatomb.cc/"
+LICENSE = "GPLv2"
+DEPENDS = "expat ffmpeg sqlite3 libexif js zlib file id3lib"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/mediatomb/mediatomb-${PV}.tar.gz \
+ file://curl.diff;patch=1 \
+ file://inotify.diff;patch=1 \
+ "
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-mysql \
+ --disable-rpl-malloc \
+ --enable-sqlite3 \
+ --enable-libjs \
+ --enable-libmagic \
+ --enable-id3lib \
+ --enable-libexif \
+ --enable-db-autocreate \
+ --disable-largefile \
+ --with-sqlite3-h=${STAGING_INCDIR} \
+ --with-sqlite3-libs=${STAGING_LIBDIR} \
+ --with-magic-h=${STAGING_INCDIR} \
+ --with-magic-libs=${STAGING_LIBDIR} \
+ --with-exif-h=${STAGING_INCDIR} \
+ --with-exif-libs=${STAGING_LIBDIR} \
+ --with-zlib-h=${STAGING_INCDIR} \
+ --with-zlib-libs=${STAGING_LIBDIR} \
+ --with-js-h=${STAGING_INCDIR}/js \
+ --with-js-libs=${STAGING_LIBDIR} \
+ --with-id3lib-h=${STAGING_INCDIR} \
+ --with-id3lib-libs=${STAGING_LIBDIR} \
+ ac_cv_header_sys_inotify_h=yes"
diff --git a/recipes/mediatomb/mediatomb_0.8+0.9.0-pre.bb b/recipes/mediatomb/mediatomb_0.8+0.9.0-pre.bb
new file mode 100644
index 0000000000..c903321b70
--- /dev/null
+++ b/recipes/mediatomb/mediatomb_0.8+0.9.0-pre.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "MediaTomb - UPnP AV MediaServer for Linux"
+HOMEPAGE = "http://mediatomb.cc/"
+LICENSE = "GPLv2"
+DEPENDS = "sqlite3 libexif js zlib file id3lib"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/mediatomb/mediatomb-0.9.0-pre.tar.gz"
+
+S = "${WORKDIR}/${PN}-0.9.0-pre"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-mysql \
+ --disable-rpl-malloc \
+ --enable-sqlite3 \
+ --enable-libjs \
+ --enable-libmagic \
+ --enable-id3lib \
+ --enable-libexif \
+ --disable-largefile \
+ --with-sqlite3-h=${STAGING_INCDIR} \
+ --with-sqlite3-libs=${STAGING_LIBDIR} \
+ --with-magic-h=${STAGING_INCDIR} \
+ --with-magic-libs=${STAGING_LIBDIR} \
+ --with-exif-h=${STAGING_INCDIR} \
+ --with-exif-libs=${STAGING_LIBDIR} \
+ --with-zlib-h=${STAGING_INCDIR} \
+ --with-zlib-libs=${STAGING_LIBDIR} \
+ --with-js-h=${STAGING_INCDIR}/js \
+ --with-js-libs=${STAGING_LIBDIR} \
+ --with-id3lib-h=${STAGING_INCDIR} \
+ --with-id3lib-libs=${STAGING_LIBDIR}"
diff --git a/recipes/mediatomb/mediatomb_0.9.0.bb b/recipes/mediatomb/mediatomb_0.9.0.bb
new file mode 100644
index 0000000000..f3ea9f54dd
--- /dev/null
+++ b/recipes/mediatomb/mediatomb_0.9.0.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "MediaTomb - UPnP AV MediaServer for Linux"
+HOMEPAGE = "http://mediatomb.cc/"
+LICENSE = "GPLv2"
+DEPENDS = "sqlite3 libexif js zlib file id3lib"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/mediatomb/mediatomb-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-mysql \
+ --disable-rpl-malloc \
+ --enable-sqlite3 \
+ --enable-libjs \
+ --enable-libmagic \
+ --enable-id3lib \
+ --enable-libexif \
+ --disable-largefile \
+ --with-sqlite3-h=${STAGING_INCDIR} \
+ --with-sqlite3-libs=${STAGING_LIBDIR} \
+ --with-magic-h=${STAGING_INCDIR} \
+ --with-magic-libs=${STAGING_LIBDIR} \
+ --with-exif-h=${STAGING_INCDIR} \
+ --with-exif-libs=${STAGING_LIBDIR} \
+ --with-zlib-h=${STAGING_INCDIR} \
+ --with-zlib-libs=${STAGING_LIBDIR} \
+ --with-js-h=${STAGING_INCDIR}/js \
+ --with-js-libs=${STAGING_LIBDIR} \
+ --with-id3lib-h=${STAGING_INCDIR} \
+ --with-id3lib-libs=${STAGING_LIBDIR}"
diff --git a/recipes/mediatomb/mediatomb_0.9.1.bb b/recipes/mediatomb/mediatomb_0.9.1.bb
new file mode 100644
index 0000000000..f3ea9f54dd
--- /dev/null
+++ b/recipes/mediatomb/mediatomb_0.9.1.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "MediaTomb - UPnP AV MediaServer for Linux"
+HOMEPAGE = "http://mediatomb.cc/"
+LICENSE = "GPLv2"
+DEPENDS = "sqlite3 libexif js zlib file id3lib"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/mediatomb/mediatomb-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-mysql \
+ --disable-rpl-malloc \
+ --enable-sqlite3 \
+ --enable-libjs \
+ --enable-libmagic \
+ --enable-id3lib \
+ --enable-libexif \
+ --disable-largefile \
+ --with-sqlite3-h=${STAGING_INCDIR} \
+ --with-sqlite3-libs=${STAGING_LIBDIR} \
+ --with-magic-h=${STAGING_INCDIR} \
+ --with-magic-libs=${STAGING_LIBDIR} \
+ --with-exif-h=${STAGING_INCDIR} \
+ --with-exif-libs=${STAGING_LIBDIR} \
+ --with-zlib-h=${STAGING_INCDIR} \
+ --with-zlib-libs=${STAGING_LIBDIR} \
+ --with-js-h=${STAGING_INCDIR}/js \
+ --with-js-libs=${STAGING_LIBDIR} \
+ --with-id3lib-h=${STAGING_INCDIR} \
+ --with-id3lib-libs=${STAGING_LIBDIR}"
diff --git a/recipes/mediatomb/mediatomb_svn.bb b/recipes/mediatomb/mediatomb_svn.bb
new file mode 100644
index 0000000000..0283eb6ae7
--- /dev/null
+++ b/recipes/mediatomb/mediatomb_svn.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "MediaTomb - UPnP AV MediaServer for Linux"
+HOMEPAGE = "http://mediatomb.org/"
+LICENSE = "GPLv2"
+DEPENDS = "sqlite3 libexif js zlib file id3lib"
+PV = "0.8+0.9pre1+svn${SRCDATE}-sqlite"
+PR = "r2"
+
+SRC_URI = "svn://mediatomb.svn.sourceforge.net/svnroot/mediatomb/trunk;proto=https;module=mediatomb"
+
+S = "${WORKDIR}/mediatomb"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-mysql \
+ --disable-rpl-malloc \
+ --enable-sqlite3 \
+ --enable-libjs \
+ --enable-libmagic \
+ --enable-id3lib \
+ --enable-libexif \
+ --disable-largefile \
+ --with-sqlite3-h=${STAGING_INCDIR} \
+ --with-sqlite3-libs=${STAGING_LIBDIR} \
+ --with-magic-h=${STAGING_INCDIR} \
+ --with-magic-libs=${STAGING_LIBDIR} \
+ --with-exif-h=${STAGING_INCDIR} \
+ --with-exif-libs=${STAGING_LIBDIR} \
+ --with-zlib-h=${STAGING_INCDIR} \
+ --with-zlib-libs=${STAGING_LIBDIR} \
+ --with-js-h=${STAGING_INCDIR}/js \
+ --with-js-libs=${STAGING_LIBDIR} \
+ --with-id3lib-h=${STAGING_INCDIR} \
+ --with-id3lib-libs=${STAGING_LIBDIR}"