summaryrefslogtreecommitdiffstats
path: root/recipes/mesa
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/mesa
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/mesa')
-rw-r--r--recipes/mesa/mesa-dri_6.5.2.bb2
-rw-r--r--recipes/mesa/mesa-dri_7.0.3.bb2
-rw-r--r--recipes/mesa/mesa_6.4.1+cvs20060101.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes/mesa/mesa-dri_6.5.2.bb b/recipes/mesa/mesa-dri_6.5.2.bb
index 323d20ff3a..2baa88fb67 100644
--- a/recipes/mesa/mesa-dri_6.5.2.bb
+++ b/recipes/mesa/mesa-dri_6.5.2.bb
@@ -10,7 +10,7 @@ PR = "${INC_PR}.0"
DEPENDS += "libdrm"
# DRI is useless without the kernel drivers
-RRECOMMENDS += " kernel-module-drm kernel-module-radeon "
+RRECOMMENDS_${PN} += " kernel-module-drm kernel-module-radeon "
do_configure() {
cd configs
diff --git a/recipes/mesa/mesa-dri_7.0.3.bb b/recipes/mesa/mesa-dri_7.0.3.bb
index 3ce7d9871d..1893d47159 100644
--- a/recipes/mesa/mesa-dri_7.0.3.bb
+++ b/recipes/mesa/mesa-dri_7.0.3.bb
@@ -11,7 +11,7 @@ PR = "${INC_PR}.0"
DEPENDS += "libdrm"
# DRI is useless without the kernel drivers
-RRECOMMENDS += " kernel-module-drm kernel-module-radeon "
+RRECOMMENDS_${PN} += " kernel-module-drm kernel-module-radeon "
do_configure() {
cd configs
diff --git a/recipes/mesa/mesa_6.4.1+cvs20060101.bb b/recipes/mesa/mesa_6.4.1+cvs20060101.bb
index 0ecd04f9ec..69b1c0c6b5 100644
--- a/recipes/mesa/mesa_6.4.1+cvs20060101.bb
+++ b/recipes/mesa/mesa_6.4.1+cvs20060101.bb
@@ -10,7 +10,7 @@ S = "${WORKDIR}/Mesa"
LICENSE = "LGPL"
-RDEPENDS = "expat"
+RDEPENDS_${PN} = "expat"
DEPENDS = "makedepend-native xf86vidmodeproto glproto virtual/libx11 libxext libxxf86vm libxi libxmu libice"
# gcc-3.4 blows up in gtktext with -frename-registers on arm-linux