aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/meta
diff options
context:
space:
mode:
authorBernhard Kaindl <bernhard.kaindl@gmx.net>2009-11-22 04:45:40 +0000
committerDenys Dmytriyenko <denis@denix.org>2010-02-19 18:10:33 -0500
commit4f0d9f93c1d1ca5d8d3d83dae101891a720b6305 (patch)
tree75d8d81758e777c78831ad6886d427f397bdfb01 /recipes/meta
parent5114a4e19d81882d83149213f040a0d81ad87b0a (diff)
downloadopenembedded-4f0d9f93c1d1ca5d8d3d83dae101891a720b6305.tar.gz
external-toolchain: Really accept toolchains built by meta-toolchain.bb
external-toolchain-generic, external-toolchain: * The current external-toolchain recipes which are documented to accept toolchains built by meta-toolchain actually do not accept such because they expect ${prefix}/package-status to exist which is provieded by the poky toolchains but not the current OE meta-toolchain package. Fix this by also looking for ${prefix}/usr/lib/opkg/status, which is the package-status file of the OE meta-toolchain package. * Also change the error message which is shown when neither file is found more explicit. Cc: Denys Dmytriyenko <denis@denix.org> Signed-off-by: Bernhard Kaindl <bernhard.kaindl@gmx.net> Acked-by: Denys Dmytriyenko <denis@denix.org> external-toolchain-generic.bb | 4 ++-- external-toolchain.bb | 4 ++-- 2 files changed, 4 insertions(+), 4 deletions(-)
Diffstat (limited to 'recipes/meta')
-rw-r--r--recipes/meta/external-toolchain-generic.bb4
-rw-r--r--recipes/meta/external-toolchain.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/recipes/meta/external-toolchain-generic.bb b/recipes/meta/external-toolchain-generic.bb
index 73f823f192..c840301aac 100644
--- a/recipes/meta/external-toolchain-generic.bb
+++ b/recipes/meta/external-toolchain-generic.bb
@@ -22,8 +22,8 @@ PR = "r2"
inherit sdk
do_stage() {
- if [ ! -e ${prefix}/package-status ]; then
- echo "The external toolchain could not be found in ${prefix}!"
+ if [ ! -e ${prefix}/package-status -a ! -e ${prefix}/usr/lib/opkg/status ]; then
+ echo "The package status file of the external toolchain could not be found in ${prefix}!"
exit 1
fi
diff --git a/recipes/meta/external-toolchain.bb b/recipes/meta/external-toolchain.bb
index 4c70054b0f..352126396f 100644
--- a/recipes/meta/external-toolchain.bb
+++ b/recipes/meta/external-toolchain.bb
@@ -21,8 +21,8 @@ PR = "r2"
inherit sdk
do_stage() {
- if [ ! -e ${prefix}/package-status ]; then
- echo "The external toolchain could not be found in ${prefix}!"
+ if [ ! -e ${prefix}/package-status -a ! -e ${prefix}/usr/lib/opkg/status ]; then
+ echo "The package status file of the external toolchain could not be found in ${prefix}!"
exit 1
fi