aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/micro-emacs
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/micro-emacs
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/micro-emacs')
-rw-r--r--recipes/micro-emacs/micro-emacs-20060909/zaurus_make.patch25
-rw-r--r--recipes/micro-emacs/micro-emacs_20060909.bb26
2 files changed, 51 insertions, 0 deletions
diff --git a/recipes/micro-emacs/micro-emacs-20060909/zaurus_make.patch b/recipes/micro-emacs/micro-emacs-20060909/zaurus_make.patch
new file mode 100644
index 0000000000..eeb76964de
--- /dev/null
+++ b/recipes/micro-emacs/micro-emacs-20060909/zaurus_make.patch
@@ -0,0 +1,25 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- me060909/src/zaurus.gmk~zaurus_make 2004-03-27 10:02:09.000000000 -0700
++++ me060909/src/zaurus.gmk 2004-03-29 17:23:12.000000000 -0700
+@@ -67,7 +67,7 @@
+ # termcap
+ test = $(shell echo "main() { printf(\"HW\n\"); }" > _t.c ; $(LD) $(LDFLAGS) -o /dev/null -ltermcap _t.c 2>&1 ; rm _t.c)
+ ifneq "$(strip $(test))" ""
+-CONSOLE_LIBS = -lncurses
++CONSOLE_LIBS = -lncurses -lgcc -lm
+ else
+ CONSOLE_LIBS = -ltermcap
+ endif
+@@ -163,7 +163,7 @@
+
+ mec: $(OBJ_C)
+ $(RM) $@
+- $(LD) $(LDFLAGS) $(LDOPTIMISE) -o $@ $(OBJ_C) $(CONSOLE_LIBS) $(LIBS)
++ $(CC) $(LDFLAGS) $(LDOPTIMISE) -o $@ $(OBJ_C) $(CONSOLE_LIBS) $(LIBS)
+ $(STRIP) $@
+
+ mew: $(OBJ_W)
diff --git a/recipes/micro-emacs/micro-emacs_20060909.bb b/recipes/micro-emacs/micro-emacs_20060909.bb
new file mode 100644
index 0000000000..f980b368b1
--- /dev/null
+++ b/recipes/micro-emacs/micro-emacs_20060909.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Mini-version of emacs, from http://www.jasspa.com"
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "ncurses"
+
+S = "${WORKDIR}/me060909"
+
+SRC_URI = "http://www.jasspa.com/release_${PV}/jasspa-mesrc-${PV}-2.tar.gz \
+ http://www.jasspa.com/release_${PV}/jasspa-memacros-${PV}.tar.gz \
+ file://${FILESDIR}/zaurus_make.patch;patch=1"
+
+do_compile () {
+ oe_runmake -C src -f zaurus.gmk mec
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/jasspa/macros
+ install -m 0755 src/mec ${D}${bindir}/mec
+ install -m 0644 ${WORKDIR}/*.* ${D}${datadir}/jasspa/macros/
+}
+
+PACKAGES += " ${PN}-macros"
+FILES_${PN}-macros = "${datadir}/jasspa"
+