aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/microcom
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/microcom
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/microcom')
-rw-r--r--recipes/microcom/microcom/make.patch44
-rw-r--r--recipes/microcom/microcom_1.02.bb16
2 files changed, 60 insertions, 0 deletions
diff --git a/recipes/microcom/microcom/make.patch b/recipes/microcom/microcom/make.patch
new file mode 100644
index 0000000000..317619b2e5
--- /dev/null
+++ b/recipes/microcom/microcom/make.patch
@@ -0,0 +1,44 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- microcom-1.02-r0/Makefile~make
++++ microcom-1.02-r0/Makefile
+@@ -18,20 +18,30 @@
+ #** Rev. 0.9 - Sept. 1999
+ #** Rev. 0.91 - Jan. 2000 - minor fixes, compiled under Mandrake 6.0
+ #****************************************************************************/
++CC = gcc
++CCLD = gcc
++LDFLAGS =
++CFLAGS = -W -Wall -O2
++
+ microcom: microcom.o mux.o script.o help.o autodet.o
+- gcc -o microcom microcom.o mux.o script.o help.o autodet.o
++ $(CCLD) $(LDFLAGS) -o microcom microcom.o mux.o script.o help.o autodet.o
+
+ autodet.o: autodet.c microcom.h
+- gcc -O -c autodet.c
++ $(CC) $(CFLAGS) -O -c autodet.c
+
+ script.o: script.c script.h microcom.h
+- gcc -O -c script.c
++ $(CC) $(CFLAGS) -O -c script.c
+
+ mux.o: mux.c microcom.h
+- gcc -O -c mux.c
++ $(CC) $(CFLAGS) -O -c mux.c
+
+ microcom.o: microcom.c microcom.h
+- gcc -O -c microcom.c
++ $(CC) $(CFLAGS) -O -c microcom.c
+
+ help.o: help.c microcom.h
+- gcc -O -c help.c
++ $(CC) $(CFLAGS) -O -c help.c
++
++clean:
++ rm -f *.o microcom
++
++distclean: clean
diff --git a/recipes/microcom/microcom_1.02.bb b/recipes/microcom/microcom_1.02.bb
new file mode 100644
index 0000000000..a268eadc23
--- /dev/null
+++ b/recipes/microcom/microcom_1.02.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "microcom is a small minicom-like serial terminal emulator with \
+scripting support."
+LICENSE = "GPL"
+
+# http://microcom.port5.com/m102.tar.gz is no longer available
+#NOTE: this should probably be converted to pull from sourceforge
+# CVS, because openwrt is just another mirror of a file which no
+# longer seems to exist outside mirrors. mirror magic.
+SRC_URI = "http://downloads.openwrt.org/sources/m102.tar.gz \
+ file://make.patch;patch=1"
+S = "${WORKDIR}"
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 microcom ${D}${bindir}/
+}