summaryrefslogtreecommitdiffstats
path: root/recipes/miniinit
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/miniinit
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/miniinit')
-rw-r--r--recipes/miniinit/files/inittab2
-rwxr-xr-xrecipes/miniinit/files/rcS4
-rw-r--r--recipes/miniinit/miniinit.bb23
3 files changed, 29 insertions, 0 deletions
diff --git a/recipes/miniinit/files/inittab b/recipes/miniinit/files/inittab
new file mode 100644
index 0000000000..352f6a4508
--- /dev/null
+++ b/recipes/miniinit/files/inittab
@@ -0,0 +1,2 @@
+::sysinit:/etc/init.d/rcS
+::shutdown:/sbin/halt
diff --git a/recipes/miniinit/files/rcS b/recipes/miniinit/files/rcS
new file mode 100755
index 0000000000..64c7ef64cf
--- /dev/null
+++ b/recipes/miniinit/files/rcS
@@ -0,0 +1,4 @@
+#!/bin/sh
+for i in /etc/rcS.d/S* /etc/rc2.d/S*; do
+ $i start 2>&1
+done | logger -s -p 6 -t ''
diff --git a/recipes/miniinit/miniinit.bb b/recipes/miniinit/miniinit.bb
new file mode 100644
index 0000000000..054c1bdae9
--- /dev/null
+++ b/recipes/miniinit/miniinit.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "minimal init."
+SECTION = "base"
+LICENSE = "GPL"
+
+# SERIAL_CONSOLE is generally defined by the MACHINE .conf.
+# Set PACKAGE_ARCH appropriately.
+PACKAGE_ARCH_${PN} = "${MACHINE_ARCH}"
+
+SRC_URI = "file://rcS file://inittab"
+
+do_install() {
+ install -d ${D}${sysconfdir} \
+ ${D}${sysconfdir}/rcS.d \
+ ${D}${sysconfdir}/rc2.d \
+ ${D}${sysconfdir}/init.d
+
+ install -m 0644 ${WORKDIR}/inittab ${D}${sysconfdir}/inittab
+ install -m 0755 ${WORKDIR}/rcS ${D}${sysconfdir}/init.d
+
+ if [ ! -z "${SERIAL_CONSOLE}" ]; then
+ echo "${SERIAL_CONSOLE}::askfirst:/bin/sh --login" >> ${D}${sysconfdir}/inittab
+ fi
+}