aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mobilemesh/mobilemesh_1.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/mobilemesh/mobilemesh_1.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/mobilemesh/mobilemesh_1.2.bb')
-rw-r--r--recipes/mobilemesh/mobilemesh_1.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/mobilemesh/mobilemesh_1.2.bb b/recipes/mobilemesh/mobilemesh_1.2.bb
new file mode 100644
index 0000000000..df8f2f98bb
--- /dev/null
+++ b/recipes/mobilemesh/mobilemesh_1.2.bb
@@ -0,0 +1,37 @@
+SECTION = "console/network"
+DESCRIPTION = "MobileMesh mobile ad-hoc routing protocol"
+HOMEPAGE = "http://www.mitre.org/work/tech_transfer/mobilemesh/"
+LICENSE = "GPL"
+DEPENDS = "openssl"
+SRC_URI = "http://meshcube.org/download/mobilemesh_1.2.tgz"
+PR = "r1"
+
+S = "${WORKDIR}/mobilemesh"
+
+CXXFLAGS += "-I ."
+LDFLAGS += "-lcrypto -lssl"
+
+do_compile() {
+ oe_runmake depends
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -d ${D}${sysconfdir}/mobilemesh
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${docdir}
+ install -d ${D}${mandir}/man8
+ oe_runmake PREFIX=${TARGET_PREFIX} BINDIR=${D}${sbindir} ETCDIR=${D}${sysconfdir}/mobilemesh install
+ install ${S}/doc/InternetDrafts/draft* ${D}${docdir}
+ #install ${S}/doc/man/mm*.ps ${D}${docdir}
+ install ${S}/doc/man/mm*.pdf ${D}${docdir}
+ install ${S}/doc/man/mm*.8 ${D}${mandir}/man8
+ install ${S}/doc/FAQ ${D}${docdir}
+ install ${S}/doc/INSTALL ${D}${docdir}
+ install ${S}/doc/LICENSE ${D}${docdir}
+ install ${S}/doc/README ${D}${docdir}
+ install ${S}/mobilemesh.init ${D}${sysconfdir}/init.d/mobilemesh
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/mobilemesh/mmrp.conf ${sysconfdir}/mobilemesh/mmdiscover.conf"