aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mozilla/firefox_1.0.7.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/mozilla/firefox_1.0.7.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/mozilla/firefox_1.0.7.bb')
-rw-r--r--recipes/mozilla/firefox_1.0.7.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/mozilla/firefox_1.0.7.bb b/recipes/mozilla/firefox_1.0.7.bb
new file mode 100644
index 0000000000..1b091bef64
--- /dev/null
+++ b/recipes/mozilla/firefox_1.0.7.bb
@@ -0,0 +1,22 @@
+PR = "r2"
+
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
+ file://xptcstubs.patch;patch=1 \
+ file://no-xmb.patch;patch=1 \
+ file://firefox-cc-fix.patch;patch=1 \
+ file://jsautocfg.h \
+ file://extensions-hack.patch;patch=1 \
+ file://firefox-1.0-gcc4-compile.patch;patch=1;pnum=0 \
+ file://xptcinvoke-arm.patch;patch=1 \
+ file://mozilla-eabi.patch;patch=1"
+S = "${WORKDIR}/mozilla"
+
+inherit autotools mozilla
+
+require firefox.inc
+
+EXTRA_OECONF += " --with-gssapi=${STAGING_LIBDIR}/../"
+
+do_compile_prepend() {
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+}