aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mozilla/firefox_3.0.8.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-03-30 15:41:49 +0100
committerGraeme Gregory <dp@xora.org.uk>2009-03-30 15:41:49 +0100
commit80570a8a80155e65f38261514be8102ff0bb62cc (patch)
treeffdd325ae078f0e7d612ee240c4e6671c0fa036f /recipes/mozilla/firefox_3.0.8.bb
parent2263e973b5822e46566d8a5a33d306723617b1cb (diff)
downloadopenembedded-80570a8a80155e65f38261514be8102ff0bb62cc.tar.gz
firefox_3.0.8.bb : add new version, seems to compile with modern gcc
so made it the default.
Diffstat (limited to 'recipes/mozilla/firefox_3.0.8.bb')
-rw-r--r--recipes/mozilla/firefox_3.0.8.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/mozilla/firefox_3.0.8.bb b/recipes/mozilla/firefox_3.0.8.bb
new file mode 100644
index 0000000000..17136d87bf
--- /dev/null
+++ b/recipes/mozilla/firefox_3.0.8.bb
@@ -0,0 +1,41 @@
+DEPENDS += "cairo"
+PR = "r1"
+
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
+ file://jsautocfg.h \
+ file://security-cross.patch;patch=1 \
+ file://jsautocfg-dontoverwrite.patch;patch=1 \
+ file://Bug339782.additional.fix.diff;patch=1 \
+ file://Bug385583.nspr.jmp_buf.eabi.diff;patch=1 \
+ file://Bug405992.atomic.nspr.diff;patch=1 \
+ file://jemalloc-tls.patch;patch=1 \
+ file://0001-Remove-Werror-from-build.patch;patch=1 \
+ file://0002-Fix-security-cross-compile-cpu-detection-error.patch;patch=1 \
+ file://plugins-dir.patch;patch=1 \
+"
+
+S = "${WORKDIR}/mozilla"
+
+inherit mozilla
+require firefox.inc
+
+export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
+FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
+
+do_compile_prepend() {
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+ sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/firefox-${PV}
+ cd dist/sdk/include
+ rm -rf obsolete
+ headers=`find . -name "*.h"`
+ for f in $headers
+ do
+ install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${PV}/
+ done
+ # removes 2 lines that call absent headers
+ sed -e '178,179d' ${STAGING_INCDIR}/firefox-${PV}/nsIServiceManager.h
+}