aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mozilla/firefox_3.1b1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/mozilla/firefox_3.1b1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/mozilla/firefox_3.1b1.bb')
-rw-r--r--recipes/mozilla/firefox_3.1b1.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes/mozilla/firefox_3.1b1.bb b/recipes/mozilla/firefox_3.1b1.bb
new file mode 100644
index 0000000000..7a41491ea7
--- /dev/null
+++ b/recipes/mozilla/firefox_3.1b1.bb
@@ -0,0 +1,47 @@
+DEPENDS += "cairo"
+
+PV = "3.0.1+3.1b1"
+MOZPV = "3.1b1"
+PR = "r1"
+
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/${MOZPV}-candidates/build2/source/firefox-${MOZPV}-source.tar.bz2 \
+ file://jsautocfg.h \
+ file://jsautocfg-dontoverwrite.patch;patch=1 \
+ file://random_to_urandom.diff;patch=1 \
+"
+
+S = "${WORKDIR}/mozilla-central"
+
+DEFAULT_PREFERENCE = "-1"
+
+inherit mozilla
+require firefox.inc
+
+export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
+FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
+
+do_configure_prepend() {
+ sed -i -e s:'head -1':'head -n1':g client.mk
+ oe_runmake -f client.mk CONFIGURE_ARGS="${EXTRA_OECONF}" configure
+}
+
+do_compile_prepend() {
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+ sed -i -e "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" \
+ -e s:'$(OS_TEST)':${TARGET_ARCH}:g \
+ ${S}/security/coreconf/Linux.mk
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/firefox-${MOZPV}
+ cd dist/sdk/include
+ rm -rf obsolete
+ headers=`find . -name "*.h"`
+ for f in $headers
+ do
+ install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${MOZPV}/
+ done
+ # removes 2 lines that call absent headers
+ sed -e '178,179d' ${STAGING_INCDIR}/firefox-${MOZPV}/nsIServiceManager.h
+}
+