aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mozilla/firefox_hg.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-11-02 11:22:10 +0100
committerKoen Kooi <koen@openembedded.org>2009-11-02 13:17:13 +0100
commitb1b029537f885bb27314552f21a159d6b75895d4 (patch)
treee295ee0eb9072cd2d2bf2b4b3ce91bc471983a3f /recipes/mozilla/firefox_hg.bb
parent7e6ad01cd018c8603677712fa082f664d1122734 (diff)
downloadopenembedded-b1b029537f885bb27314552f21a159d6b75895d4.tar.gz
firefox: add 3.5.4
Diffstat (limited to 'recipes/mozilla/firefox_hg.bb')
-rw-r--r--recipes/mozilla/firefox_hg.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes/mozilla/firefox_hg.bb b/recipes/mozilla/firefox_hg.bb
new file mode 100644
index 0000000000..17a46ee1c8
--- /dev/null
+++ b/recipes/mozilla/firefox_hg.bb
@@ -0,0 +1,52 @@
+DESCRIPTION = "Mozilla Mobile browser"
+DEPENDS += "autoconf213-native cairo alsa-lib sqlite3"
+
+PV = "3.4+3.5b4"
+MOZPV = "3.5b4"
+PR = "r0"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "hg://hg.mozilla.org/;module=mozilla-central;rev=8c9a6d851018 \
+ file://jsautocfg.h \
+ file://jsautocfg-dontoverwrite.patch;patch=1 \
+"
+
+S = "${WORKDIR}/mozilla-central"
+
+inherit mozilla
+require firefox.inc
+
+PARALLEL_MAKE = ""
+export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
+FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
+
+export LIBXUL_DIST="${S}/objdir/xulrunner/dist/"
+CFLAGS_append = " -DMOZ_GFX_OPTIMIZE_MOBILE "
+
+do_configure_prepend() {
+ sed -i -e 's:head\ -1:head\ -n1:g' client.mk
+ oe_runmake -f client.mk CONFIGURE_ARGS="${EXTRA_OECONF}" configure
+}
+
+do_compile_prepend() {
+ # A compile time assert is broken:
+ # http://mxr.mozilla.org/mozilla-central/source/nsprpub/pr/include/prlog.h#259
+ for i in $(find ${S} -name "autoconf.mk") ; do
+ sed -i -e s:fsigned-char:fno-signed-char:g $i
+ done
+
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+ sed -i -e "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" \
+ -e s:'$(OS_TEST)':${TARGET_ARCH}:g \
+ ${S}/security/coreconf/Linux.mk
+}
+
+
+do_stage() {
+ :
+}
+
+
+FILES_${PN} += "${libdir}/fennec"
+