aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mozilla
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-03-04 14:49:56 +0100
committerKoen Kooi <koen@openembedded.org>2010-03-04 16:37:23 +0100
commit4d040590a7b3a44a9c18acced263dae350650bb5 (patch)
treec49ab37c1cc1c655d1c68b6770c369245e1e55e0 /recipes/mozilla
parent941aaf1feb776d273ddca8f5e67bcb510811a405 (diff)
downloadopenembedded-4d040590a7b3a44a9c18acced263dae350650bb5.tar.gz
firefox: fix .pc files for 3.5.2 and 3.6, fix up staging a bit
Diffstat (limited to 'recipes/mozilla')
-rw-r--r--recipes/mozilla/firefox-3.5.2/firefox-plugin.pc10
-rw-r--r--recipes/mozilla/firefox-3.5.2/firefox-xpcom.pc13
-rw-r--r--recipes/mozilla/firefox-3.5.2/nspr.pc10
-rw-r--r--recipes/mozilla/firefox-3.6/firefox-plugin.pc10
-rw-r--r--recipes/mozilla/firefox-3.6/firefox-xpcom.pc13
-rw-r--r--recipes/mozilla/firefox-3.6/nspr.pc10
-rw-r--r--recipes/mozilla/firefox.inc13
-rw-r--r--recipes/mozilla/firefox_3.6.bb3
8 files changed, 77 insertions, 5 deletions
diff --git a/recipes/mozilla/firefox-3.5.2/firefox-plugin.pc b/recipes/mozilla/firefox-3.5.2/firefox-plugin.pc
new file mode 100644
index 0000000000..611acd5944
--- /dev/null
+++ b/recipes/mozilla/firefox-3.5.2/firefox-plugin.pc
@@ -0,0 +1,10 @@
+prefix=/usr
+exec_prefix=/usr
+libdir=/usr/lib
+includedir=/usr/include/firefox-3.5.2
+
+Name: Mozilla Plug-In API
+Description: Mozilla Plug-In API
+Version: 3.5
+Requires: firefox-xpcom = 3.5
+Cflags: -I${includedir}/java -I${includedir}/plugin
diff --git a/recipes/mozilla/firefox-3.5.2/firefox-xpcom.pc b/recipes/mozilla/firefox-3.5.2/firefox-xpcom.pc
new file mode 100644
index 0000000000..935d357d84
--- /dev/null
+++ b/recipes/mozilla/firefox-3.5.2/firefox-xpcom.pc
@@ -0,0 +1,13 @@
+prefix=/usr
+exec_prefix=/usr
+libdir=/usr/lib
+includedir=/usr/include
+mozdir=${includedir}/firefox-3.5.2
+idldir=${includedir}/firefox-3.5.2
+
+Name: XPCOM
+Description: The Mozilla Cross Platform Component Library
+Version: 3.5
+Requires: nspr >= 4.8
+Libs: -L${libdir} -lxpcom -Wl,-R${libdir}
+Cflags: -I${mozdir} -I${mozdir}/xpcom -I${mozdir}/string
diff --git a/recipes/mozilla/firefox-3.5.2/nspr.pc b/recipes/mozilla/firefox-3.5.2/nspr.pc
new file mode 100644
index 0000000000..ba3d131978
--- /dev/null
+++ b/recipes/mozilla/firefox-3.5.2/nspr.pc
@@ -0,0 +1,10 @@
+prefix=/usr
+exec_prefix=/usr
+libdir=/usr/lib
+includedir=/usr/include/firefox-3.5.2
+
+Name: NSPR
+Description: The Netscape Portable Runtime
+Version: 4.8
+Libs: -L${libdir} -lplds4 -lplc4 -lnspr4 -lpthread -ldl -Wl,-R${libdir}
+Cflags: -I${includedir}
diff --git a/recipes/mozilla/firefox-3.6/firefox-plugin.pc b/recipes/mozilla/firefox-3.6/firefox-plugin.pc
new file mode 100644
index 0000000000..f6ad141f9f
--- /dev/null
+++ b/recipes/mozilla/firefox-3.6/firefox-plugin.pc
@@ -0,0 +1,10 @@
+prefix=/usr
+exec_prefix=/usr
+libdir=/usr/lib
+includedir=/usr/include/firefox-3.6
+
+Name: Mozilla Plug-In API
+Description: Mozilla Plug-In API
+Version: 3.5
+Requires: firefox-xpcom = 3.6
+Cflags: -I${includedir}/java -I${includedir}/plugin
diff --git a/recipes/mozilla/firefox-3.6/firefox-xpcom.pc b/recipes/mozilla/firefox-3.6/firefox-xpcom.pc
new file mode 100644
index 0000000000..6eb1289cda
--- /dev/null
+++ b/recipes/mozilla/firefox-3.6/firefox-xpcom.pc
@@ -0,0 +1,13 @@
+prefix=/usr
+exec_prefix=/usr
+libdir=/usr/lib
+includedir=/usr/include
+mozdir=${includedir}/firefox-3.6
+idldir=${includedir}/firefox-3.6
+
+Name: XPCOM
+Description: The Mozilla Cross Platform Component Library
+Version: 3.6
+Requires: nspr >= 4.8
+Libs: -L${libdir} -lxpcom -Wl,-R${libdir}
+Cflags: -I${mozdir} -I${mozdir}/xpcom -I${mozdir}/string
diff --git a/recipes/mozilla/firefox-3.6/nspr.pc b/recipes/mozilla/firefox-3.6/nspr.pc
new file mode 100644
index 0000000000..b73ffc04f7
--- /dev/null
+++ b/recipes/mozilla/firefox-3.6/nspr.pc
@@ -0,0 +1,10 @@
+prefix=/usr
+exec_prefix=/usr
+libdir=/usr/lib
+includedir=/usr/include/firefox-3.6
+
+Name: NSPR
+Description: The Netscape Portable Runtime
+Version: 4.8
+Libs: -L${libdir} -lplds4 -lplc4 -lnspr4 -lpthread -ldl -Wl,-R${libdir}
+Cflags: -I${includedir}
diff --git a/recipes/mozilla/firefox.inc b/recipes/mozilla/firefox.inc
index cf429f05eb..024858a64d 100644
--- a/recipes/mozilla/firefox.inc
+++ b/recipes/mozilla/firefox.inc
@@ -48,6 +48,15 @@ do_install() {
grep -Rl app.update.enabled ${D}${libdir}/${PN}-*/ \
| grep '.js$' \
| xargs -n 1 sed -i 's/\(pref("app.update.enabled",\s*\)true)/\1false)/g'
+
+ for pc in ${WORKDIR}/*.pc ; do
+ sed -i s:3.5.2:${PV}:g $pc
+ done
+
+ install -d ${D}${libdir}/pkgconfig
+ install -m 0644 ${WORKDIR}/firefox-plugin.pc ${D}${libdir}/pkgconfig
+ install -m 0644 ${WORKDIR}/firefox-xpcom.pc ${D}${libdir}/pkgconfig
+ install -m 0644 ${WORKDIR}/nspr.pc ${D}${libdir}/pkgconfig
}
pkg_postinst_${PN}() {
@@ -55,10 +64,6 @@ pkg_postinst_${PN}() {
chmod -R a+w ${libdir}/${PN}* ||true
}
-do_stage() {
- autotools_stage_all
-}
-
# Force feed mozilla our ldflags
TARGET_CC_ARCH += " ${LDFLAGS} "
diff --git a/recipes/mozilla/firefox_3.6.bb b/recipes/mozilla/firefox_3.6.bb
index 43e42b731b..573154f3aa 100644
--- a/recipes/mozilla/firefox_3.6.bb
+++ b/recipes/mozilla/firefox_3.6.bb
@@ -1,7 +1,8 @@
DEPENDS += "cairo sqlite3 libnotify"
-PR = "r2"
+PR = "r4"
+# The .pc files below have "3.6" hardcoded, fix that before using them in a newer FF version!
SRC_URI = "ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}.source.tar.bz2;name=archive \
file://jsautocfg.h \
file://security-cross.patch;patch=1 \