aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mozilla
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-03-03 12:05:33 -0700
committerTom Rini <tom_rini@mentor.com>2010-03-03 12:05:33 -0700
commit679a2367acde02f76f43f446c56c1eefed4e69c0 (patch)
treef97b3a6ce9f22fb4ad39e52a43bf560bf5e65c12 /recipes/mozilla
parentb9601a21e733d20d2dbf805609aca4b2cdc57bf1 (diff)
downloadopenembedded-679a2367acde02f76f43f446c56c1eefed4e69c0.tar.gz
firefox: Perform a number of cleanups and fix consistency issues.
- parallel builds need to happen via MOZ_MAKE_FLAGS and it gripes if still passed -jN, so keep the old value before we clear it. - Move the HOST_LIBIDL stuff into configure, otherwise bad things happen when you don't have pkg-config on the build host. - Prior to 3.6, wireless-tools can be, or not be built already and the Necko wifi options deals. With how 3.6 is configured, it must be disabled or DEPENDED on. For consistency, turn it off. - In 3.5 and newer, libnotify can be used, add it to DEPENDS (could be disabled). - Because of both of the above, bump PR. Signed-off-by: Tom Rini <tom_rini@mentor.com> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/mozilla')
-rw-r--r--recipes/mozilla/fennec_hg.bb2
-rw-r--r--recipes/mozilla/firefox-3.5.2/mozconfig1
-rw-r--r--recipes/mozilla/firefox-3.5.4/mozconfig1
-rw-r--r--recipes/mozilla/firefox-3.5.5/mozconfig1
-rw-r--r--recipes/mozilla/firefox-3.6/mozconfig1
-rw-r--r--recipes/mozilla/firefox.inc8
-rw-r--r--recipes/mozilla/firefox_3.0.1.bb1
-rw-r--r--recipes/mozilla/firefox_3.0.4.bb1
-rw-r--r--recipes/mozilla/firefox_3.0.8.bb1
-rw-r--r--recipes/mozilla/firefox_3.1b1.bb1
-rw-r--r--recipes/mozilla/firefox_3.1b2.bb1
-rw-r--r--recipes/mozilla/firefox_3.5.2.bb6
-rw-r--r--recipes/mozilla/firefox_3.5.4.bb5
-rw-r--r--recipes/mozilla/firefox_3.5.5.bb5
-rw-r--r--recipes/mozilla/firefox_3.5b4.bb5
-rw-r--r--recipes/mozilla/firefox_3.6.bb5
-rw-r--r--recipes/mozilla/firefox_hg.bb2
17 files changed, 15 insertions, 32 deletions
diff --git a/recipes/mozilla/fennec_hg.bb b/recipes/mozilla/fennec_hg.bb
index ef4cedd70b..ada5fa8e87 100644
--- a/recipes/mozilla/fennec_hg.bb
+++ b/recipes/mozilla/fennec_hg.bb
@@ -19,8 +19,6 @@ require firefox.inc
DEPENDS += "libnotify autoconf213-native cairo alsa-lib sqlite3"
-PARALLEL_MAKE = ""
-
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
export LIBXUL_DIST="${S}/objdir/xulrunner/dist/"
diff --git a/recipes/mozilla/firefox-3.5.2/mozconfig b/recipes/mozilla/firefox-3.5.2/mozconfig
index d8d3f3923d..7e2ade0b71 100644
--- a/recipes/mozilla/firefox-3.5.2/mozconfig
+++ b/recipes/mozilla/firefox-3.5.2/mozconfig
@@ -26,6 +26,7 @@ ac_add_options --disable-jsd
ac_add_options --disable-installer
ac_add_options --disable-xprint
ac_add_options --disable-necko-disk-cache
+ac_add_options --disable-necko-wifi
ac_add_options --disable-updater
# configure necko to allocate smaller network buffers
diff --git a/recipes/mozilla/firefox-3.5.4/mozconfig b/recipes/mozilla/firefox-3.5.4/mozconfig
index d8d3f3923d..7e2ade0b71 100644
--- a/recipes/mozilla/firefox-3.5.4/mozconfig
+++ b/recipes/mozilla/firefox-3.5.4/mozconfig
@@ -26,6 +26,7 @@ ac_add_options --disable-jsd
ac_add_options --disable-installer
ac_add_options --disable-xprint
ac_add_options --disable-necko-disk-cache
+ac_add_options --disable-necko-wifi
ac_add_options --disable-updater
# configure necko to allocate smaller network buffers
diff --git a/recipes/mozilla/firefox-3.5.5/mozconfig b/recipes/mozilla/firefox-3.5.5/mozconfig
index d8d3f3923d..7e2ade0b71 100644
--- a/recipes/mozilla/firefox-3.5.5/mozconfig
+++ b/recipes/mozilla/firefox-3.5.5/mozconfig
@@ -26,6 +26,7 @@ ac_add_options --disable-jsd
ac_add_options --disable-installer
ac_add_options --disable-xprint
ac_add_options --disable-necko-disk-cache
+ac_add_options --disable-necko-wifi
ac_add_options --disable-updater
# configure necko to allocate smaller network buffers
diff --git a/recipes/mozilla/firefox-3.6/mozconfig b/recipes/mozilla/firefox-3.6/mozconfig
index b561f067b8..883a396e53 100644
--- a/recipes/mozilla/firefox-3.6/mozconfig
+++ b/recipes/mozilla/firefox-3.6/mozconfig
@@ -26,6 +26,7 @@ ac_add_options --disable-jsd
ac_add_options --disable-installer
ac_add_options --disable-xprint
ac_add_options --enable-necko-disk-cache
+ac_add_options --disable-necko-wifi
ac_add_options --disable-updater
# configure necko to allocate smaller network buffers
diff --git a/recipes/mozilla/firefox.inc b/recipes/mozilla/firefox.inc
index b0e79f96c4..cf429f05eb 100644
--- a/recipes/mozilla/firefox.inc
+++ b/recipes/mozilla/firefox.inc
@@ -2,7 +2,6 @@ DESCRIPTION ?= "Browser made by mozilla"
DEPENDS += "alsa-lib"
SRC_URI += "file://mozilla-${PN}.png file://mozilla-${PN}.desktop"
-PARALLEL_MAKE = ""
ARM_INSTRUCTION_SET = "arm"
MOZPV ?= "${PV}"
@@ -31,13 +30,6 @@ FILES_${PN}-dbg += " ${libdir}/${PN}-*/.debug \
${bindir}/.debug \
"
-export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
-
-# Due to sysroot we need to sed out references to the target staging when building the native version of xpidl
-# Symptons of the failure include "gthread.h:344: error: size of array 'type name' is negative"
-export HOST_LIBIDL_CFLAGS = "`${HOST_LIBIDL_CONFIG} --cflags | sed -e s:${STAGING_DIR_TARGET}:${STAGING_DIR_NATIVE}:g`"
-
-
do_install() {
oe_runmake DESTDIR="${D}" destdir="${D}" install
install -d ${D}${datadir}/applications
diff --git a/recipes/mozilla/firefox_3.0.1.bb b/recipes/mozilla/firefox_3.0.1.bb
index ee60fc026e..72c72bd13f 100644
--- a/recipes/mozilla/firefox_3.0.1.bb
+++ b/recipes/mozilla/firefox_3.0.1.bb
@@ -23,7 +23,6 @@ S = "${WORKDIR}/mozilla"
inherit mozilla
require firefox.inc
-export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
do_compile_prepend() {
diff --git a/recipes/mozilla/firefox_3.0.4.bb b/recipes/mozilla/firefox_3.0.4.bb
index 7cfebfc554..f783000d24 100644
--- a/recipes/mozilla/firefox_3.0.4.bb
+++ b/recipes/mozilla/firefox_3.0.4.bb
@@ -23,7 +23,6 @@ DEFAULT_PREFERENCE = "-1"
inherit mozilla
require firefox.inc
-export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
do_compile_prepend() {
diff --git a/recipes/mozilla/firefox_3.0.8.bb b/recipes/mozilla/firefox_3.0.8.bb
index 541a542c92..5ce6f95340 100644
--- a/recipes/mozilla/firefox_3.0.8.bb
+++ b/recipes/mozilla/firefox_3.0.8.bb
@@ -23,7 +23,6 @@ S = "${WORKDIR}/mozilla"
inherit mozilla
require firefox.inc
-export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
do_compile_prepend() {
diff --git a/recipes/mozilla/firefox_3.1b1.bb b/recipes/mozilla/firefox_3.1b1.bb
index 7a41491ea7..54113f4985 100644
--- a/recipes/mozilla/firefox_3.1b1.bb
+++ b/recipes/mozilla/firefox_3.1b1.bb
@@ -17,7 +17,6 @@ DEFAULT_PREFERENCE = "-1"
inherit mozilla
require firefox.inc
-export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
do_configure_prepend() {
diff --git a/recipes/mozilla/firefox_3.1b2.bb b/recipes/mozilla/firefox_3.1b2.bb
index 2d661ea5f9..7be8baa32e 100644
--- a/recipes/mozilla/firefox_3.1b2.bb
+++ b/recipes/mozilla/firefox_3.1b2.bb
@@ -16,7 +16,6 @@ DEFAULT_PREFERENCE = "-1"
inherit mozilla
require firefox.inc
-export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
do_configure_prepend() {
diff --git a/recipes/mozilla/firefox_3.5.2.bb b/recipes/mozilla/firefox_3.5.2.bb
index 3d940d7af5..b6e265b7d3 100644
--- a/recipes/mozilla/firefox_3.5.2.bb
+++ b/recipes/mozilla/firefox_3.5.2.bb
@@ -1,5 +1,6 @@
-DEPENDS += "cairo sqlite3"
-PR = "r3"
+DEPENDS += "cairo sqlite3 libnotify"
+
+PR = "r4"
SRC_URI = "ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
file://jsautocfg.h \
@@ -25,7 +26,6 @@ require firefox.inc
EXTRA_OECONF += " --enable-official-branding "
-export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
do_compile_prepend() {
diff --git a/recipes/mozilla/firefox_3.5.4.bb b/recipes/mozilla/firefox_3.5.4.bb
index 8ba6ba15db..b1b2af372a 100644
--- a/recipes/mozilla/firefox_3.5.4.bb
+++ b/recipes/mozilla/firefox_3.5.4.bb
@@ -1,6 +1,6 @@
-DEPENDS += "cairo sqlite3"
+DEPENDS += "cairo sqlite3 libnotify"
-PR = "r2"
+PR = "r3"
SRC_URI = "ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}.source.tar.bz2 \
file://jsautocfg.h \
@@ -26,7 +26,6 @@ require firefox.inc
EXTRA_OECONF += " --enable-official-branding "
-export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
do_compile_prepend() {
diff --git a/recipes/mozilla/firefox_3.5.5.bb b/recipes/mozilla/firefox_3.5.5.bb
index da54872046..ea3d4fc4b5 100644
--- a/recipes/mozilla/firefox_3.5.5.bb
+++ b/recipes/mozilla/firefox_3.5.5.bb
@@ -1,6 +1,6 @@
-DEPENDS += "cairo sqlite3"
+DEPENDS += "cairo sqlite3 libnotify"
-PR = "r3"
+PR = "r4"
SRC_URI = "ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}.source.tar.bz2 \
file://jsautocfg.h \
@@ -26,7 +26,6 @@ require firefox.inc
EXTRA_OECONF += " --enable-official-branding --disable-crashreporter"
-export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
do_compile_prepend() {
diff --git a/recipes/mozilla/firefox_3.5b4.bb b/recipes/mozilla/firefox_3.5b4.bb
index 4a12329231..0418c3b257 100644
--- a/recipes/mozilla/firefox_3.5b4.bb
+++ b/recipes/mozilla/firefox_3.5b4.bb
@@ -1,8 +1,8 @@
-DEPENDS += "cairo sqlite"
+DEPENDS += "cairo sqlite libnotify"
PV = "3.0.1+3.5b4"
MOZPV = "3.5b4"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/${MOZPV}-candidates/build1/source/firefox-${MOZPV}-source.tar.bz2 \
file://jsautocfg.h \
@@ -16,7 +16,6 @@ DEFAULT_PREFERENCE = "-10"
inherit mozilla
require firefox.inc
-export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
do_configure_prepend() {
diff --git a/recipes/mozilla/firefox_3.6.bb b/recipes/mozilla/firefox_3.6.bb
index 82e92be128..43e42b731b 100644
--- a/recipes/mozilla/firefox_3.6.bb
+++ b/recipes/mozilla/firefox_3.6.bb
@@ -1,6 +1,6 @@
-DEPENDS += "cairo sqlite3"
+DEPENDS += "cairo sqlite3 libnotify"
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}.source.tar.bz2;name=archive \
file://jsautocfg.h \
@@ -28,7 +28,6 @@ require firefox.inc
EXTRA_OECONF += " --enable-official-branding --disable-crashreporter"
-export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
do_compile_prepend() {
diff --git a/recipes/mozilla/firefox_hg.bb b/recipes/mozilla/firefox_hg.bb
index 17a46ee1c8..37bb2608bd 100644
--- a/recipes/mozilla/firefox_hg.bb
+++ b/recipes/mozilla/firefox_hg.bb
@@ -17,8 +17,6 @@ S = "${WORKDIR}/mozilla-central"
inherit mozilla
require firefox.inc
-PARALLEL_MAKE = ""
-export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
export LIBXUL_DIST="${S}/objdir/xulrunner/dist/"