aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mozilla
diff options
context:
space:
mode:
authorThomas B. Ruecker <dm8tbr@qsl.net>2010-05-12 15:52:41 +0200
committerKoen Kooi <koen@openembedded.org>2010-05-12 16:12:10 +0200
commite9f5e8f54a851a4a88c068a3cf4801e89748a2c4 (patch)
treeac997917d414dc1f4f249118bd38a30dfd1f34b5 /recipes/mozilla
parent18993334c37bfc5564e84b1ec543cfbd6e8a6306 (diff)
downloadopenembedded-e9f5e8f54a851a4a88c068a3cf4801e89748a2c4.tar.gz
fennec: rediff the native bpp patch and update .desktop file
Diffstat (limited to 'recipes/mozilla')
-rw-r--r--recipes/mozilla/fennec/mozilla-fennec.desktop2
-rw-r--r--recipes/mozilla/fennec/use-native-bpp.patch44
-rw-r--r--recipes/mozilla/fennec_hg.bb3
3 files changed, 9 insertions, 40 deletions
diff --git a/recipes/mozilla/fennec/mozilla-fennec.desktop b/recipes/mozilla/fennec/mozilla-fennec.desktop
index 5c56d1d21d..6c9bd20a7b 100644
--- a/recipes/mozilla/fennec/mozilla-fennec.desktop
+++ b/recipes/mozilla/fennec/mozilla-fennec.desktop
@@ -1,5 +1,5 @@
[Desktop Entry]
-Version=0.7
+Version=1.1beta1
Encoding=UTF-8
Name=Fennec
Comment=Fennec mobile browser
diff --git a/recipes/mozilla/fennec/use-native-bpp.patch b/recipes/mozilla/fennec/use-native-bpp.patch
index fd3f9b71f8..1ecb9f3922 100644
--- a/recipes/mozilla/fennec/use-native-bpp.patch
+++ b/recipes/mozilla/fennec/use-native-bpp.patch
@@ -1,12 +1,6 @@
-diff -r f603fec24bf7 gfx/thebes/src/gfxPlatformGtk.cpp
---- a/gfx/thebes/src/gfxPlatformGtk.cpp Tue Dec 02 16:05:36 2008 -0500
-+++ b/gfx/thebes/src/gfxPlatformGtk.cpp Tue Dec 02 23:14:03 2008 -0500
-@@ -80,18 +80,23 @@
-
- #define GDK_PIXMAP_SIZE_MAX 32767
-
- #ifndef MOZ_PANGO
- #include <ft2build.h>
+--- a/gfx/thebes/src/gfxPlatformGtk.cpp 2010-04-19 18:02:04.000000000 +0000
++++ b/gfx/thebes/src/gfxPlatformGtk.cpp 2010-04-25 11:36:49.000000000 +0000
+@@ -91,7 +91,12 @@
#include FT_FREETYPE_H
#endif
@@ -14,26 +8,15 @@ diff -r f603fec24bf7 gfx/thebes/src/gfxPlatformGtk.cpp
+#include "nsIPrefBranch.h"
+#include "nsServiceManagerUtils.h"
+
- double gfxPlatformGtk::sDPI = -1.0;
gfxFontconfigUtils *gfxPlatformGtk::sFontconfigUtils = nsnull;
+static PRBool gUseSystemVisualFormat = PR_FALSE;
#ifndef MOZ_PANGO
typedef nsDataHashtable<nsStringHashKey, nsRefPtr<FontFamily> > FontTable;
- static FontTable *gPlatformFonts = NULL;
- static FontTable *gPlatformFontAliases = NULL;
- static FT_Library gPlatformFTLibrary = NULL;
- #endif
-
-@@ -113,16 +118,26 @@ gfxPlatformGtk::gfxPlatformGtk()
- gPlatformFonts = new FontTable();
- gPlatformFonts->Init(100);
- gPlatformFontAliases = new FontTable();
- gPlatformFontAliases->Init(100);
+@@ -127,6 +132,16 @@
+ gCodepointsWithNoFonts = new gfxSparseBitSet();
UpdateFontList();
#endif
-
- InitDPI();
+
+ nsCOMPtr<nsIPrefBranch> prefs = do_GetService(NS_PREFSERVICE_CONTRACTID);
+ if (!prefs)
@@ -47,17 +30,7 @@ diff -r f603fec24bf7 gfx/thebes/src/gfxPlatformGtk.cpp
}
gfxPlatformGtk::~gfxPlatformGtk()
- {
- gfxFontconfigUtils::Shutdown();
- sFontconfigUtils = nsnull;
-
- #ifdef MOZ_PANGO
-@@ -184,18 +199,24 @@ gfxPlatformGtk::CreateOffscreenSurface(c
- // XXX we really need a different interface here, something that passes
- // in more context, including the display and/or target surface type that
- // we should try to match
- Display* display = GDK_DISPLAY();
- if (!display)
+@@ -202,8 +217,14 @@
return nsnull;
GdkPixmap* pixmap = nsnull;
@@ -74,8 +47,3 @@ diff -r f603fec24bf7 gfx/thebes/src/gfxPlatformGtk.cpp
if (xrenderFormat && sizeOk) {
pixmap = gdk_pixmap_new(nsnull, size.width, size.height,
- xrenderFormat->depth);
-
- if (pixmap) {
- gdk_drawable_set_colormap(GDK_DRAWABLE(pixmap), nsnull);
- newSurface = new gfxXlibSurface(display,
diff --git a/recipes/mozilla/fennec_hg.bb b/recipes/mozilla/fennec_hg.bb
index 1e69aed469..15f936b98f 100644
--- a/recipes/mozilla/fennec_hg.bb
+++ b/recipes/mozilla/fennec_hg.bb
@@ -2,11 +2,12 @@ DESCRIPTION = "Mozilla Mobile browser"
PV = "0.9+${MOZPV}"
MOZPV = "1.1b2"
-PR = "r8"
+PR = "r9"
PE = "1"
SRC_URI = "hg://hg.mozilla.org/;module=mozilla-central;rev=060ddfe5aa48 \
hg://hg.mozilla.org/;module=mobile-browser;rev=ad254d8abbc9 \
+ file://use-native-bpp.patch;patch=1 \
file://jsautocfg.h \
file://jsautocfg-dontoverwrite.patch;patch=1 \
"