aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mpeg-encode
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/mpeg-encode
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/mpeg-encode')
-rw-r--r--recipes/mpeg-encode/files/fixup.patch76
-rw-r--r--recipes/mpeg-encode/mpeg-encode_1.5b.bb16
2 files changed, 92 insertions, 0 deletions
diff --git a/recipes/mpeg-encode/files/fixup.patch b/recipes/mpeg-encode/files/fixup.patch
new file mode 100644
index 0000000000..c90f32760a
--- /dev/null
+++ b/recipes/mpeg-encode/files/fixup.patch
@@ -0,0 +1,76 @@
+diff -urN mpeg_encode.old//headers/libpnmrw.h mpeg_encode//headers/libpnmrw.h
+--- mpeg_encode.old//headers/libpnmrw.h 1995-08-09 16:17:41.000000000 +0100
++++ mpeg_encode//headers/libpnmrw.h 2009-02-10 17:06:09.508519503 +0000
+@@ -13,18 +13,7 @@
+ #ifndef _PNMRW_H_
+ #define _PNMRW_H_
+
+-/* CONFIGURE: On some systems, malloc.h doesn't declare these, so we have
+-** to do it. On other systems, for example HP/UX, it declares them
+-** incompatibly. And some systems, for example Dynix, don't have a
+-** malloc.h at all. A sad situation. If you have compilation problems
+-** that point here, feel free to tweak or remove these declarations.
+-*/
+ #include <malloc.h>
+-#if !defined(sco) && !defined(sgi) && !defined(IRIX)
+-extern char* malloc();
+-#endif
+-/* End of configurable definitions. */
+-
+
+ /* Definitions to make PBMPLUS work with either ANSI C or C Classic. */
+
+diff -urN mpeg_encode.old//jpeg/Makefile mpeg_encode//jpeg/Makefile
+--- mpeg_encode.old//jpeg/Makefile 1995-08-05 00:27:00.000000000 +0100
++++ mpeg_encode//jpeg/Makefile 2009-02-10 17:27:20.488862124 +0000
+@@ -20,9 +20,6 @@
+ manprefix =
+ manext = 1
+
+-# The name of your C compiler:
+-CC= gcc
+-
+ # You may need to adjust these cc options:
+ CFLAGS= -O -I$(srcdir)
+ # Generally, we recommend defining any configuration symbols in jconfig.h,
+@@ -49,10 +46,8 @@
+ RM= rm -f
+ # file rename command
+ MV= mv
+-# library (.a) file creation command
+-AR= ar rc
+ # second step in .a creation (use "touch" if not needed)
+-AR2= ranlib
++AR2= $(RANLIB)
+ # installation program
+ INSTALL= /bin/install -c
+ INSTALL_PROGRAM= $(INSTALL)
+@@ -121,7 +116,7 @@
+
+ libjpeg.a: $(LIBOBJECTS)
+ $(RM) libjpeg.a
+- $(AR) libjpeg.a $(LIBOBJECTS)
++ $(AR) rc libjpeg.a $(LIBOBJECTS)
+ $(AR2) libjpeg.a
+
+ cjpeg: $(COBJECTS) libjpeg.a
+diff -urN mpeg_encode.old//libpnmrw.c mpeg_encode//libpnmrw.c
+--- mpeg_encode.old//libpnmrw.c 1995-08-16 23:24:26.000000000 +0100
++++ mpeg_encode//libpnmrw.c 2009-02-10 17:58:49.768855068 +0000
+@@ -28,6 +28,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <errno.h>
+ #include "libpnmrw.h"
+
+ /* if don't have string.h, try strings.h */
+@@ -126,8 +127,6 @@
+ pm_perror( reason )
+ char* reason;
+ {
+- extern char* sys_errlist[];
+- extern int errno;
+ char* e;
+
+ e = sys_errlist[errno];
diff --git a/recipes/mpeg-encode/mpeg-encode_1.5b.bb b/recipes/mpeg-encode/mpeg-encode_1.5b.bb
new file mode 100644
index 0000000000..c350739531
--- /dev/null
+++ b/recipes/mpeg-encode/mpeg-encode_1.5b.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "The Berkeley MPEG Encoder."
+HOMEPAGE = "http://bmrc.berkeley.edu/frame/research/mpeg/mpeg_encode.html"
+SECTION = "multimedia"
+PR = "r0"
+
+SRC_URI = "http://bmrc.berkeley.edu/ftp/pub/multimedia/mpeg/encode/mpeg_encode-${PV}-src.tar.gz \
+ file://fixup.patch;patch=1"
+
+S = "${WORKDIR}/mpeg_encode"
+
+CFLAGS_append += " -I${S}/headers"
+
+do_install() {
+ install -D -m 0755 ${S}/mpeg_encode ${D}${bindir}/mpeg_encode
+ install -D -m 0644 ${S}/mpeg_encode.1 ${D}${mandir}/man1/mpeg_encode.1
+}