summaryrefslogtreecommitdiffstats
path: root/recipes/mtools
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-06-08 14:40:39 +0200
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-06-08 15:13:48 +0200
commit60010f564531dce0f6c81ee52648c75a4d8a4ee9 (patch)
tree66de761d55dd3f99d9cc80974f0606aed675523f /recipes/mtools
parent526f95f33fc2290b219f8134f47e96706e847b4e (diff)
downloadopenembedded-60010f564531dce0f6c81ee52648c75a4d8a4ee9.tar.gz
mtools: change permissions of sources to get quilt apply all patches
Diffstat (limited to 'recipes/mtools')
-rw-r--r--recipes/mtools/mtools_4.0.10.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes/mtools/mtools_4.0.10.bb b/recipes/mtools/mtools_4.0.10.bb
index 5b7f0cd890..b53306a517 100644
--- a/recipes/mtools/mtools_4.0.10.bb
+++ b/recipes/mtools/mtools_4.0.10.bb
@@ -18,3 +18,9 @@ S = "${WORKDIR}/mtools-${PV}"
inherit autotools
EXTRA_OECONF = "--without-x"
+
+do_fix_perms() {
+ chmod 644 ${S}/*.c ${S}/*.h
+}
+
+addtask fix_perms after do_unpack before do_patch