summaryrefslogtreecommitdiffstats
path: root/recipes/mtools
diff options
context:
space:
mode:
authorMichael Smith <msmith@cbnco.com>2009-08-17 03:29:02 +0000
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-08-18 16:12:57 +0200
commitb0f102c5b7c4620fdfe87a02c15cef82332fe147 (patch)
tree641fbf29ff0e57de60e6bca3f2658d905f740455 /recipes/mtools
parent76b6179494fba8599f2cb842c63c2d47a3ec88f2 (diff)
downloadopenembedded-b0f102c5b7c4620fdfe87a02c15cef82332fe147.tar.gz
mtools: don't install-info; fixes build on non-Debian hosts
The install-info installed into staging by dpkg-native looks for /var/backups/infodir.bak and /usr/share/base-files/info.dir on the build system. On Debian/Ubuntu this is benign, but on other distros these files don't exist and the install fails. The info file is still installed, we just don't try to rebuild the nonexistent directory. There are cleaner ways to solve this in the long run: http://dev.openbossa.org/trac/mamona/ticket/139 Signed-off-by: Michael Smith <msmith@cbnco.com> Signed-off-by: Holger Freyther <zecke@selfish.org>
Diffstat (limited to 'recipes/mtools')
-rw-r--r--recipes/mtools/mtools_4.0.10.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes/mtools/mtools_4.0.10.bb b/recipes/mtools/mtools_4.0.10.bb
index b53306a517..18fbb7dbc7 100644
--- a/recipes/mtools/mtools_4.0.10.bb
+++ b/recipes/mtools/mtools_4.0.10.bb
@@ -13,12 +13,15 @@ SRC_URI="http://ftp.gnu.org/gnu/mtools/mtools-${PV}.tar.bz2 \
file://plainio.patch;patch=1 \
file://use-sg_io.patch;patch=1"
-S = "${WORKDIR}/mtools-${PV}"
+PR = "r1"
inherit autotools
EXTRA_OECONF = "--without-x"
+# Don't try to run install-info -- it'll fail on non-Debian build systems.
+EXTRA_OEMAKE = "INSTALL_INFO="
+
do_fix_perms() {
chmod 644 ${S}/*.c ${S}/*.h
}