aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mumpot
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/mumpot
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/mumpot')
-rw-r--r--recipes/mumpot/files/mumpot-cyclemap.desktop8
-rw-r--r--recipes/mumpot/files/mumpot-mapnik.desktop8
-rw-r--r--recipes/mumpot/files/mumpot-tah.desktop8
-rw-r--r--recipes/mumpot/mumpot_0.4.bb20
4 files changed, 44 insertions, 0 deletions
diff --git a/recipes/mumpot/files/mumpot-cyclemap.desktop b/recipes/mumpot/files/mumpot-cyclemap.desktop
new file mode 100644
index 0000000000..495e712bac
--- /dev/null
+++ b/recipes/mumpot/files/mumpot-cyclemap.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Mumpot cyclemap
+Comment=Mumpot cyclemap
+Exec=mumpot-cyclemap
+Terminal=0
+Type=Application
+Categories=X-PIM;GTK;Education;Science;Geography;
+StartupNotify=True
diff --git a/recipes/mumpot/files/mumpot-mapnik.desktop b/recipes/mumpot/files/mumpot-mapnik.desktop
new file mode 100644
index 0000000000..9d852d2577
--- /dev/null
+++ b/recipes/mumpot/files/mumpot-mapnik.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Mumpot Mapnik
+Comment=Mumpot Mapnuk
+Exec=mumpot-mapnik
+Terminal=0
+Type=Application
+Categories=X-PIM;GTK;Education;Science;Geography;
+StartupNotify=True
diff --git a/recipes/mumpot/files/mumpot-tah.desktop b/recipes/mumpot/files/mumpot-tah.desktop
new file mode 100644
index 0000000000..805c1d42d9
--- /dev/null
+++ b/recipes/mumpot/files/mumpot-tah.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Mumpot t@h
+Comment=Mumpot t@h
+Exec=mumpot-tah
+Terminal=0
+Type=Application
+Categories=X-PIM;GTK;Education;Science;Geography;
+StartupNotify=True
diff --git a/recipes/mumpot/mumpot_0.4.bb b/recipes/mumpot/mumpot_0.4.bb
new file mode 100644
index 0000000000..ab9d876902
--- /dev/null
+++ b/recipes/mumpot/mumpot_0.4.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "A map-viewer, simple editor and routing application for OSM maps"
+HOMEPAGE = "http://www.mumpot.org/"
+AUTHOR = "Andreas Kemnade"
+SECTION = "x11/applications"
+LICENSE = "GPLv3"
+DEPENDS = "gtk+ bluez-libs bzip2 libxml2 libpng jpeg"
+
+SRC_URI = "http://www.mumpot.org/download/mumpot-${PV}.tar.gz \
+ file://mumpot-tah.desktop \
+ file://mumpot-mapnik.desktop \
+ file://mumpot-cyclemap.desktop"
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 ${WORKDIR}/mumpot-tah.desktop ${D}${datadir}/applications/mumpot-tah.desktop
+ install -m 0644 ${WORKDIR}/mumpot-mapnik.desktop ${D}${datadir}/applications/mumpot-mapnik.desktop
+ install -m 0644 ${WORKDIR}/mumpot-cyclemap.desktop ${D}${datadir}/applications/mumpot-cyclemap.desktop
+}