aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mupdf/mupdf_0.6.bb
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2010-10-30 21:42:42 +0300
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-11-03 16:51:54 +0100
commit9660ed039a775334d49f696d46b65fc338ae4382 (patch)
treed5a7fe8f82459c3ed36496bf23cf870b082b7a14 /recipes/mupdf/mupdf_0.6.bb
parent9952e0bc74c7001e90cd678127a7ce3379ff587f (diff)
downloadopenembedded-9660ed039a775334d49f696d46b65fc338ae4382.tar.gz
mupdf: Add custom desktop file for Jlime.
* Added mupdf.desktop * Modified mupdf-0.6 recipe for mupdf.desktop. Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
Diffstat (limited to 'recipes/mupdf/mupdf_0.6.bb')
-rw-r--r--recipes/mupdf/mupdf_0.6.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes/mupdf/mupdf_0.6.bb b/recipes/mupdf/mupdf_0.6.bb
index 88e7868fca..31d4ed2856 100644
--- a/recipes/mupdf/mupdf_0.6.bb
+++ b/recipes/mupdf/mupdf_0.6.bb
@@ -10,7 +10,7 @@ SRC_URI = "http://mupdf.com/download/source/${PN}-${PV}.tar.gz \
file://mupdf_fix_endianness.patch \
file://Makerules"
-SRC_URI_append_jlime = " file://keybindings.patch "
+SRC_URI_append_jlime = " file://keybindings.patch file://mupdf.desktop "
S = "${WORKDIR}/mupdf"
@@ -36,6 +36,10 @@ do_configure() {
echo "CFLAGS += -DNOCJK" >> ${S}/Makerules
}
+do_configure_append_jlime() {
+ mv ${WORKDIR}/mupdf.desktop ${S}/debian/
+}
+
do_compile() {
# mupdf uses couple of tools for code generation during build process
# so we need to compile them first with host compiler