aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mupdf
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2010-10-30 21:42:39 +0300
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-11-03 16:51:22 +0100
commitd59e6936d545b9273a3fc97c190c57462acbbef2 (patch)
treeb3cfde461930f817fa260e84c7a6cb541a7a9524 /recipes/mupdf
parent3d79c824d105c90fc5d9c393eeaa0f28769acf88 (diff)
downloadopenembedded-d59e6936d545b9273a3fc97c190c57462acbbef2.tar.gz
mupdf: Add keybindings.patch, disable ccache which breaks compilation.
* Added keybindings.patch which is jlime-specific, and changes some keys to better fit our keyboard layouts. * Added CCACHE = "", disabling ccache because compilation is broken with ccache installed. Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
Diffstat (limited to 'recipes/mupdf')
-rw-r--r--recipes/mupdf/mupdf-0.6/keybindings.patch77
-rw-r--r--recipes/mupdf/mupdf_0.6.bb5
2 files changed, 82 insertions, 0 deletions
diff --git a/recipes/mupdf/mupdf-0.6/keybindings.patch b/recipes/mupdf/mupdf-0.6/keybindings.patch
new file mode 100644
index 0000000000..62c9526b60
--- /dev/null
+++ b/recipes/mupdf/mupdf-0.6/keybindings.patch
@@ -0,0 +1,77 @@
+diff -ru mupdf.orig/apps/pdfapp.c mupdf/apps/pdfapp.c
+--- mupdf.orig/apps/pdfapp.c 2010-05-27 19:31:10.000000000 +0300
++++ mupdf/apps/pdfapp.c 2010-10-18 16:20:24.709000664 +0300
+@@ -444,7 +444,8 @@
+ * Back and forth ...
+ */
+
+- case 'p':
++ case 'b':
++ case '\b':
+ panto = PAN_TO_BOTTOM;
+ if (app->numberlen > 0)
+ app->pageno -= atoi(app->number);
+@@ -452,7 +453,8 @@
+ app->pageno--;
+ break;
+
+- case 'n':
++ case 'f':
++ case ' ':
+ panto = PAN_TO_TOP;
+ if (app->numberlen > 0)
+ app->pageno += atoi(app->number);
+@@ -460,8 +462,7 @@
+ app->pageno++;
+ break;
+
+- case 'b':
+- case '\b':
++ case 'p':
+ panto = DONT_PAN;
+ if (app->numberlen > 0)
+ app->pageno -= atoi(app->number);
+@@ -469,8 +470,7 @@
+ app->pageno--;
+ break;
+
+- case 'f':
+- case ' ':
++ case 'n':
+ panto = DONT_PAN;
+ if (app->numberlen > 0)
+ app->pageno += atoi(app->number);
+@@ -480,7 +480,7 @@
+
+ case 'B':
+ panto = PAN_TO_TOP; app->pageno -= 10; break;
+- case 'F':
++ case 'N':
+ panto = PAN_TO_TOP; app->pageno += 10; break;
+
+ /*
+diff -ru mupdf.orig/apps/x11_main.c mupdf/apps/x11_main.c
+--- mupdf.orig/apps/x11_main.c 2010-05-31 01:27:37.000000000 +0300
++++ mupdf/apps/x11_main.c 2010-10-18 16:14:21.891309637 +0300
+@@ -639,17 +639,17 @@
+ break;
+
+ case XK_Left:
+- len = 1; buf[0] = 'p';
++ len = 1; buf[0] = ',';
+ break;
+ case XK_Right:
+- len = 1; buf[0] = 'n';
++ len = 1; buf[0] = '.';
+ break;
+
+ case XK_Page_Up:
+- len = 1; buf[0] = 'b';
++ len = 1; buf[0] = '+';
+ break;
+ case XK_Page_Down:
+- len = 1; buf[0] = ' ';
++ len = 1; buf[0] = '-';
+ break;
+ }
+ if (len)
diff --git a/recipes/mupdf/mupdf_0.6.bb b/recipes/mupdf/mupdf_0.6.bb
index 16d49d8ff1..88e7868fca 100644
--- a/recipes/mupdf/mupdf_0.6.bb
+++ b/recipes/mupdf/mupdf_0.6.bb
@@ -10,6 +10,8 @@ SRC_URI = "http://mupdf.com/download/source/${PN}-${PV}.tar.gz \
file://mupdf_fix_endianness.patch \
file://Makerules"
+SRC_URI_append_jlime = " file://keybindings.patch "
+
S = "${WORKDIR}/mupdf"
PACKAGES =+ "${PN}-tools ${PN}-tools-doc "
@@ -22,6 +24,9 @@ FILES_${PN}-tools-doc = "${mandir}/man1/pdfclean.1 ${mandir}/man1/pdfdraw.1 \
# so we need to provide some safe settings
FULL_OPTIMIZATION = "-O2"
+# Compilation is broken with ccache so we disable it.
+CCACHE = ""
+
do_configure() {
cp ${WORKDIR}/Makerules ${S}/Makerules