aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mypaint
diff options
context:
space:
mode:
authorChristian Charreyre <christian.charreyre@cioinfoindus.fr>2011-05-02 19:40:39 +0200
committerPaul Menzel <paulepanter@users.sourceforge.net>2011-05-18 01:04:53 +0200
commit29e70a3033b053e9863552ee1189f474852eb974 (patch)
treeb92a6017402a347fc1d3c54aef49aadf64996421 /recipes/mypaint
parent562661512f456e27870f1d5a3aace88915b3604c (diff)
downloadopenembedded-29e70a3033b053e9863552ee1189f474852eb974.tar.gz
mypaint: Add version 0.9.1 (initial recipe)
This version is build tested using `angstrom-2008.1`, `angstrom-2010.x` and `minimal{,-uclibc}` and run tested using `angstrom-2008.1` each time for `MACHINE = "beagleboard"`. Upstream’s licensing information is ambiguous. The header files do not match what is written in `LICENSE` or `COPYING` [1–5]. Debian’s copyright document [6] is taken as a reference. [1] http://gitorious.org/mypaint/mypaint/blobs/master/LICENSE [2] http://gitorious.org/mypaint/mypaint/blobs/master/COPYING [3] http://gitorious.org/mypaint/mypaint/blobs/master/gui/application.py [4] http://gitorious.org/mypaint/mypaint/blobs/master/brushlib/COPYING [5] http://gitorious.org/mypaint/mypaint/blobs/master/brushlib/brush.hpp [6] http://packages.debian.org/changelogs/pool/main/m/mypaint/mypaint_0.9.1-1/mypaint.copyright Signed-off-by: Christian Charreyre <christian.charreyre@cioinfoindus.fr> Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
Diffstat (limited to 'recipes/mypaint')
-rw-r--r--recipes/mypaint/files/scons-adapt.patch50
-rw-r--r--recipes/mypaint/mypaint_0.9.1.bb37
2 files changed, 87 insertions, 0 deletions
diff --git a/recipes/mypaint/files/scons-adapt.patch b/recipes/mypaint/files/scons-adapt.patch
new file mode 100644
index 0000000000..8152c34b87
--- /dev/null
+++ b/recipes/mypaint/files/scons-adapt.patch
@@ -0,0 +1,50 @@
+Author: Christian Charreyre <christian.charreyre@cioinfoindus.fr>
+
+Adapt scons to OE
+Index: mypaint-0.9.1/lib/SConscript
+===================================================================
+--- mypaint-0.9.1.orig/lib/SConscript 2011-04-21 11:31:29.000000000 +0200
++++ mypaint-0.9.1/lib/SConscript 2011-04-21 11:35:30.000000000 +0200
+@@ -1,5 +1,11 @@
+ Import('env')
+-import sys
++import sys, os
++env.Replace(SHCXX = os.environ['CXX'])
++env.Replace(SHLINK = os.environ['CXX'])
++env.Replace(LDMODULEFLAGS = os.environ['TARGET_LDFLAGS'])
++env.Append(LDMODULEFLAGS = ['-Wl,--hash-style=gnu'])
++env.Append(LDMODULEFLAGS = ['-shared'])
++env.Replace(PATH = os.environ['PATH'])
+
+ # For the record: I know that scons supports swig. But it doesn't scan for #include in the generated code.
+ #
+Index: mypaint-0.9.1/SConstruct
+===================================================================
+--- mypaint-0.9.1.orig/SConstruct 2011-03-04 15:44:59.000000000 +0100
++++ mypaint-0.9.1/SConstruct 2011-05-02 17:21:17.000000000 +0200
+@@ -11,13 +11,6 @@
+ if sys.platform == "win32":
+ python = 'python' # usually no versioned binaries on Windows
+
+-try:
+- import numpy
+-except ImportError:
+- print 'You need to have numpy installed.'
+- print
+- raise
+-
+ SConsignFile() # no .scsonsign into $PREFIX please
+
+ if sys.platform == "darwin":
+@@ -40,8 +33,9 @@
+
+ env.Append(CXXFLAGS=' -Wall -Wno-sign-compare -Wno-write-strings')
+
+-# Get the numpy include path (for numpy/arrayobject.h).
+-numpy_path = numpy.get_include()
++# Defines the numpy include path (for numpy/arrayobject.h).
++# This is specefic to OE, to avoid to build python-numpy-native
++numpy_path = os.environ['STAGING_DIR_TARGET']+os.environ['PYTHON_SITEPACKAGES_DIR']+'/numpy/core/include'
+ env.Append(CPPPATH=numpy_path)
+
+
diff --git a/recipes/mypaint/mypaint_0.9.1.bb b/recipes/mypaint/mypaint_0.9.1.bb
new file mode 100644
index 0000000000..378083763b
--- /dev/null
+++ b/recipes/mypaint/mypaint_0.9.1.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "drawing program with dynamic brushes for graphic tablets"
+HOMEPAGE = "http://mypaint.info/"
+SECTION = "x11/applications"
+PRIORITY = "optional"
+LICENSE = "GPLv2 GPLv2+ LGPLv2+"
+
+DEPENDS = "glib-2.0 libpng python-numpy swig-native"
+RDEPENDS_${PN} = "python-image python-json"
+
+SRC_URI = "http://download.gna.org/mypaint/${PN}-${PV}.tar.bz2 \
+ file://scons-adapt.patch \
+"
+
+SRC_URI[md5sum] = "6249a16359a438d6dc658f5765b35515"
+SRC_URI[sha256sum] = "407b599f62fb0d6e711fee57d22e64d3aec88825364fb5f7f73b9f0940aa7aed"
+
+inherit distutils scons
+
+do_compile() {
+ STAGING_INCDIR=${STAGING_INCDIR} \
+ STAGING_LIBDIR=${STAGING_LIBDIR} \
+ STAGING_DIR_TARGET=${STAGING_DIR_TARGET} \
+ PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR} \
+ BUILD_SYS=${BUILD_SYS} \
+ HOST_SYS=${HOST_SYS} \
+ PATH=${PATH} scons_do_compile
+}
+
+do_install() {
+ STAGING_DIR_TARGET=${STAGING_DIR_TARGET} \
+ PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR} \
+ BUILD_SYS=${BUILD_SYS} \
+ HOST_SYS=${HOST_SYS} \
+ scons_do_install
+}
+
+FILES_${PN} += "${datadir}"