aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mysql/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/mysql/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/mysql/files')
-rw-r--r--recipes/mysql/files/autofoo.patch319
-rw-r--r--recipes/mysql/files/configure-ps-cache-check.patch27
-rw-r--r--recipes/mysql/files/fix_host_path.patch37
-rw-r--r--recipes/mysql/files/gen_lex_hash.patch19
-rw-r--r--recipes/mysql/files/my.cnf21
-rw-r--r--recipes/mysql/files/mysqld.sh20
6 files changed, 443 insertions, 0 deletions
diff --git a/recipes/mysql/files/autofoo.patch b/recipes/mysql/files/autofoo.patch
new file mode 100644
index 0000000000..669393a23b
--- /dev/null
+++ b/recipes/mysql/files/autofoo.patch
@@ -0,0 +1,319 @@
+diff -aurp mysql-4.1.22.old/acinclude.m4 mysql-4.1.22/acinclude.m4
+--- mysql-4.1.22.old/acinclude.m4 2008-09-18 13:00:13.000000000 -0500
++++ mysql-4.1.22/acinclude.m4 2008-09-18 12:58:41.000000000 -0500
+@@ -1,5 +1,88 @@
+ # Local macros for automake & autoconf
+
++AH_TEMPLATE([SPRINTF_RETURNS_INT], [sprintf returns an int])
++AH_TEMPLATE([SPRINTF_RETURNS_PTR], [sprintf returns a char *])
++AH_TEMPLATE([SPRINTF_RETURNS_GARBAGE], [sprintf returns something unknown to us])
++
++AC_DEFUN([MYSQL_SPRINTF_RET], [
++ AC_CACHE_CHECK([return type of sprintf],
++ [mysql_cv_func_sprintf_ret], [
++ old_CFLAGS="$CFLAGS"
++ CFLAGS="$CFLAGS -Werror"
++ AC_COMPILE_IFELSE([
++#include <stdio.h>
++int sprintf(char *str, const char *format, ...);
++ ], [mysql_cv_func_sprintf_ret=int],
++ AC_COMPILE_IFELSE([
++#include <stdio.h>
++char * sprintf(char *str, const char *format, ...);
++ ], [mysql_cv_func_sprintf_ret=ptr],
++ [mysql_cv_func_sprintf_ret=unknown])
++ )
++ CFLAGS="$old_CFLAGS"
++ ])
++ if test x"$mysql_cv_func_sprintf_ret" = "xint"; then
++ AC_DEFINE([SPRINTF_RETURNS_INT], [1])
++ elif test x"$mysql_cv_func_sprintf_ret" = "xptr"; then
++ AC_DEFINE([SPRINTF_RETURNS_PTR], [1])
++ else
++ AC_DEFINE([SPRINTF_RETURNS_GARBAGE], [1])
++ fi
++])
++
++# _MYSQL_FUNC_ATOMIC_ADD
++# ----------------------
++# Check for Linux specific atomic_add function
++AC_DEFUN([_MYSQL_FUNC_ATOMIC_ADD],
++[AC_CACHE_CHECK([for atomic_add], [mysql_cv_func_atomic_add],
++[AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <asm/atomic.h>]],
++ [
++int main()
++{
++ atomic_t v;
++
++ atomic_set(&v, 23);
++ atomic_add(5, &v);
++ return atomic_read(&v) == 28 ? 0 : -1;
++}
++ ])],
++ [mysql_cv_func_atomic_add=yes],
++ [mysql_cv_func_atomic_add=no])])
++ if test x"$mysql_func_atomic_add" = "xyes"; then
++ AC_DEFINE([HAVE_ATOMIC_ADD], [1])
++ fi[]dnl
++])# _MYSQL_FUNC_ATOMIC_ADD
++
++# _MYSQL_FUNC_ATOMIC_SUB
++# ----------------------
++# Check for Linux specific atomic_sub function
++AC_DEFUN([_MYSQL_FUNC_ATOMIC_SUB],
++[AC_CACHE_CHECK([for atomic_sub], [mysql_cv_func_atomic_sub],
++[AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <asm/atomic.h>]],
++ [
++int main()
++{
++ atomic_t v;
++
++ atomic_set(&v, 23);
++ atomic_sub(5, &v);
++ return atomic_read(&v) == 18 ? 0 : -1;
++}
++ ])],
++ [mysql_cv_func_atomic_sub=yes],
++ [mysql_cv_func_atomic_sub=no])])
++ if test x"$mysql_func_atomic_sub" = "xyes"; then
++ AC_DEFINE([HAVE_ATOMIC_SUB], [1])
++ fi[]dnl
++])# _MYSQL_FUNC_ATOMIC_SUB
++
++# MYSQL_FUNCS_ATOMIC
++# ------------------
++# Check for Linux specific atomic add and sub functions
++AC_DEFUN([MYSQL_FUNCS_ATOMIC], [
++ AC_REQUIRE([_MYSQL_FUNC_ATOMIC_ADD])dnl
++ AC_REQUIRE([_MYSQL_FUNC_ATOMIC_SUB])dnl
++])# MYSQL_FUNCS_ATOMIC
+
+ AC_DEFUN([MYSQL_CHECK_READLINE_DECLARES_HIST_ENTRY], [
+ AC_CACHE_CHECK([HIST_ENTRY is declared in readline/readline.h], mysql_cv_hist_entry_declared,
+@@ -344,7 +427,7 @@ dnl ------------------------------------
+ AC_DEFUN([MYSQL_CHECK_ULONG],
+ [AC_MSG_CHECKING(for type ulong)
+ AC_CACHE_VAL(ac_cv_ulong,
+-[AC_TRY_RUN([#include <stdio.h>
++[AC_TRY_LINK([#include <stdio.h>
+ #include <sys/types.h>
+ main()
+ {
+@@ -362,7 +445,7 @@ fi
+ AC_DEFUN([MYSQL_CHECK_UCHAR],
+ [AC_MSG_CHECKING(for type uchar)
+ AC_CACHE_VAL(ac_cv_uchar,
+-[AC_TRY_RUN([#include <stdio.h>
++[AC_TRY_LINK([#include <stdio.h>
+ #include <sys/types.h>
+ main()
+ {
+@@ -380,7 +463,7 @@ fi
+ AC_DEFUN([MYSQL_CHECK_UINT],
+ [AC_MSG_CHECKING(for type uint)
+ AC_CACHE_VAL(ac_cv_uint,
+-[AC_TRY_RUN([#include <stdio.h>
++[AC_TRY_LINK([#include <stdio.h>
+ #include <sys/types.h>
+ main()
+ {
+@@ -399,7 +482,7 @@ fi
+ AC_DEFUN([MYSQL_CHECK_IN_ADDR_T],
+ [AC_MSG_CHECKING(for type in_addr_t)
+ AC_CACHE_VAL(ac_cv_in_addr_t,
+-[AC_TRY_RUN([#include <stdio.h>
++[AC_TRY_LINK([#include <stdio.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+@@ -460,7 +543,7 @@ fi
+ AC_DEFUN([MYSQL_CHECK_FP_EXCEPT],
+ [AC_MSG_CHECKING(for type fp_except)
+ AC_CACHE_VAL(ac_cv_fp_except,
+-[AC_TRY_RUN([#include <stdio.h>
++[AC_TRY_LINK([#include <stdio.h>
+ #include <sys/types.h>
+ #include <ieeefp.h>
+ main()
+diff -aurp mysql-4.1.22.old/configure.in mysql-4.1.22/configure.in
+--- mysql-4.1.22.old/configure.in 2008-09-18 13:00:14.000000000 -0500
++++ mysql-4.1.22/configure.in 2008-09-18 12:54:00.000000000 -0500
+@@ -236,8 +236,6 @@ then
+ else
+ AC_PATH_PROG(AS, as, as)
+ fi
+-# Still need ranlib for readline; local static use only so no libtool.
+-AC_PROG_RANLIB
+ # We use libtool
+ #AC_LIBTOOL_WIN32_DLL
+ AC_PROG_LIBTOOL
+@@ -258,44 +256,7 @@ AC_PROG_YACC
+ AC_CHECK_PROG(PDFMANUAL, pdftex, manual.pdf)
+ AC_CHECK_PROG(DVIS, tex, manual.dvi)
+
+-AC_MSG_CHECKING("return type of sprintf")
+-
+-#check the return type of sprintf
+-case $SYSTEM_TYPE in
+- *netware*)
+- AC_DEFINE(SPRINTF_RETURNS_INT, [1]) AC_MSG_RESULT("int")
+- ;;
+- *)
+-AC_TRY_RUN([
+- int main()
+- {
+- char* s = "hello";
+- char buf[6];
+- if((int)sprintf(buf, s) == strlen(s))
+- return 0;
+-
+- return -1;
+- }
+- ],
+- [AC_DEFINE(SPRINTF_RETURNS_INT, [1], [POSIX sprintf])
+- AC_MSG_RESULT("int")],
+- [AC_TRY_RUN([
+- int main()
+- {
+- char* s = "hello";
+- char buf[6];
+- if((char*)sprintf(buf,s) == buf + strlen(s))
+- return 0;
+- return -1;
+- } ],
+- [AC_DEFINE(SPRINTF_RETURNS_PTR, [1], [Broken sprintf])
+- AC_MSG_RESULT("ptr")],
+- [AC_DEFINE(SPRINTF_RETURNS_GARBAGE, [1], [Broken sprintf])
+- AC_MSG_RESULT("garbage")])
+- ])
+- ;;
+-esac
+-
++MYSQL_SPRINTF_RET
+
+ # option, cache_name, variable,
+ # code to execute if yes, code to exectute if fail
+@@ -878,47 +839,7 @@ struct request_info *req;
+ AC_SUBST(WRAPLIBS)
+
+ if test "$TARGET_LINUX" = "true"; then
+- AC_MSG_CHECKING([for atomic operations])
+-
+- AC_LANG_SAVE
+- AC_LANG_CPLUSPLUS
+-
+- atom_ops=
+- AC_TRY_RUN([
+-#include <asm/atomic.h>
+-int main()
+-{
+- atomic_t v;
+-
+- atomic_set(&v, 23);
+- atomic_add(5, &v);
+- return atomic_read(&v) == 28 ? 0 : -1;
+-}
+- ],
+- [AC_DEFINE([HAVE_ATOMIC_ADD], [1],
+- [atomic_add() from <asm/atomic.h> (Linux only)])
+- atom_ops="${atom_ops}atomic_add "],
+- )
+- AC_TRY_RUN([
+-#include <asm/atomic.h>
+-int main()
+-{
+- atomic_t v;
+-
+- atomic_set(&v, 23);
+- atomic_sub(5, &v);
+- return atomic_read(&v) == 18 ? 0 : -1;
+-}
+- ],
+- [AC_DEFINE([HAVE_ATOMIC_SUB], [1],
+- [atomic_sub() from <asm/atomic.h> (Linux only)])
+- atom_ops="${atom_ops}atomic_sub "],
+- )
+-
+- if test -z "$atom_ops"; then atom_ops="no"; fi
+- AC_MSG_RESULT($atom_ops)
+-
+- AC_LANG_RESTORE
++ MYSQL_FUNC_ATOMIC
+
+ AC_ARG_WITH(pstack,
+ [ --with-pstack Use the pstack backtrace library],
+@@ -971,13 +892,13 @@ fi
+ # Later in this script LIBS will be augmented with a threads library.
+ NON_THREADED_LIBS="$LIBS"
+
+-AC_MSG_CHECKING([for int8])
++AC_CACHE_CHECK([for int8], [mysql_cv_type_int8], [
+ case $SYSTEM_TYPE in
+ *netware)
+ AC_MSG_RESULT([no])
+ ;;
+ *)
+-AC_TRY_RUN([
++AC_LINK_IFELSE([AC_LANG_PROGRAM([[
+ #ifdef HAVE_STDLIB_H
+ #include <stdlib.h>
+ #endif
+@@ -988,22 +909,21 @@ AC_TRY_RUN([
+
+ #ifdef HAVE_SYS_TYPES_H
+ #include <sys/types.h>
+-#endif
+-
++#endif]], [
+ int main()
+ {
+ int8 i;
+ return 0;
+-}
+-],
+-[AC_DEFINE([HAVE_INT_8_16_32], [1],
+- [whether int8, int16 and int32 types exist])
+-AC_MSG_RESULT([yes])],
+-[AC_MSG_RESULT([no])]
+-)
++}])], [mysql_cv_type_int8=yes], [mysql_cv_type_int8=no])
+ ;;
+ esac
+
++if test x"$mysql_cv_type_int8" = "xyes"; then
++ AC_DEFINE([HAVE_INT_8_16_32], [1],
++ [whether int8, int16 and int32 types exist])
++fi
++])
++
+ #
+ # Some system specific hacks
+ #
+@@ -1814,7 +1734,7 @@ then
+ AC_MSG_ERROR("MySQL needs a long long type.")
+ fi
+ # off_t is not a builtin type
+-MYSQL_CHECK_SIZEOF(off_t, 4)
++AC_CHECK_SIZEOF(off_t, 4)
+ if test "$ac_cv_sizeof_off_t" -eq 0
+ then
+ AC_MSG_ERROR("MySQL needs a off_t type.")
+diff -aurp mysql-4.1.22.old/innobase/configure.in mysql-4.1.22/innobase/configure.in
+--- mysql-4.1.22.old/innobase/configure.in 2008-09-18 13:00:14.000000000 -0500
++++ mysql-4.1.22/innobase/configure.in 2008-09-18 12:55:39.000000000 -0500
+@@ -3,6 +3,7 @@ AC_INIT
+ AC_CANONICAL_SYSTEM
+ AM_MAINTAINER_MODE
+ AM_CONFIG_HEADER(ib_config.h)
++AC_CONFIG_AUX_DIR([..])
+ AM_INIT_AUTOMAKE(ib, 0.90)
+
+ # This is need before AC_PROG_CC
+@@ -32,7 +33,6 @@ CFLAGS="$CFLAGS "
+ CXXFLAGS="$CXXFLAGS "
+
+ AC_PROG_CC
+-AC_PROG_RANLIB
+ AC_PROG_INSTALL
+ AC_PROG_LIBTOOL
+ AC_CHECK_HEADERS(aio.h sched.h)
diff --git a/recipes/mysql/files/configure-ps-cache-check.patch b/recipes/mysql/files/configure-ps-cache-check.patch
new file mode 100644
index 0000000000..3b5b3fd063
--- /dev/null
+++ b/recipes/mysql/files/configure-ps-cache-check.patch
@@ -0,0 +1,27 @@
+Index: mysql-4.1.22/configure.in
+===================================================================
+--- mysql-4.1.22.orig/configure.in 2009-01-28 16:33:28.000000000 +0000
++++ mysql-4.1.22/configure.in 2009-01-28 16:43:26.000000000 +0000
+@@ -471,8 +471,8 @@
+
+ # Lock for PS
+ AC_PATH_PROG(PS, ps, ps)
+-AC_MSG_CHECKING("how to check if pid exists")
+-PS=$ac_cv_path_PS
++AC_CACHE_CHECK([how to check if pid exists], [ac_cv_FIND_PROC],
++[
+ # Linux style
+ if $PS p $$ 2> /dev/null | grep $0 > /dev/null
+ then
+@@ -511,8 +511,9 @@
+ AC_MSG_ERROR([Could not find the right ps switches. Which OS is this ?. See the Installation chapter in the Reference Manual.])
+ esac
+ fi
+-AC_SUBST(FIND_PROC)
+-AC_MSG_RESULT("$FIND_PROC")
++ac_cv_FIND_PROC="$FIND_PROC"
++])
++AC_SUBST([FIND_PROC], [$ac_cv_FIND_PROC])
+
+ # Check if a pid is valid
+ AC_PATH_PROG(KILL, kill, kill)
diff --git a/recipes/mysql/files/fix_host_path.patch b/recipes/mysql/files/fix_host_path.patch
new file mode 100644
index 0000000000..4f69cd5198
--- /dev/null
+++ b/recipes/mysql/files/fix_host_path.patch
@@ -0,0 +1,37 @@
+--- mysql-4.1.22/configure.in.old 2008-09-18 20:11:15.000000000 -0500
++++ mysql-4.1.22/configure.in 2008-09-18 20:12:28.000000000 -0500
+@@ -456,9 +456,9 @@ else
+ fi
+ fi
+
+-AC_SUBST(HOSTNAME)
+-AC_SUBST(PERL)
+-AC_SUBST(PERL5)
++AC_SUBST(HOSTNAME,/bin/hostname)
++AC_SUBST(PERL,$(bindir)/perl)
++AC_SUBST(PERL5,$(bindir)/perl)
+
+ # for build ndb docs
+
+@@ -516,16 +516,17 @@ AC_MSG_RESULT("$FIND_PROC")
+
+ # Check if a pid is valid
+ AC_PATH_PROG(KILL, kill, kill)
++AC_SUBST(KILL,/bin/kill)
+ AC_MSG_CHECKING("for kill switches")
+-if $ac_cv_path_KILL -0 $$
++if $KILL -0 $$
+ then
+- CHECK_PID="$ac_cv_path_KILL -0 \$\$PID > /dev/null 2> /dev/null"
++ CHECK_PID="$KILL -0 \$\$PID > /dev/null 2> /dev/null"
+ elif kill -s 0 $$
+ then
+- CHECK_PID="$ac_cv_path_KILL -s 0 \$\$PID > /dev/null 2> /dev/null"
++ CHECK_PID="$KILL -s 0 \$\$PID > /dev/null 2> /dev/null"
+ else
+ AC_MSG_WARN([kill -0 to check for pid seems to fail])
+- CHECK_PID="$ac_cv_path_KILL -s SIGCONT \$\$PID > /dev/null 2> /dev/null"
++ CHECK_PID="$KILL -s SIGCONT \$\$PID > /dev/null 2> /dev/null"
+ fi
+ AC_SUBST(CHECK_PID)
+ AC_MSG_RESULT("$CHECK_PID")
diff --git a/recipes/mysql/files/gen_lex_hash.patch b/recipes/mysql/files/gen_lex_hash.patch
new file mode 100644
index 0000000000..c398d048dc
--- /dev/null
+++ b/recipes/mysql/files/gen_lex_hash.patch
@@ -0,0 +1,19 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- mysql-4.1.15/sql/Makefile.am~gen_lexhash
++++ mysql-4.1.15/sql/Makefile.am
+@@ -137,8 +137,10 @@
+ @echo "If it fails, re-run configure with --with-low-memory"
+ $(CXXCOMPILE) $(LM_CFLAGS) -c $<
+
++GEN_LEX_HASH = ./gen_lex_hash$(EXEEXT)
++
+ lex_hash.h: gen_lex_hash$(EXEEXT)
+- ./gen_lex_hash$(EXEEXT) > $@
++ $(GEN_LEX_HASH) > $@
+
+ # For testing of udf_example.so; Works on platforms with gcc
+ # (This is not part of our build process but only provided as an example)
diff --git a/recipes/mysql/files/my.cnf b/recipes/mysql/files/my.cnf
new file mode 100644
index 0000000000..15a8b1b4ab
--- /dev/null
+++ b/recipes/mysql/files/my.cnf
@@ -0,0 +1,21 @@
+[client]
+#password = password
+port = 3306
+socket = /tmp/mysql.sock
+
+[mysqld_safe]
+err-log = /var/log/mysql.err
+
+[mysqld]
+user = mysql
+port = 3306
+socket = /tmp/mysql.sock
+pid-file = /var/run/mysqld.pid
+log-error = /var/log/mysqld.err
+basedir = /usr
+datadir = /var/mysql
+skip-locking
+skip-innodb
+skip-networking
+bind-address = localhost
+
diff --git a/recipes/mysql/files/mysqld.sh b/recipes/mysql/files/mysqld.sh
new file mode 100644
index 0000000000..c94772e202
--- /dev/null
+++ b/recipes/mysql/files/mysqld.sh
@@ -0,0 +1,20 @@
+# MySQL init script
+
+. /etc/default/rcS
+
+case "$1" in
+ start)
+ /usr/bin/mysqld_safe &
+ ;;
+ stop)
+ if test -f /var/run/mysqld.pid ; then
+ PID=`cat /var/run/mysqld.pid`
+ kill $PID
+ fi
+ ;;
+ *)
+ echo "Usage: /etc/init.d/mysqld {start|stop}"
+ ;;
+esac
+
+exit 0