aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mythtv
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-27 22:39:18 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-27 22:41:24 +0200
commitc3e1a6c297958baa43f4d096f117e6c6bd8f9cfa (patch)
tree5a940c36dfd6f54e77ae9888f089b8d915c63c2c /recipes/mythtv
parent38b96d1e42d7643d39de5a1f65ff034d6bc59c6e (diff)
downloadopenembedded-c3e1a6c297958baa43f4d096f117e6c6bd8f9cfa.tar.gz
mythplugins-023: fixed it
some patches did not apply -> repaired mythflix is not supported any more -> removed mythnetvisions -> added Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/mythtv')
-rw-r--r--recipes/mythtv/mythplugins-0.23/configure.patch13
-rw-r--r--recipes/mythtv/mythplugins-0.23/mytharchive.pro.patch41
-rw-r--r--recipes/mythtv/mythplugins-0.23/mythplugins_wo_qtopengl.diff115
-rw-r--r--recipes/mythtv/mythplugins-0.23/sysroot.patch203
-rw-r--r--recipes/mythtv/mythplugins_0.23+fixes.bb34
5 files changed, 390 insertions, 16 deletions
diff --git a/recipes/mythtv/mythplugins-0.23/configure.patch b/recipes/mythtv/mythplugins-0.23/configure.patch
new file mode 100644
index 0000000000..fd747a92e5
--- /dev/null
+++ b/recipes/mythtv/mythplugins-0.23/configure.patch
@@ -0,0 +1,13 @@
+Index: mythplugins-0.22rc1/configure
+===================================================================
+--- mythplugins-0.22rc1.orig/configure
++++ mythplugins-0.22rc1/configure
+@@ -730,7 +730,7 @@ if test "$music" = "yes" ; then
+ fi
+
+ if test "$taglib" = "yes" ; then
+- echo "INCLUDEPATH += `taglib-config --prefix`/include/taglib" >> ./mythmusic/mythmusic/config.pro
++ echo "INCLUDEPATH += `taglib-config --cflags | sed 's:-I::'`" >> ./mythmusic/mythmusic/config.pro
+ fi
+ fi
+
diff --git a/recipes/mythtv/mythplugins-0.23/mytharchive.pro.patch b/recipes/mythtv/mythplugins-0.23/mytharchive.pro.patch
new file mode 100644
index 0000000000..e5ea1808a9
--- /dev/null
+++ b/recipes/mythtv/mythplugins-0.23/mytharchive.pro.patch
@@ -0,0 +1,41 @@
+Index: mythplugins-0.22rc2/mytharchive/mytharchive/mytharchive.pro
+===================================================================
+--- mythplugins-0.22rc2.orig/mytharchive/mytharchive/mytharchive.pro
++++ mythplugins-0.22rc2/mytharchive/mytharchive/mytharchive.pro
+@@ -32,28 +32,28 @@ SOURCES += dbcheck.cpp archiveutil.cpp s
+ SOURCES += mythburn.cpp themeselector.cpp editmetadata.cpp thumbfinder.cpp
+ SOURCES += exportnative.cpp importnative.cpp
+
+-burnuifiles.path = $${SYSROOT}$${PREFIX}/share/mythtv/themes/default
++burnuifiles.path = $${PREFIX}/share/mythtv/themes/default
+ burnuifiles.files = mythburn-ui.xml
+
+-scriptfiles.path = $${SYSROOT}$${PREFIX}/share/mythtv/mytharchive/scripts
++scriptfiles.path = $${PREFIX}/share/mythtv/mytharchive/scripts
+ scriptfiles.files = ../mythburn/scripts/*
+
+-introfiles.path = $${SYSROOT}$${PREFIX}/share/mythtv/mytharchive/intro
++introfiles.path = $${PREFIX}/share/mythtv/mytharchive/intro
+ introfiles.files = ../mythburn/intro/*.mpg
+
+-musicfiles.path = $${SYSROOT}$${PREFIX}/share/mythtv/mytharchive/music
++musicfiles.path = $${PREFIX}/share/mythtv/mytharchive/music
+ musicfiles.files = ../mythburn/music/*.ac3
+
+-imagefiles.path = $${SYSROOT}$${PREFIX}/share/mythtv/mytharchive/images
++imagefiles.path = $${PREFIX}/share/mythtv/mytharchive/images
+ imagefiles.files = ../mythburn/images/*.png
+
+-themefiles.path = $${SYSROOT}$${PREFIX}/share/mythtv/mytharchive/themes
++themefiles.path = $${PREFIX}/share/mythtv/mytharchive/themes
+ themefiles.files = ../mythburn/themes/*
+
+-profilefiles.path = $${SYSROOT}$${PREFIX}/share/mythtv/mytharchive/encoder_profiles
++profilefiles.path = $${PREFIX}/share/mythtv/mytharchive/encoder_profiles
+ profilefiles.files = ../mythburn/encoder_profiles/*.xml
+
+-nativeuifiles.path = $${SYSROOT}$${PREFIX}/share/mythtv/themes/default
++nativeuifiles.path = $${PREFIX}/share/mythtv/themes/default
+ nativeuifiles.files = mythnative-ui.xml
+
+ INSTALLS += scriptfiles introfiles themefiles imagefiles musicfiles
diff --git a/recipes/mythtv/mythplugins-0.23/mythplugins_wo_qtopengl.diff b/recipes/mythtv/mythplugins-0.23/mythplugins_wo_qtopengl.diff
new file mode 100644
index 0000000000..639dd85acb
--- /dev/null
+++ b/recipes/mythtv/mythplugins-0.23/mythplugins_wo_qtopengl.diff
@@ -0,0 +1,115 @@
+Index: mythplugins/mytharchive/mytharchive/mytharchive.pro
+===================================================================
+--- mythplugins.orig/mytharchive/mytharchive/mytharchive.pro
++++ mythplugins/mytharchive/mytharchive/mytharchive.pro
+@@ -14,7 +14,7 @@ LIBS += -lmythavcodec-$$LIBVERSION
+ LIBS += -lmythavformat-$$LIBVERSION
+ LIBS += -lmythswscale-$$LIBVERSION
+
+-TEMPLATE = lib opengl
++TEMPLATE = lib
+ CONFIG += plugin thread
+ TARGET = mytharchive
+ target.path = $${LIBDIR}/mythtv/plugins
+@@ -61,6 +61,7 @@ INSTALLS += profilefiles burnuifiles
+ INSTALLS += nativeuifiles
+
+ #The following line was inserted by qt3to4
+-QT += xml sql opengl
++QT += xml sql
++using_opengl:QT += opengl
+
+ include ( ../../libs-targetfix.pro )
+Index: mythplugins/mytharchive/mytharchivehelper/mytharchivehelper.pro
+===================================================================
+--- mythplugins.orig/mytharchive/mytharchivehelper/mytharchivehelper.pro
++++ mythplugins/mytharchive/mytharchivehelper/mytharchivehelper.pro
+@@ -9,7 +9,8 @@ INCLUDEPATH += $${SYSROOT}$${PREFIX}/inc
+ DEPENDPATH *= $${INCLUDEPATH}
+
+ TEMPLATE = app
+-CONFIG += thread opengl
++CONFIG += thread
++using_opengl:CONFIG += opengl
+
+ target.path = $${PREFIX}/bin
+
+@@ -27,4 +28,5 @@ LIBS += -lmythavcodec-$$LIBVERSION
+ LIBS += -lmythavformat-$$LIBVERSION
+ LIBS += -lmythswscale-$$LIBVERSION
+
+-QT += xml sql opengl
++QT += xml sql
++using_opengl:QT += opengl
+Index: mythplugins/mythbrowser/mythbrowser/mythbrowser.pro
+===================================================================
+--- mythplugins.orig/mythbrowser/mythbrowser/mythbrowser.pro
++++ mythplugins/mythbrowser/mythbrowser/mythbrowser.pro
+@@ -2,10 +2,12 @@ include (../../mythconfig.mak )
+ include (../../settings.pro )
+ include (../../programs-libs.pro )
+
+-QT += network xml sql opengl webkit
++QT += network xml sql webkit
++using_opengl:QT += opengl
+
+ TEMPLATE = lib
+-CONFIG += thread opengl plugin warn_on
++CONFIG += thread plugin warn_on
++using_opengl:CONFIG += opengl
+ TARGET = mythbrowser
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+Index: mythplugins/mythgallery/mythgallery/mythgallery.pro
+===================================================================
+--- mythplugins.orig/mythgallery/mythgallery/mythgallery.pro
++++ mythplugins/mythgallery/mythgallery/mythgallery.pro
+@@ -37,6 +37,7 @@ opengl {
+
+
+ #The following line was inserted by qt3to4
+-QT += network opengl sql xml
++QT += network sql xml
++using_opengl:QT += opengl
+
+ include ( ../../libs-targetfix.pro )
+Index: mythplugins/mythgame/mythgame/mythgame.pro
+===================================================================
+--- mythplugins.orig/mythgame/mythgame/mythgame.pro
++++ mythplugins/mythgame/mythgame/mythgame.pro
+@@ -23,6 +23,6 @@ use_hidesyms {
+ LIBS += -lz
+
+ #The following line was inserted by qt3to4
+-QT += xml sql opengl
++QT += xml sql
+
+ include ( ../../libs-targetfix.pro )
+Index: mythplugins/mythmusic/mythmusic/mythmusic.pro
+===================================================================
+--- mythplugins.orig/mythmusic/mythmusic/mythmusic.pro
++++ mythplugins/mythmusic/mythmusic/mythmusic.pro
+@@ -3,7 +3,8 @@ include ( ../../settings.pro )
+ include ( ../../programs-libs.pro )
+ include (config.pro)
+
+-QT += xml sql opengl qt3support network
++QT += xml sql qt3support network
++using_opengl:QT += opengl
+
+ !exists( config.pro ) {
+ error(Missing config.pro: please run the configure script)
+Index: mythplugins/mythvideo/mtd/mtd.pro
+===================================================================
+--- mythplugins.orig/mythvideo/mtd/mtd.pro
++++ mythplugins/mythvideo/mtd/mtd.pro
+@@ -5,7 +5,8 @@ include ( ../../programs-libs.pro )
+ QT += sql xml network
+
+ TEMPLATE = app
+-CONFIG += thread opengl
++CONFIG += thread
++using_opengl:CONFIG += opengl
+ TARGET = mtd
+ target.path = $${PREFIX}/bin
+ INSTALLS += target
diff --git a/recipes/mythtv/mythplugins-0.23/sysroot.patch b/recipes/mythtv/mythplugins-0.23/sysroot.patch
new file mode 100644
index 0000000000..fec1c464f5
--- /dev/null
+++ b/recipes/mythtv/mythplugins-0.23/sysroot.patch
@@ -0,0 +1,203 @@
+Index: mythplugins/programs-libs.pro
+===================================================================
+--- mythplugins.orig/programs-libs.pro
++++ mythplugins/programs-libs.pro
+@@ -4,7 +4,7 @@ INCLUDEPATH += $${SYSROOT}$${PREFIX}/inc
+ INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmyth
+ DEPENDPATH *= $${INCLUDEPATH}
+
+-LIBS += -L$${LIBDIR} $$EXTRA_LIBS -lmythdb-$$LIBVERSION
++LIBS += -L$${SYSROOT}$${LIBDIR} $$EXTRA_LIBS -lmythdb-$$LIBVERSION
+ LIBS += -lmythavutil-$$LIBVERSION -lmythavcodec-$$LIBVERSION
+ LIBS += -lmyth-$$LIBVERSION -lmythui-$$LIBVERSION -lmythupnp-$$LIBVERSION
+
+Index: mythplugins/configure
+===================================================================
+--- mythplugins.orig/configure
++++ mythplugins/configure
+@@ -359,24 +359,25 @@ TMPE="${TMPDIR1}/myth-conf-${RANDOM}-$$-
+
+ has_library()
+ {
+- if test -f /etc/ld.so.conf ; then
+- LIBPATHS=`cat /etc/ld.so.conf | grep -v "#" | grep -v "include"`
+- else
+- LIBPATHS=''
+- fi
+-
+- LIBPATHS="$LIBPATHS `echo $LD_LIBRARY_PATH | sed s/':'/' '/g` "
+- # Mac OS X has a different variable for this:
+- LIBPATHS="$LIBPATHS `echo $DYLD_LIBRARY_PATH | sed s/':'/' '/g` "
+-
+- # recurse down just one level, should be enough in most cases
+- if test -f /etc/ld.so.conf ; then
+- INCL=`cat /etc/ld.so.conf | grep -v "#" | grep "^include"`
+- SRCH=`echo "$INCL" | sed '{ s/^include \//\//; s/^include /\/etc\//}'`
+- for x in $SRCH ; do
+- LP_APPEND=`cat $x | grep -v "#" | grep -v "^include"`
+- LIBPATHS="$LIBPATHS $LP_APPEND"
+- done
++ LIBPATHS=''
++ if test "x$sysroot" = "x" ; then
++ if test -f /etc/ld.so.conf ; then
++ LIBPATHS=`cat /etc/ld.so.conf | grep -v "#" | grep -v "include"`
++ fi
++
++ LIBPATHS="$LIBPATHS `echo $LD_LIBRARY_PATH | sed s/':'/' '/g` "
++ # Mac OS X has a different variable for this:
++ LIBPATHS="$LIBPATHS `echo $DYLD_LIBRARY_PATH | sed s/':'/' '/g` "
++
++ # recurse down just one level, should be enough in most cases
++ if test -f /etc/ld.so.conf ; then
++ INCL=`cat /etc/ld.so.conf | grep -v "#" | grep "^include"`
++ SRCH=`echo "$INCL" | sed '{ s/^include \//\//; s/^include /\/etc\//}'`
++ for x in $SRCH ; do
++ LP_APPEND=`cat $x | grep -v "#" | grep -v "^include"`
++ LIBPATHS="$LIBPATHS $LP_APPEND"
++ done
++ fi
+ fi
+
+ LIBPATHS="`echo $LIBPATHS $sysroot$prefix/$libdir_name $sysroot/$libdir_name $sysroot/usr/$libdir_name $sysroot/usr/local/$libdir_name $sysroot/usr/X11R6/$libdir_name | sed s/'\/ '/' '/g` "
+@@ -393,8 +394,10 @@ has_library()
+ has_header()
+ {
+ HPATHS="$sysroot$prefix/include $sysroot/usr/local/include $sysroot/usr/include $sysroot/usr/include/g++-v3 $sysroot/usr/X11R6/include $sysroot/"
+- INCL=`echo $DYLD_LIBRARY_PATH $LD_LIBRARY_PATH | sed s/':'/' '/g`
+- HPATHS="$HPATHS `echo $INCL | sed s/$libdir_name/include/g` "
++ if test "x$sysroot" = "x" ; then
++ INCL=`echo $DYLD_LIBRARY_PATH $LD_LIBRARY_PATH | sed s/':'/' '/g`
++ HPATHS="$HPATHS `echo $INCL | sed s/$libdir_name/include/g` "
++ fi
+
+ HAS_IT="no"
+ for HPATH in $HPATHS ; do
+@@ -804,7 +807,7 @@ if test "$music" = "yes" ; then
+ if test "$sdl" = "yes" ; then
+ echo " libvisual support will be included in MythMusic"
+ echo "#define LIBVISUAL_SUPPORT 1" >> ./mythmusic/mythmusic/config.h
+- echo "INCLUDEPATH += /usr/include/libvisual-0.4" >> ./mythmusic/mythmusic/config.pro
++ echo "INCLUDEPATH += ${sysroot}/usr/include/libvisual-0.4" >> ./mythmusic/mythmusic/config.pro
+ echo "LIBS += -lvisual-0.4" >> ./mythmusic/mythmusic/config.pro
+ else
+ echo " libvisual support will not be included in MythMusic (requires SDL support)"
+Index: mythplugins/settings.pro
+===================================================================
+--- mythplugins.orig/settings.pro
++++ mythplugins/settings.pro
+@@ -3,8 +3,8 @@ CONFIG += $$CCONFIG
+ LIBVERSION = 0.23.1
+
+ INCLUDEPATH += $${SYSROOT}$${PREFIX}/include
+-#INCLUDEPATH += /usr/include/cdda
+-#INCLUDEPATH += /usr/include/FLAC
++#INCLUDEPATH += $${SYSROOT}/usr/include/cdda
++#INCLUDEPATH += $${SYSROOT}/usr/include/FLAC
+
+ LIBS *= -L$${SYSROOT}$${PREFIX}/$${LIBDIRNAME}
+
+Index: mythplugins/mythgallery/mythgallery/mythgallery.pro
+===================================================================
+--- mythplugins.orig/mythgallery/mythgallery/mythgallery.pro
++++ mythplugins/mythgallery/mythgallery/mythgallery.pro
+@@ -14,7 +14,7 @@ TARGET = mythgallery
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+
+-INCLUDEPATH += $${PREFIX}/include/mythtv
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv
+
+ # Input
+ HEADERS += iconview.h singleview.h
+Index: mythplugins/mythweather/mythweather/mythweather.pro
+===================================================================
+--- mythplugins.orig/mythweather/mythweather/mythweather.pro
++++ mythplugins/mythweather/mythweather/mythweather.pro
+@@ -13,8 +13,8 @@ INSTALLS += target
+ QMAKE_COPY_DIR = sh ../../cpsvndir
+ win32:QMAKE_COPY_DIR = sh ../../cpsimple
+
+-INCLUDEPATH += $${PREFIX}/include/mythtv
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythui
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythui
+
+ datafiles.path = $${PREFIX}/share/mythtv/mythweather/
+ datafiles.files = weather-screens.xml
+Index: mythplugins/mythmovies/mythmovies/mythmovies.pro
+===================================================================
+--- mythplugins.orig/mythmovies/mythmovies/mythmovies.pro
++++ mythplugins/mythmovies/mythmovies/mythmovies.pro
+@@ -10,7 +10,7 @@ TARGET = mythmovies
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythui
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythui
+
+ # Input
+ HEADERS += moviesui.h helperobjects.h moviessettings.h
+Index: mythplugins/mythzoneminder/mythzoneminder/mythzoneminder.pro
+===================================================================
+--- mythplugins.orig/mythzoneminder/mythzoneminder/mythzoneminder.pro
++++ mythplugins/mythzoneminder/mythzoneminder/mythzoneminder.pro
+@@ -9,7 +9,7 @@ TARGET = mythzoneminder
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythui
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythui
+
+ # Input
+ HEADERS += zmconsole.h zmplayer.h zmevents.h zmliveplayer.h zmdefines.h
+Index: mythplugins/mythnews/mythnews/mythnews.pro
+===================================================================
+--- mythplugins.orig/mythnews/mythnews/mythnews.pro
++++ mythplugins/mythnews/mythnews/mythnews.pro
+@@ -10,9 +10,9 @@ TARGET = mythnews
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+
+-INCLUDEPATH += $${PREFIX}/include/mythtv
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythui
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythdb
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythui
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythdb
+
+ installfiles.path = $${PREFIX}/share/mythtv/mythnews
+ installfiles.files = news-sites.xml
+Index: mythplugins/targetdep.pro
+===================================================================
+--- mythplugins.orig/targetdep.pro
++++ mythplugins/targetdep.pro
+@@ -10,10 +10,10 @@ MYTH_SHLIB_EXT=$${LIBVERSION}.$${QMAKE_E
+ MYTH_LIB_EXT =$${LIBVERSION}.$${QMAKE_EXTENSION_LIB}
+
+
+-DEPLIBS = $${LIBDIR}
++DEPLIBS = $${SYSROOT}$${LIBDIR}
+
+ # On Windows, dlls were installed with exes:
+-mingw : DEPLIBS = $${PREFIX}/bin
++mingw : DEPLIBS = $${SYSROOT}$${PREFIX}/bin
+
+ TARGETDEPS += $${DEPLIBS}/libmyth-$${MYTH_SHLIB_EXT}
+ TARGETDEPS += $${DEPLIBS}/libmythdb-$${MYTH_SHLIB_EXT}
+Index: mythplugins/mythnetvision/mythnetvision/mythnetvision.pro
+===================================================================
+--- mythplugins.orig/mythnetvision/mythnetvision/mythnetvision.pro
++++ mythplugins/mythnetvision/mythnetvision/mythnetvision.pro
+@@ -10,9 +10,9 @@ TARGET = mythnetvision
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+
+-INCLUDEPATH += $${PREFIX}/include/mythtv
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythui
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythdb
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythui
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythdb
+
+ installfiles.path = $${PREFIX}/share/mythtv/mythnetvision
+
diff --git a/recipes/mythtv/mythplugins_0.23+fixes.bb b/recipes/mythtv/mythplugins_0.23+fixes.bb
index 202ead9016..ed8dcfddae 100644
--- a/recipes/mythtv/mythplugins_0.23+fixes.bb
+++ b/recipes/mythtv/mythplugins_0.23+fixes.bb
@@ -1,6 +1,6 @@
DEPENDS = "flac taglib mythtv libvorbis libexif libvisual libsdl-x11 libcdaudio cdparanoia"
-RDEPENDS_${PN} = "mytharchive mythbrowser mythflix mythgallery mythgame \
- mythmusic mythmovies mythnews mythvideo mythweather mythzoneminder"
+RDEPENDS_${PN} = "mytharchive mythbrowser mythgallery mythgame mythmovies \
+ mythmusic mythnetvision mythnews mythvideo mythweather mythzoneminder"
RRECOMMENDS_${PN} = "mythweb_lighttpd"
# the apache variant does not work yet, too many issues with apache+php+mysql"
@@ -11,6 +11,7 @@ DEPENDS_mythweb_lighttpd = "mythweb"
RDEPENDS_mythweb_lighttpd = "lighttpd lighttpd-module-cgi lighttpd-module-fastcgi \
lighttpd-module-rewrite php-cgi lighttpd-module-auth"
+RDEPENDS_mythnetvision += " python python-mysqldb "
PR = "svnr${SRCPV}+r0"
PV = "0.23"
@@ -22,7 +23,6 @@ SRC_URI = "svn://svn.mythtv.org/svn/branches/release-0-23-fixes;module=mythplugi
file://mytharchive.pro.patch \
"
-
QMAKE_PROFILES = "mythplugins.pro"
S = "${WORKDIR}/mythplugins"
@@ -45,6 +45,10 @@ do_configure() {
${S}/configure --qmake=qmake2 ${EXTRA_OECONF}
}
+do_install () {
+ oe_runmake install INSTALL_ROOT="${D}"
+}
+
do_install_mythweb_apache () {
oe_runmake install INSTALL_ROOT="${D}"
install -d ${D}${datadir}/apache2
@@ -83,11 +87,12 @@ PACKAGES =+ " \
mythweb_apache mythweb_lighttpd \
mytharchive mytharchive-dbg \
mythbrowser mythbrowser-dbg \
- mythflix mythflix-dbg \
mythgallery mythgallery-dbg \
mythgame mythgame-dbg \
mythmovies mythmovies-dbg \
mythmusic mythmusic-dbg \
+ mythnetvision mythnetvision-dbg \
+ mythnetvision-data \
mythnews mythnews-dbg \
mythvideo mythvideo-dbg \
mythweather mythweather-dbg \
@@ -127,18 +132,6 @@ FILES_mythbrowser = "${libdir}/mythtv/plugins/libmythbrowser.so \
"
FILES_mythbrowser-dbg = "${libdir}/mythtv/plugins/.debug/libmythbrowser.so"
-FILES_mythflix = "${libdir}/mythtv/plugins/libmythflix.so \
- ${datadir}/mythtv/i18n/mythflix* \
- ${datadir}/mythtv/mythflix/* \
- ${datadir}/mythtv/netflix_menu.xml \
- ${datadir}/mythtv/themes/default/mythflix_background.png \
- ${datadir}/mythtv/themes/default/netflix-ui.xml \
- ${datadir}/mythtv/themes/default-wide/netflix-ui.xml \
- ${datadir}/mythtv/themes/default/title_netflix.png \
- ${datadir}/mythtv/themes/default-wide/netflix-bg.png \
- "
-FILES_mythflix-dbg = "${libdir}/mythtv/plugins/.debug/libmythflix.so"
-
FILES_mythgallery = "${libdir}/mythtv/plugins/libmythgallery.so \
${datadir}/mythtv/i18n/mythgallery* \
${datadir}/mythtv/themes/default/gallery*.png \
@@ -244,6 +237,15 @@ FILES_mythnews = "${libdir}/mythtv/plugins/libmythnews.so \
"
FILES_mythnews-dbg = "${libdir}/mythtv/plugins/.debug/libmythnews.so"
+FILES_mythnetvision = "${libdir}/mythtv/plugins/libmythnetvision.so \
+ ${datadir}/mythtv/mythnetvision/* \
+ ${datadir}/mythtv/i18n/mythnetvision* \
+ ${datadir}/mythtv/mythnetvision.xml\
+ ${datadir}/mythtv/themes/default/netvision-ui.xml \
+ ${datadir}/mythtv/themes/default-wide/nenetvision-ui.xml \
+ "
+#FILES_mythnetvision-dbg = "${libdir}/mythtv/plugins/.debug/libmythnetvision.so"
+
FILES_mythvideo = "${libdir}/mythtv/plugins/libmythvideo.so \
${bindir}/mtd \
${datadir}/mythtv/mythvideo/* \