summaryrefslogtreecommitdiffstats
path: root/recipes/neon
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/neon
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/neon')
-rw-r--r--recipes/neon/files/gnutls-2.patch11
-rw-r--r--recipes/neon/files/gnutls-force-and-detect.patch23
-rw-r--r--recipes/neon/files/no-func-checks.patch32
-rw-r--r--recipes/neon/neon_0.25.5.bb19
-rw-r--r--recipes/neon/neon_0.26.0.bb17
5 files changed, 102 insertions, 0 deletions
diff --git a/recipes/neon/files/gnutls-2.patch b/recipes/neon/files/gnutls-2.patch
new file mode 100644
index 0000000000..2b37dfc889
--- /dev/null
+++ b/recipes/neon/files/gnutls-2.patch
@@ -0,0 +1,11 @@
+diff -Nurd neon-0.25.5/macros/neon.m4 neon-0.25.5-patched/macros/neon.m4
+--- neon-0.25.5/macros/neon.m4 2009-02-03 16:23:40.000000000 +0100
++++ neon-0.25.5-patched/macros/neon.m4 2009-02-03 16:24:00.000000000 +0100
+@@ -895,6 +895,7 @@
+ 1.0.?|1.0.1?|1.0.20|1.0.21)
+ AC_MSG_ERROR([GNU TLS version $ne_gnutls_ver is too old -- 1.0.22 or later required]) ;;
+ 1.*) ;;
++ 2.*) ;;
+ *) AC_MSG_ERROR([GNU TLS version $ne_gnutls_ver is not supported]) ;;
+ esac
+
diff --git a/recipes/neon/files/gnutls-force-and-detect.patch b/recipes/neon/files/gnutls-force-and-detect.patch
new file mode 100644
index 0000000000..4c794ba138
--- /dev/null
+++ b/recipes/neon/files/gnutls-force-and-detect.patch
@@ -0,0 +1,23 @@
+diff --git a/macros/neon.m4 b/macros/neon.m4
+index 01072b9..6d3258f 100644
+--- a/macros/neon.m4
++++ b/macros/neon.m4
+@@ -886,15 +886,11 @@ yes|openssl)
+ NEON_EXTRAOBJS="$NEON_EXTRAOBJS ne_openssl"
+ ;;
+ gnutls)
+- AC_MSG_ERROR([GNU TLS support is not yet complete])
++ dnl AC_MSG_ERROR([GNU TLS support is not yet complete])
+
+- AC_PATH_PROG(GNUTLS_CONFIG, libgnutls-config, no)
++ GNUTLS_CONFIG="pkg-config gnutls"
+
+- if test "$GNUTLS_CONFIG" = "no"; then
+- AC_MSG_ERROR([could not find libgnutls-config in \$PATH])
+- fi
+-
+- ne_gnutls_ver=`$GNUTLS_CONFIG --version`
++ ne_gnutls_ver=`$GNUTLS_CONFIG --modversion`
+ case $ne_gnutls_ver in
+ 1.0.?|1.0.1?|1.0.20|1.0.21)
+ AC_MSG_ERROR([GNU TLS version $ne_gnutls_ver is too old -- 1.0.22 or later required]) ;;
diff --git a/recipes/neon/files/no-func-checks.patch b/recipes/neon/files/no-func-checks.patch
new file mode 100644
index 0000000000..46ca24398e
--- /dev/null
+++ b/recipes/neon/files/no-func-checks.patch
@@ -0,0 +1,32 @@
+--- neon-0.24.7/macros/neon.m4.old 2005-02-24 16:28:01 +00:00
++++ neon-0.24.7/macros/neon.m4 2005-02-24 16:40:17 +00:00
+@@ -508,26 +508,9 @@
+ # Enable getaddrinfo() support only if all the necessary functions
+ # are found.
+ ne_enable_gai=yes
+-NE_CHECK_FUNCS(getaddrinfo gai_strerror inet_ntop,,[ne_enable_gai=no; break])
+-if test $ne_enable_gai = yes; then
+- AC_DEFINE(USE_GETADDRINFO, 1, [Define if getaddrinfo() should be used])
+- AC_CACHE_CHECK([for working AI_ADDRCONFIG], [ne_cv_gai_addrconfig], [
+- AC_RUN_IFELSE([AC_LANG_PROGRAM([#include <netdb.h>],
+-[struct addrinfo hints = {0}, *result;
+-hints.ai_flags = AI_ADDRCONFIG;
+-if (getaddrinfo("localhost", NULL, &hints, &result) != 0) return 1;])],
+- ne_cv_gai_addrconfig=yes, ne_cv_gai_addrconfig=no)])
+- if test $ne_cv_gai_addrconfig = yes; then
+- AC_DEFINE(USE_GAI_ADDRCONFIG, 1, [Define if getaddrinfo supports AI_ADDRCONFIG])
+- fi
+-else
+- # Checks for non-getaddrinfo() based resolver interfaces.
+- NE_SEARCH_LIBS(hstrerror, resolv,,[:])
+- NE_CHECK_FUNCS(hstrerror)
+- # Older Unixes don't declare h_errno.
+- AC_CHECK_DECL(h_errno,,,[#define _XOPEN_SOURCE_EXTENDED 1
+-#include <netdb.h>])
+-fi
++ne_cv_gai_addrconfig=yes
++AC_DEFINE(USE_GETADDRINFO, 1, [Define if getaddrinfo() should be used])
++AC_DEFINE(USE_GAI_ADDRCONFIG, 1, [Define if getaddrinfo supports AI_ADDRCONFIG])
+
+ AC_CHECK_MEMBERS(struct tm.tm_gmtoff,,
+ AC_MSG_WARN([no timezone handling in date parsing on this platform]),
diff --git a/recipes/neon/neon_0.25.5.bb b/recipes/neon/neon_0.25.5.bb
new file mode 100644
index 0000000000..9151a74665
--- /dev/null
+++ b/recipes/neon/neon_0.25.5.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "neon is an HTTP and WebDAV client library, with a C interface."
+HOMEPAGE = "http://www.webdav.org/neon"
+SECTION = "libs"
+LICENSE = "LGPL"
+DEPENDS = "zlib libxml2 expat time gnutls"
+
+PR = "r4"
+
+SRC_URI = "http://www.webdav.org/${PN}/${P}.tar.gz \
+ file://gnutls-force-and-detect.patch;patch=1 \
+ file://gnutls-2.patch;patch=1"
+
+inherit autotools binconfig lib_package pkgconfig
+
+EXTRA_OECONF = "--with-ssl=gnutls --with-libxml2 --with-expat --enable-shared"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/neon/neon_0.26.0.bb b/recipes/neon/neon_0.26.0.bb
new file mode 100644
index 0000000000..3a234851aa
--- /dev/null
+++ b/recipes/neon/neon_0.26.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "neon is an HTTP and WebDAV client library, with a C interface."
+SECTION = "libs"
+LICENSE = "LGPL"
+DEPENDS = "zlib libxml2 expat time gnutls"
+PR = "r2"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://www.webdav.org/${PN}/${P}.tar.gz"
+
+inherit autotools binconfig lib_package pkgconfig
+
+EXTRA_OECONF = "--with-ssl=gnutls --with-libxml2 --with-expat --enable-shared"
+
+do_stage () {
+ autotools_stage_all
+}