summaryrefslogtreecommitdiffstats
path: root/recipes/netbase
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-08-04 17:10:19 +0200
committerKoen Kooi <koen@openembedded.org>2010-08-04 17:11:23 +0200
commitf8e7634c9631b8849a160a2db4a2876b19aa7c69 (patch)
treee11cd06bc72c1b2e719d052617448a6a8de8375b /recipes/netbase
parenta75370f9492ab51052921ed9a98af00518c7effd (diff)
downloadopenembedded-f8e7634c9631b8849a160a2db4a2876b19aa7c69.tar.gz
netbase: add custom interfaces file for beagleboard
* changes usb0 to dhcp
Diffstat (limited to 'recipes/netbase')
-rw-r--r--recipes/netbase/netbase/beagleboard/interfaces60
-rw-r--r--recipes/netbase/netbase_4.21.bb2
2 files changed, 61 insertions, 1 deletions
diff --git a/recipes/netbase/netbase/beagleboard/interfaces b/recipes/netbase/netbase/beagleboard/interfaces
new file mode 100644
index 0000000000..ae420bd551
--- /dev/null
+++ b/recipes/netbase/netbase/beagleboard/interfaces
@@ -0,0 +1,60 @@
+# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
+
+# The loopback interface
+auto lo
+iface lo inet loopback
+# Wireless interfaces
+#
+# Example of an unencrypted (no WEP or WPA) wireless connection
+# that connects to any available access point:
+#
+iface wlan0 inet dhcp
+ wireless_mode managed
+ wireless_essid any
+#
+#
+# Same as above but locked to a specific access point:
+#
+#iface wlan0 inet dhcp
+# wireless_mode managed
+# wireless-essid some-essid
+#
+# A WEP encrypted connection locked to a specific access point:
+#
+#iface wlan0 inet dhcp
+# wireless-essid some-essid
+# wireless-key s:My-PlainText-Password
+# wireless-mode managed
+#
+# A WPA1 or WPA2 encrypted connection locked to a specific access point.
+# This is the best option for non-roaming, single-network usage.
+# Note that your card may require a firmware update to use WPA.
+# Some distributions install a temporary volatile firmware update on ifup.
+#
+#iface wlan0 inet dhcp
+# wpa-essid some-essid
+# wpa-psk My-PlainText-Password
+#
+# A WPA1 or WPA2 encrypted connection using an external configuration file
+# for wpa-supplicant. This is the way to go if you need to configure multiple
+# networks with different keys and / or WPA settings and roaming support.
+#
+# iface wlan0 inet dhcp
+# wpa-conf /etc/wpa_supplicant.conf
+# wpa-driver hostap
+
+
+
+iface atml0 inet dhcp
+
+# Wired or wireless interfaces
+auto eth0
+iface eth0 inet dhcp
+iface eth1 inet dhcp
+
+# Ethernet/RNDIS gadget (g_ether) or LAN9514
+iface usb0 inet dhcp
+
+# Bluetooth networking
+iface bnep0 inet dhcp
+
diff --git a/recipes/netbase/netbase_4.21.bb b/recipes/netbase/netbase_4.21.bb
index baec44bafc..656ca489a5 100644
--- a/recipes/netbase/netbase_4.21.bb
+++ b/recipes/netbase/netbase_4.21.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "This package provides the necessary \
infrastructure for basic TCP/IP based networking."
SECTION = "base"
LICENSE = "GPLv2"
-PR = "r42"
+PR = "r43"
inherit update-rc.d