aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/netkit-tftp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/netkit-tftp
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/netkit-tftp')
-rw-r--r--recipes/netkit-tftp/netkit-tftp-0.17/mconfig.patch20
-rw-r--r--recipes/netkit-tftp/netkit-tftp-0.17/pack_tftphdr.patch52
-rw-r--r--recipes/netkit-tftp/netkit-tftp-0.17/tftpd_add_debug.patch28
-rw-r--r--recipes/netkit-tftp/netkit-tftp_0.17.bb15
-rw-r--r--recipes/netkit-tftp/netkit-tftpd_0.17.bb36
5 files changed, 151 insertions, 0 deletions
diff --git a/recipes/netkit-tftp/netkit-tftp-0.17/mconfig.patch b/recipes/netkit-tftp/netkit-tftp-0.17/mconfig.patch
new file mode 100644
index 0000000000..26f2f2b6b6
--- /dev/null
+++ b/recipes/netkit-tftp/netkit-tftp-0.17/mconfig.patch
@@ -0,0 +1,20 @@
+diff -urNd netkit-base-0.17/MCONFIG netkit-base-0.17-new/MCONFIG
+--- netkit-base-0.17/MCONFIG 1969-12-31 18:00:00.000000000 -0600
++++ netkit-base-0.17-new/MCONFIG 2002-10-12 13:33:16.000000000 -0500
+@@ -0,0 +1,16 @@
++BINDIR=/usr/bin
++SBINDIR=/usr/sbin
++MANDIR=/usr/man
++ROOTBINDIR=/bin
++BINMODE=755
++DAEMONMODE=755
++MANMODE=644
++SUIDMODE=4755
++PREFIX=/usr
++EXECPREFIX=/usr
++ROOTPREFIX=
++INSTALLROOT=
++CC=arm-linux-gcc
++CFLAGS=-I/usr/src/coding/projects/userspace/buildroot/output/staging/usr/include -O2 -Wall -W -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline
++LDFLAGS=
++LIBS=
diff --git a/recipes/netkit-tftp/netkit-tftp-0.17/pack_tftphdr.patch b/recipes/netkit-tftp/netkit-tftp-0.17/pack_tftphdr.patch
new file mode 100644
index 0000000000..b5caaa2953
--- /dev/null
+++ b/recipes/netkit-tftp/netkit-tftp-0.17/pack_tftphdr.patch
@@ -0,0 +1,52 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- netkit-tftp-0.17/include/arpa/tftp.h~pack_tftphdr.patch
++++ netkit-tftp-0.17/include/arpa/tftp.h
+@@ -10,10 +10,6 @@
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+- * 3. All advertising materials mentioning features or use of this software
+- * must display the following acknowledgement:
+- * This product includes software developed by the University of
+- * California, Berkeley and its contributors.
+ * 4. Neither the name of the University nor the names of its contributors
+ * may be used to endorse or promote products derived from this software
+ * without specific prior written permission.
+@@ -30,10 +26,7 @@
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ *
+- * From: @(#)tftp.h 8.1 (Berkeley) 6/2/93
+- * $Id: tftp.h,v 1.1 2000/07/22 18:59:20 dholland Exp $
+- *
+- * (Fixed for netkit to have well-defined field sizes)
++ * @(#)tftp.h 8.1 (Berkeley) 6/2/93
+ */
+
+ #ifndef _ARPA_TFTP_H
+@@ -54,14 +47,14 @@
+ #define ERROR 05 /* error code */
+
+ struct tftphdr {
+- u_int16_t th_opcode; /* packet type */
++ short th_opcode; /* packet type */
+ union {
+- u_int16_t tu_block; /* block # */
+- u_int16_t tu_code; /* error code */
+- char tu_stuff[1]; /* request packet stuff */
+- } th_u;
+- char th_data[1]; /* data or error string */
+-};
++ unsigned short tu_block; /* block # */
++ short tu_code; /* error code */
++ char tu_stuff[1]; /* request packet stuff */
++ } __attribute__ ((__packed__)) th_u;
++ char th_data[1]; /* data or error string */
++} __attribute__ ((__packed__));
+
+ #define th_block th_u.tu_block
+ #define th_code th_u.tu_code
diff --git a/recipes/netkit-tftp/netkit-tftp-0.17/tftpd_add_debug.patch b/recipes/netkit-tftp/netkit-tftp-0.17/tftpd_add_debug.patch
new file mode 100644
index 0000000000..f7dfd58ed4
--- /dev/null
+++ b/recipes/netkit-tftp/netkit-tftp-0.17/tftpd_add_debug.patch
@@ -0,0 +1,28 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- netkit-tftp-0.17/tftpd/tftpd.c~tftpd_add_debug
++++ netkit-tftp-0.17/tftpd/tftpd.c
+@@ -252,6 +252,8 @@
+ char *filename, *mode = NULL;
+
+ filename = cp = tp->th_stuff;
++ syslog(LOG_NOTICE, "tp->th_opcode=%x, tp = %p, &(tp->th_stuff)=%p, filename=%s", tp->th_opcode,tp, &(tp->th_stuff),filename);
++
+ again:
+ while (cp < buf + size) {
+ if (*cp == '\0')
+@@ -340,8 +342,10 @@
+ return(EACCESS);
+ }
+ }
+- if (stat(filename, &stbuf) < 0)
++ if (stat(filename, &stbuf) < 0) {
++ syslog(LOG_NOTICE, "file %s not found", filename);
+ return (errno == ENOENT ? ENOTFOUND : EACCESS);
++ }
+ #if 0
+ /*
+ * The idea is that symlinks are dangerous. However, a symlink
diff --git a/recipes/netkit-tftp/netkit-tftp_0.17.bb b/recipes/netkit-tftp/netkit-tftp_0.17.bb
new file mode 100644
index 0000000000..ee9225db72
--- /dev/null
+++ b/recipes/netkit-tftp/netkit-tftp_0.17.bb
@@ -0,0 +1,15 @@
+SECTION = "console/network"
+DESCRIPTION = "netkit-tftp includes a commandline tftp client."
+LICENSE = "BSD"
+SRC_URI = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-tftp-${PV}.tar.gz \
+ file://mconfig.patch;patch=1"
+
+EXTRA_OEMAKE = ""
+do_compile () {
+ oe_runmake 'CC=${CC}' 'LD=${LD}' all
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tftp/tftp ${D}${bindir}
+}
diff --git a/recipes/netkit-tftp/netkit-tftpd_0.17.bb b/recipes/netkit-tftp/netkit-tftpd_0.17.bb
new file mode 100644
index 0000000000..537d2beb69
--- /dev/null
+++ b/recipes/netkit-tftp/netkit-tftpd_0.17.bb
@@ -0,0 +1,36 @@
+SECTION = "console/network"
+DESCRIPTION = "netkit-tftpd includes a tftp server."
+DEPENDS = "netkit-base"
+RDEPENDS = "netkit-base"
+LICENSE = "BSD"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/netkit-tftp-${PV}"
+
+SRC_URI = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-tftp-${PV}.tar.gz \
+ file://mconfig.patch;patch=1 \
+ file://tftpd_add_debug.patch;patch=1 \
+ file://pack_tftphdr.patch;patch=1"
+
+S = "${WORKDIR}/netkit-tftp-${PV}"
+
+PR = "r7"
+
+EXTRA_OEMAKE = ""
+do_compile () {
+ oe_runmake 'CC=${CC}' 'LD=${LD}' all
+}
+
+do_install () {
+ install -d ${D}${sbindir}
+ install -m 0755 tftpd/tftpd ${D}${sbindir}/tftpd
+}
+
+pkg_postinst () {
+ #only run on the device
+ if [ -n "$D" ]; then exit 1; fi
+
+ #install inetd.conf line to run tftpd
+ echo "tftp dgram udp wait root ${sbindir}/tftpd tftpd" >> /etc/inetd.conf
+
+ #force inetd to reload settings
+ kill -SIGHUP `cat /var/run/inetd.pid`
+}