aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/netperf
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/netperf
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/netperf')
-rw-r--r--recipes/netperf/files/cpu_set.patch24
-rw-r--r--recipes/netperf/files/init51
-rw-r--r--recipes/netperf/netperf_2.3.bb49
-rw-r--r--recipes/netperf/netperf_2.4.4.bb41
4 files changed, 165 insertions, 0 deletions
diff --git a/recipes/netperf/files/cpu_set.patch b/recipes/netperf/files/cpu_set.patch
new file mode 100644
index 0000000000..b2b95c78b7
--- /dev/null
+++ b/recipes/netperf/files/cpu_set.patch
@@ -0,0 +1,24 @@
+Index: netperf-2.4.4/src/netlib.c
+===================================================================
+--- netperf-2.4.4.orig/src/netlib.c 2007-10-17 23:16:02.000000000 +0200
++++ netperf-2.4.4/src/netlib.c 2008-12-03 17:56:32.000000000 +0100
+@@ -1988,10 +1988,15 @@
+ fall-back on what we had before, which is to use just the size of
+ an unsigned long. raj 2006-09-14 */
+
+-#if defined(__CPU_SETSIZE)
+-#define NETPERF_CPU_SETSIZE __CPU_SETSIZE
+-#define NETPERF_CPU_SET(cpu, cpusetp) __CPU_SET(cpu, cpusetp)
+-#define NETPERF_CPU_ZERO(cpusetp) __CPU_ZERO (cpusetp)
++#if defined(CPU_SETSIZE)
++#define NETPERF_CPU_SETSIZE CPU_SETSIZE
++#define NETPERF_CPU_SET(cpu, cpusetp) CPU_SET(cpu, cpusetp)
++#define NETPERF_CPU_ZERO(cpusetp) CPU_ZERO (cpusetp)
++ typedef cpu_set_t netperf_cpu_set_t;
++#elif defined(__CPU_SETSIZE)
++#define NETPERF_CPU_SETSIZE __CPU_SETSIZE
++#define NETPERF_CPU_SET(cpu, cpusetp) __CPU_SET (cpu, cpusetp)
++#define NETPERF_CPU_ZERO(cpusetp) __CPU_ZERO (cpusetp)
+ typedef cpu_set_t netperf_cpu_set_t;
+ #else
+ #define NETPERF_CPU_SETSIZE sizeof(unsigned long)
diff --git a/recipes/netperf/files/init b/recipes/netperf/files/init
new file mode 100644
index 0000000000..7cc053ad18
--- /dev/null
+++ b/recipes/netperf/files/init
@@ -0,0 +1,51 @@
+#!/bin/sh
+#
+#
+# Written by Miquel van Smoorenburg <miquels@cistron.nl>.
+# Modified for Debian GNU/Linux by Ian Murdock <imurdock@gnu.org>.
+# Modified for Debian by Christoph Lameter <clameter@debian.org>
+# Modified for openembedded by Bruno Randolf <bruno.randolf@4g-systems.biz>
+
+PATH=/bin:/usr/bin:/sbin:/usr/sbin
+DAEMON=/usr/sbin/netserver
+
+test -f $DAEMON || exit 0
+
+case "$1" in
+ start)
+ echo -n "Starting network benchmark server: netserver"
+ start-stop-daemon -S -x $DAEMON > /dev/null 2>&1
+ echo "."
+ ;;
+ stop)
+ echo -n "Stopping network benchmark server: netserver"
+ start-stop-daemon -K -x $DAEMON
+ echo "."
+ ;;
+ #reload)
+ #
+ # If the daemon can reload its config files on the fly
+ # for example by sending it SIGHUP, do it here.
+ #
+ # If the daemon responds to changes in its config file
+ # directly anyway, make this a do-nothing entry.
+ #
+ # start-stop-daemon --stop --signal 1 --verbose --exec $DAEMON
+ # ;;
+ restart|force-reload)
+ #
+ # If the "reload" option is implemented, move the "force-reload"
+ # option to the "reload" entry above. If not, "force-reload" is
+ # just the same as "restart".
+ #
+ start-stop-daemon -K -x $DAEMON
+ sleep 1
+ start-stop-daemon -S -x $DAEMON
+ ;;
+ *)
+ echo "Usage: /etc/init.d/netperf {start|stop|restart|force-reload}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/netperf/netperf_2.3.bb b/recipes/netperf/netperf_2.3.bb
new file mode 100644
index 0000000000..ea6954e358
--- /dev/null
+++ b/recipes/netperf/netperf_2.3.bb
@@ -0,0 +1,49 @@
+SECTION = "console/network"
+DESCRIPTION="Network performance benchmark including tests for TCP, UDP, sockets, ATM and more."
+HOMEPAGE="http://www.netperf.org/"
+LICENSE="netperf"
+
+SRC_URI="${DEBIAN_MIRROR}/non-free/n/netperf/netperf_${PV}.orig.tar.gz \
+ file://init"
+
+inherit update-rc.d
+
+S = "${WORKDIR}/netperf-${PV}.orig"
+
+CFLAGS_append = " -DDO_UNIX -DDO_IPV6"
+
+do_compile() {
+ oe_runmake
+ sed -i 's:^\(NETHOME=\).*:${bindir}:' *_script
+}
+
+do_install() {
+ install -d ${D}${sbindir} ${D}${bindir} ${D}${sysconfdir}/init.d
+ install -m 4755 netperf ${D}${bindir}
+ install -m 4755 netserver ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/netperf
+
+ # man
+ install -d ${D}${mandir}/man1/
+ install -m 0644 netserver.man ${D}${mandir}/man1/netserver.1
+ install -m 0644 netperf.man ${D}${mandir}/man1/netperf.1
+
+ # move scripts to examples directory
+ install -d ${D}${docdir}/netperf/examples
+ install -m 0644 tcp_range_script ${D}${docdir}/netperf/examples/
+ install -m 0644 tcp_stream_script ${D}${docdir}/netperf/examples/
+ install -m 0644 tcp_rr_script ${D}${docdir}/netperf/examples/
+ install -m 0644 udp_stream_script ${D}${docdir}/netperf/examples/
+ install -m 0644 udp_rr_script ${D}${docdir}/netperf/examples/
+ install -m 0644 snapshot_script ${D}${docdir}/netperf/examples/
+
+ # docs ..
+ install -m 0644 ACKNWLDGMNTS ${D}${docdir}/netperf
+ install -m 0644 COPYRIGHT ${D}${docdir}/netperf
+ install -m 0644 Release_Notes ${D}${docdir}/netperf
+ install -m 0644 README ${D}${docdir}/netperf
+ install -m 0644 netperf.ps ${D}${docdir}/netperf
+}
+
+INITSCRIPT_NAME="netperf"
+INITSCRIPT_PARAMS="defaults"
diff --git a/recipes/netperf/netperf_2.4.4.bb b/recipes/netperf/netperf_2.4.4.bb
new file mode 100644
index 0000000000..0af225ffba
--- /dev/null
+++ b/recipes/netperf/netperf_2.4.4.bb
@@ -0,0 +1,41 @@
+DESCRIPTION="Network performance benchmark including tests for TCP, UDP, sockets, ATM and more."
+SECTION = "console/network"
+HOMEPAGE = "http://www.netperf.org/"
+LICENSE = "netperf"
+PR = "r1"
+
+SRC_URI="ftp://ftp.netperf.org/netperf/netperf-${PV}.tar.bz2 \
+ file://cpu_set.patch;patch=1 \
+ file://init"
+
+inherit update-rc.d autotools
+
+S = "${WORKDIR}/netperf-${PV}"
+
+# cpu_set.patch plus _GNU_SOURCE makes src/netlib.c compile with CPU_ macros
+CFLAGS_append = " -DDO_UNIX -DDO_IPV6 -D_GNU_SOURCE"
+
+do_install() {
+ install -d ${D}${sbindir} ${D}${bindir} ${D}${sysconfdir}/init.d
+ install -m 4755 src/netperf ${D}${bindir}
+ install -m 4755 src/netserver ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/netperf
+
+ # man
+ install -d ${D}${mandir}/man1/
+ install -m 0644 doc/netserver.man ${D}${mandir}/man1/netserver.1
+ install -m 0644 doc/netperf.man ${D}${mandir}/man1/netperf.1
+
+ # move scripts to examples directory
+ install -d ${D}${docdir}/netperf/examples
+ install -m 0644 doc/examples/*_script ${D}${docdir}/netperf/examples/
+
+ # docs ..
+ install -m 0644 COPYING ${D}${docdir}/netperf
+ install -m 0644 Release_Notes ${D}${docdir}/netperf
+ install -m 0644 README ${D}${docdir}/netperf
+ install -m 0644 doc/netperf_old.ps ${D}${docdir}/netperf
+}
+
+INITSCRIPT_NAME="netperf"
+INITSCRIPT_PARAMS="defaults"