aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/netsurf/netsurf_2.1.bb
diff options
context:
space:
mode:
authorDmitry Artamonow <mad_soft@inbox.ru>2009-05-23 22:45:05 +0000
committerTom Rini <trini@embeddedalley.com>2009-05-30 12:32:45 -0400
commit8fdae48f8fcadabf049b378a48a9dfea11ba02f4 (patch)
tree08041fea61476b332e94a2cbff1d2551d73ca5a4 /recipes/netsurf/netsurf_2.1.bb
parentb66852caed52146efcb1ae8145d535780ae6c943 (diff)
downloadopenembedded-8fdae48f8fcadabf049b378a48a9dfea11ba02f4.tar.gz
netsurf: add recipe for version 2.1
It's gtk+ version built with GIF,JPEG,PNG and without SVG,MNG and PDF printing support. Signed-off-by: Dmitry Artamonow <mad_soft@inbox.ru> Acked-by: Tom Rini <trini@embeddedalley.com>
Diffstat (limited to 'recipes/netsurf/netsurf_2.1.bb')
-rw-r--r--recipes/netsurf/netsurf_2.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/netsurf/netsurf_2.1.bb b/recipes/netsurf/netsurf_2.1.bb
new file mode 100644
index 0000000000..073f17f53b
--- /dev/null
+++ b/recipes/netsurf/netsurf_2.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Lightweight web browser capable of handling many of the \
+web standards in use today."
+HOMEPAGE = "http://www.netsurf-browser.org/"
+SECTION = "x11/network"
+LICENSE = "GPLv2"
+
+SRC_URI = "http://www.netsurf-browser.org/downloads/releases/netsurf-${PV}-src.tar.gz \
+ file://fix_makefile.patch;patch=1 \
+ file://debugxml_fix.patch;patch=1 \
+ file://netsurf.png \
+ file://netsurf.desktop \
+ file://Makefile.config"
+
+# Workaround for 2.1 tarball (unpacks into netsurf/, not netsurf-2.1/ )
+S = "${WORKDIR}/netsurf"
+
+DEPENDS = "gtk+ lemon-native re2c-native jpeg openssl curl libxml2 \
+ libglade hubbub libnsgif libnsbmp lcms"
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix}"
+
+do_configure() {
+ cp ${WORKDIR}/Makefile.config ${S}/
+}
+
+do_install() {
+ oe_runmake install
+ install -d ${D}/${datadir}/applications
+ install -d ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/netsurf.png ${D}/${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/netsurf.desktop ${D}/${datadir}/applications/
+}