aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/netsurf
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2010-11-20 15:44:01 +0200
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-11-20 14:57:45 +0100
commite800b4433fe87669e960aa35361852217fb5721f (patch)
tree0ea562247bde39f9d290b693ba687b57579ee2e8 /recipes/netsurf
parent18e9ef2b9b8f9c6353a44315f2efa410457b3ed2 (diff)
downloadopenembedded-e800b4433fe87669e960aa35361852217fb5721f.tar.gz
netsurf: Update netsurf, dependancies, add netsurf-fb recipe.
Updated netsurf-2.1 to netsurf-2.6 and updated fix_makefile.patch and debugxml_fix.patch for netsurf-2.6. Updated hubbub, libnsbmp, libnsgif, libparserutils from version 0.0.1 to version 0.0.2. Added two new recipes libcss and libwapcaplet which are needed by netsurf-2.6. Recipe libcss comes with patch no-werror.patch which removed the definition of -Werror from the makefile for building with gcc-4.5, as per the recommendation of the netsurf developers. Added netsurf-fb recipe, which builds netsurf with a framebuffer frontend, which is much lighter than the GTK frontend (and can run under a plain tty). The framebuffer frontend is set to use SDL because it's the most stable backend at the moment. Font rendering is handled by freetype and uses the DejaVu fonts. Added libnsfb, a framebuffer abstraction layer library needed by netsurf-fb along with a patch, no-werror.patch, which removes the definition of -Werror from the makefile for building with gcc-4.5. Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
Diffstat (limited to 'recipes/netsurf')
-rw-r--r--recipes/netsurf/hubbub_0.0.2.bb33
-rw-r--r--recipes/netsurf/libcss-0.0.2/no-werror.patch16
-rw-r--r--recipes/netsurf/libcss_0.0.2.bb30
-rw-r--r--recipes/netsurf/libnsbmp_0.0.2.bb27
-rw-r--r--recipes/netsurf/libnsfb/no-werror.patch12
-rw-r--r--recipes/netsurf/libnsfb_svn.bb32
-rw-r--r--recipes/netsurf/libnsgif_0.0.2.bb28
-rw-r--r--recipes/netsurf/libparserutils_0.0.2.bb39
-rw-r--r--recipes/netsurf/libwapcaplet_0.0.2.bb28
-rw-r--r--recipes/netsurf/netsurf-2.6/Makefile.config9
-rw-r--r--recipes/netsurf/netsurf-2.6/debugxml_fix.patch63
-rw-r--r--recipes/netsurf/netsurf-2.6/fix_makefile.patch12
-rw-r--r--recipes/netsurf/netsurf-2.6/netsurf.desktop10
-rw-r--r--recipes/netsurf/netsurf-2.6/netsurf.pngbin0 -> 9329 bytes
-rw-r--r--recipes/netsurf/netsurf-fb/Makefile.config19
-rw-r--r--recipes/netsurf/netsurf-fb/debugxml_fix.patch63
-rw-r--r--recipes/netsurf/netsurf-fb/fix_makefile.patch12
-rw-r--r--recipes/netsurf/netsurf-fb_svn.bb31
-rw-r--r--recipes/netsurf/netsurf_2.6.bb37
19 files changed, 501 insertions, 0 deletions
diff --git a/recipes/netsurf/hubbub_0.0.2.bb b/recipes/netsurf/hubbub_0.0.2.bb
new file mode 100644
index 0000000000..e488f8d6cb
--- /dev/null
+++ b/recipes/netsurf/hubbub_0.0.2.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Hubbub is an HTML5 compliant parsing library"
+HOMEPAGE = "http://www.netsurf-browser.org/projects/hubbub/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+DEPENDS = "libparserutils"
+
+SRC_URI = "http://www.netsurf-browser.org/projects/releases/hubbub-${PV}-src.tar.gz"
+
+PR = "r0"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
+
+# NOTE: we're using default buildmode here, which results in building only
+# static libraries (.a) Not a problem as hubbub is only used by Netsurf
+# at the moment
+
+do_stage() {
+ oe_libinstall -a -C build-OE/ libhubbub ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/hubbub
+ install -m 0644 include/hubbub/*.h ${STAGING_INCDIR}/hubbub
+}
+
+
+do_install() {
+ oe_runmake install
+}
+
+SRC_URI[md5sum] = "dbdc6bb13a71ce72384d7ee5891a0382"
+SRC_URI[sha256sum] = "fd195b91e80ef2ea1f558f94bd5bb5df89228b1af3e9b7c5c1039f65d506aa1d"
diff --git a/recipes/netsurf/libcss-0.0.2/no-werror.patch b/recipes/netsurf/libcss-0.0.2/no-werror.patch
new file mode 100644
index 0000000000..9becd0d682
--- /dev/null
+++ b/recipes/netsurf/libcss-0.0.2/no-werror.patch
@@ -0,0 +1,16 @@
+diff -ru libcss-0.0.2.old/Makefile libcss-0.0.2/Makefile
+--- libcss-0.0.2.old/Makefile 2010-09-21 22:32:37.000000000 +0300
++++ libcss-0.0.2/Makefile 2010-11-18 21:30:11.206667670 +0200
+@@ -13,12 +13,6 @@
+ WARNFLAGS := -Wall -W -Wundef -Wpointer-arith -Wcast-align \
+ -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes \
+ -Wmissing-declarations -Wnested-externs -pedantic
+-# BeOS/Haiku/AmigaOS4 standard library headers create warnings
+-ifneq ($(TARGET),beos)
+- ifneq ($(TARGET),AmigaOS)
+- WARNFLAGS := $(WARNFLAGS) -Werror
+- endif
+-endif
+ CFLAGS := -D_BSD_SOURCE -I$(CURDIR)/include/ \
+ -I$(CURDIR)/src $(WARNFLAGS) $(CFLAGS)
+ ifneq ($(GCCVER),2)
diff --git a/recipes/netsurf/libcss_0.0.2.bb b/recipes/netsurf/libcss_0.0.2.bb
new file mode 100644
index 0000000000..038c257268
--- /dev/null
+++ b/recipes/netsurf/libcss_0.0.2.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "LibCSS is a CSS parser and selection engine, written in C"
+HOMEPAGE = "http://www.netsurf-browser.org/projects/libcss/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+DEPENDS = "libwapcaplet"
+
+SRC_URI = "http://www.netsurf-browser.org/projects/releases/libcss-${PV}-src.tar.gz \
+ file://no-werror.patch"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
+
+# NOTE: we're using default buildmode here, which results in building only
+# static libraries (.a) Not a problem as libnsbmp is only used by Netsurf
+# at the moment
+
+do_stage() {
+ oe_libinstall -a -C build-OE/ libcss ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/libcss
+ install -m 0644 include/libcss/*.h ${STAGING_INCDIR}/libcss
+}
+
+do_install() {
+ oe_runmake install
+}
+
+SRC_URI[md5sum] = "3bbdd853a2f52db7ab0e2ea3597e62fa"
+SRC_URI[sha256sum] = "5205351cb3231173eded5885c22cb7d1c26ae66d3c30c48e2fb826719d78989a"
diff --git a/recipes/netsurf/libnsbmp_0.0.2.bb b/recipes/netsurf/libnsbmp_0.0.2.bb
new file mode 100644
index 0000000000..15802b504c
--- /dev/null
+++ b/recipes/netsurf/libnsbmp_0.0.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Libnsbmp is a decoding library for the BMP and ICO image file formats"
+HOMEPAGE = "http://www.netsurf-browser.org/projects/libnsbmp/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+
+SRC_URI = "http://www.netsurf-browser.org/projects/releases/libnsbmp-${PV}-src.tar.gz"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
+
+# NOTE: we're using default buildmode here, which results in building only
+# static libraries (.a) Not a problem as libnsbmp is only used by Netsurf
+# at the moment
+
+do_stage() {
+ oe_libinstall -a -C build-OE/ libnsbmp ${STAGING_LIBDIR}
+ install -m 0644 include/*.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ oe_runmake install
+}
+
+SRC_URI[md5sum] = "6196f5223f744c7c6493421d205e591c"
+SRC_URI[sha256sum] = "b18b9252b274699379cadff398e40c727930c9fcfb6bcf8ed3d346e7a93c720e"
diff --git a/recipes/netsurf/libnsfb/no-werror.patch b/recipes/netsurf/libnsfb/no-werror.patch
new file mode 100644
index 0000000000..defa22bb41
--- /dev/null
+++ b/recipes/netsurf/libnsfb/no-werror.patch
@@ -0,0 +1,12 @@
+diff -ru libnsfb.orig/Makefile libnsfb/Makefile
+--- libnsfb.orig/Makefile 2010-11-18 22:03:40.000000000 +0200
++++ libnsfb/Makefile 2010-11-18 22:04:51.803334238 +0200
+@@ -13,7 +13,7 @@
+ # Toolchain flags
+ WARNFLAGS := -Wall -Wextra -Wundef -Wpointer-arith -Wcast-align \
+ -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes \
+- -Wmissing-declarations -Wnested-externs -Werror -pedantic \
++ -Wmissing-declarations -Wnested-externs -pedantic \
+ -Wno-overlength-strings # For nsglobe.c
+ CFLAGS := -g -std=c99 -D_BSD_SOURCE -I$(CURDIR)/include/ \
+ -I$(CURDIR)/src $(WARNFLAGS) $(CFLAGS)
diff --git a/recipes/netsurf/libnsfb_svn.bb b/recipes/netsurf/libnsfb_svn.bb
new file mode 100644
index 0000000000..41d8d1b302
--- /dev/null
+++ b/recipes/netsurf/libnsfb_svn.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "LibNSFB is a framebuffer abstraction library, written in C"
+HOMEPAGE = "http://www.netsurf-browser.org/projects/libnsfb/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+DEPENDS = "xcb-util"
+
+SRCREV = "10944"
+PV = "0.0.1+svnr${SRCPV}"
+PR = "r0"
+
+SRC_URI = "svn://svn.netsurf-browser.org/trunk;module=libnsfb \
+ file://no-werror.patch"
+
+S = ${WORKDIR}/libnsfb
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
+
+# NOTE: we're using default buildmode here, which results in building only
+# static libraries (.a) Not a problem as libnsbmp is only used by Netsurf
+# at the moment
+
+do_stage() {
+ oe_libinstall -a -C build-OE/ libnsfb ${STAGING_LIBDIR}
+ install -m 0644 include/*.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ oe_runmake install
+}
diff --git a/recipes/netsurf/libnsgif_0.0.2.bb b/recipes/netsurf/libnsgif_0.0.2.bb
new file mode 100644
index 0000000000..f9184b64ac
--- /dev/null
+++ b/recipes/netsurf/libnsgif_0.0.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Libnsgif is a decoding library for the GIF image file format"
+HOMEPAGE = "http://www.netsurf-browser.org/projects/libnsgif/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+
+SRC_URI = "http://www.netsurf-browser.org/projects/releases/libnsgif-${PV}-src.tar.gz"
+PR = "r0"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
+
+# NOTE: we're using default buildmode here, which results in building only
+# static libraries (.a) Not a problem as libnsbmp is only used by Netsurf
+# at the moment
+
+do_stage() {
+ oe_libinstall -a -C build-OE/ libnsgif ${STAGING_LIBDIR}
+ install -m 0644 include/*.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ oe_runmake install
+}
+
+SRC_URI[md5sum] = "08dd5fc3ea330784f6c1e55c58244749"
+SRC_URI[sha256sum] = "dcb68be6a49ecc376cfa283d2f1e7eae035c75f99c0934ac80951e1777059617"
diff --git a/recipes/netsurf/libparserutils_0.0.2.bb b/recipes/netsurf/libparserutils_0.0.2.bb
new file mode 100644
index 0000000000..3e2623b399
--- /dev/null
+++ b/recipes/netsurf/libparserutils_0.0.2.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "LibParserUtils is a library for building efficient parsers"
+HOMEPAGE = "http://www.netsurf-browser.org/projects/libparserutils/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+
+SRC_URI = "http://www.netsurf-browser.org/projects/releases/libparserutils-${PV}-src.tar.gz"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
+
+# NOTE: we're using default buildmode here, which results in building only
+# static libraries (.a) Not a problem as libparserutils is only used by Netsurf
+# at the moment
+
+do_stage () {
+ oe_libinstall -a -C build-OE/ libparserutils ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/parserutils
+ install -d ${STAGING_INCDIR}/parserutils/charset
+ install -d ${STAGING_INCDIR}/parserutils/input
+ install -d ${STAGING_INCDIR}/parserutils/utils
+ install -m 0644 include/parserutils/*.h ${STAGING_INCDIR}/parserutils
+ install -m 0644 include/parserutils/charset/*.h \
+ ${STAGING_INCDIR}/parserutils/charset
+ install -m 0644 include/parserutils/input/*.h \
+ ${STAGING_INCDIR}/parserutils/input
+ install -m 0644 include/parserutils/utils/*.h \
+ ${STAGING_INCDIR}/parserutils/utils
+}
+
+
+do_install() {
+ oe_runmake install
+}
+
+SRC_URI[md5sum] = "5b2e4ddeebe451cc801ccd6e7da06f87"
+SRC_URI[sha256sum] = "769be8da5c9a012d2d968fc814567c1067febf3d3df5e18f1ae2521324dcd923"
diff --git a/recipes/netsurf/libwapcaplet_0.0.2.bb b/recipes/netsurf/libwapcaplet_0.0.2.bb
new file mode 100644
index 0000000000..4954933a62
--- /dev/null
+++ b/recipes/netsurf/libwapcaplet_0.0.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "LibWapcaplet is a string internment library, written in C"
+HOMEPAGE = "http://www.netsurf-browser.org/projects/libwapcaplet/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+
+SRC_URI = "http://www.netsurf-browser.org/projects/releases/libwapcaplet-${PV}-src.tar.gz"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
+
+# NOTE: we're using default buildmode here, which results in building only
+# static libraries (.a) Not a problem as libnsbmp is only used by Netsurf
+# at the moment
+
+do_stage() {
+ oe_libinstall -a -C build-OE/ libwapcaplet ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/libwapcaplet
+ install -m 0644 include/libwapcaplet/*.h ${STAGING_INCDIR}/libwapcaplet
+}
+
+do_install() {
+ oe_runmake install
+}
+
+SRC_URI[md5sum] = "c73b5ff5fce55819cc698e8cb486d5eb"
+SRC_URI[sha256sum] = "4246215ceff620a882d170b3ef4abaa04fcb4190122a62b6e9b3e662ab880869"
diff --git a/recipes/netsurf/netsurf-2.6/Makefile.config b/recipes/netsurf/netsurf-2.6/Makefile.config
new file mode 100644
index 0000000000..72c86003f5
--- /dev/null
+++ b/recipes/netsurf/netsurf-2.6/Makefile.config
@@ -0,0 +1,9 @@
+override NETSURF_USE_BMP := YES
+override NETSURF_USE_GIF := YES
+override NETSURF_USE_JPEG := YES
+override NETSURF_USE_PNG := YES
+override NETSURF_USE_MNG := NO
+override NETSURF_USE_HARU_PDF := NO
+override NETSURF_USE_RSVG := NO
+override NETSURF_USE_ROSPRITE := NO
+
diff --git a/recipes/netsurf/netsurf-2.6/debugxml_fix.patch b/recipes/netsurf/netsurf-2.6/debugxml_fix.patch
new file mode 100644
index 0000000000..df7b635140
--- /dev/null
+++ b/recipes/netsurf/netsurf-2.6/debugxml_fix.patch
@@ -0,0 +1,63 @@
+diff -ru netsurf-old/gtk/gtk_scaffolding.c netsurf/gtk/gtk_scaffolding.c
+--- netsurf-old/gtk/gtk_scaffolding.c 2010-09-18 23:53:43.000000000 +0300
++++ netsurf/gtk/gtk_scaffolding.c 2010-11-18 18:16:07.650000875 +0200
+@@ -27,7 +27,6 @@
+ #include <unistd.h>
+ #include <gtk/gtk.h>
+ #include <gdk-pixbuf/gdk-pixbuf.h>
+-#include <libxml/debugXML.h>
+ #include "gtk/gtk_scaffolding.h"
+ #include "content/content.h"
+ #include "content/hlcache.h"
+@@ -1099,50 +1098,7 @@
+
+ MULTIHANDLER(savedomtree)
+ {
+- GtkWidget *save_dialog;
+-
+- save_dialog = gtk_file_chooser_dialog_new("Save File", g->window,
+- GTK_FILE_CHOOSER_ACTION_SAVE,
+- GTK_STOCK_CANCEL, GTK_RESPONSE_CANCEL,
+- GTK_STOCK_SAVE, GTK_RESPONSE_ACCEPT,
+- NULL);
+-
+- gtk_file_chooser_set_current_folder(GTK_FILE_CHOOSER(save_dialog),
+- getenv("HOME") ? getenv("HOME") : "/");
+-
+- gtk_file_chooser_set_current_name(GTK_FILE_CHOOSER(save_dialog),
+- "domtree.txt");
+-
+- if (gtk_dialog_run(GTK_DIALOG(save_dialog)) == GTK_RESPONSE_ACCEPT) {
+- gchar *filename = gtk_file_chooser_get_filename(
+- GTK_FILE_CHOOSER(save_dialog));
+- FILE *fh;
+- LOG(("Saving dom tree to %s...\n", filename));
+-
+- fh = fopen((const char *) filename, "w");
+- if (fh == NULL) {
+- warn_user("Error saving box tree dump.",
+- "Unable to open file for writing.");
+- } else {
+- struct browser_window *bw;
+- bw = gui_window_get_browser_window(g->top_level);
+-
+- if (bw->current_content &&
+- content_get_type(bw->current_content) ==
+- CONTENT_HTML) {
+- xmlDebugDumpDocument(fh,
+- html_get_document(bw->current_content));
+- }
+-
+- fclose(fh);
+- }
+-
+- g_free(filename);
+- }
+-
+- gtk_widget_destroy(save_dialog);
+-
+- return TRUE;
++ return FALSE;
+ }
+
+
diff --git a/recipes/netsurf/netsurf-2.6/fix_makefile.patch b/recipes/netsurf/netsurf-2.6/fix_makefile.patch
new file mode 100644
index 0000000000..a8cea0f34f
--- /dev/null
+++ b/recipes/netsurf/netsurf-2.6/fix_makefile.patch
@@ -0,0 +1,12 @@
+diff -ru netsurf-old/Makefile netsurf/Makefile
+--- netsurf-old/Makefile 2010-09-21 22:35:54.000000000 +0300
++++ netsurf/Makefile 2010-11-18 18:13:37.793334209 +0200
+@@ -842,7 +842,7 @@
+ @cp -RL gtk/res/toolbarIndices $(DESTDIR)$(NETSURF_GTK_RESOURCES)
+ @cp -RL gtk/res/Aliases $(DESTDIR)$(NETSURF_GTK_RESOURCES)
+ @cp -RL gtk/res/SearchEngines $(DESTDIR)$(NETSURF_GTK_RESOURCES)
+- @cp -RL gtk/res/docs $(DESTDIR)$(NETSURF_GTK_RESOURCES)
++# @cp -RL gtk/res/docs $(DESTDIR)$(NETSURF_GTK_RESOURCES)
+ @cp -RL gtk/res/themes $(DESTDIR)$(NETSURF_GTK_RESOURCES)
+ @# Install translations
+ @cp -RL gtk/res/C $(DESTDIR)$(NETSURF_GTK_RESOURCES)
diff --git a/recipes/netsurf/netsurf-2.6/netsurf.desktop b/recipes/netsurf/netsurf-2.6/netsurf.desktop
new file mode 100644
index 0000000000..4188d3019d
--- /dev/null
+++ b/recipes/netsurf/netsurf-2.6/netsurf.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Name=NetSurf
+Comment=NetSurf Web Browser
+GenericName=Web Browser
+Icon=netsurf
+Exec=netsurf
+Terminal=false
+StartupNotify=false
+Categories=Network;WebBrowser;
diff --git a/recipes/netsurf/netsurf-2.6/netsurf.png b/recipes/netsurf/netsurf-2.6/netsurf.png
new file mode 100644
index 0000000000..3064e5d4f3
--- /dev/null
+++ b/recipes/netsurf/netsurf-2.6/netsurf.png
Binary files differ
diff --git a/recipes/netsurf/netsurf-fb/Makefile.config b/recipes/netsurf/netsurf-fb/Makefile.config
new file mode 100644
index 0000000000..ebb6d4eef1
--- /dev/null
+++ b/recipes/netsurf/netsurf-fb/Makefile.config
@@ -0,0 +1,19 @@
+override NETSURF_USE_BMP := YES
+override NETSURF_USE_GIF := YES
+override NETSURF_USE_JPEG := YES
+override NETSURF_USE_PNG := YES
+override NETSURF_USE_MNG := NO
+override NETSURF_USE_HARU_PDF := NO
+override NETSURF_USE_RSVG := NO
+override NETSURF_USE_ROSPRITE := NO
+override NETSURF_FB_FRONTEND := sdl
+
+override NETSURF_FB_FONTLIB := freetype
+override NETSURF_FB_FONT_SANS_SERIF := /usr/share/fonts/truetype/DejaVuSans.ttf
+override NETSURF_FB_FONT_SANS_SERIF_BOLD := /usr/share/fonts/truetype/DejaVuSans-Bold.ttf
+override NETSURF_FB_FONT_SANS_SERIF_ITALIC := /usr/share/fonts/truetype/DejaVuSans-Oblique.ttf
+override NETSURF_FB_FONT_SANS_SERIF_ITALIC_BOLD := /usr/share/fonts/truetype/DejaVuSans-BoldOblique.ttf
+override NETSURF_FB_FONT_SERIF := /usr/share/fonts/truetype/DejaVuSerif.ttf
+override NETSURF_FB_FONT_SERIF_BOLD := /usr/share/fonts/truetype/DejaVuSerif-Bold.ttf
+override NETSURF_FB_FONT_MONOSPACE := /usr/share/fonts/truetype/DejaVuSansMono.ttf
+override NETSURF_FB_FONT_MONOSPACE_BOLD := /usr/share/fonts/truetype/DejaVuSansMono-Bold.ttf
diff --git a/recipes/netsurf/netsurf-fb/debugxml_fix.patch b/recipes/netsurf/netsurf-fb/debugxml_fix.patch
new file mode 100644
index 0000000000..df7b635140
--- /dev/null
+++ b/recipes/netsurf/netsurf-fb/debugxml_fix.patch
@@ -0,0 +1,63 @@
+diff -ru netsurf-old/gtk/gtk_scaffolding.c netsurf/gtk/gtk_scaffolding.c
+--- netsurf-old/gtk/gtk_scaffolding.c 2010-09-18 23:53:43.000000000 +0300
++++ netsurf/gtk/gtk_scaffolding.c 2010-11-18 18:16:07.650000875 +0200
+@@ -27,7 +27,6 @@
+ #include <unistd.h>
+ #include <gtk/gtk.h>
+ #include <gdk-pixbuf/gdk-pixbuf.h>
+-#include <libxml/debugXML.h>
+ #include "gtk/gtk_scaffolding.h"
+ #include "content/content.h"
+ #include "content/hlcache.h"
+@@ -1099,50 +1098,7 @@
+
+ MULTIHANDLER(savedomtree)
+ {
+- GtkWidget *save_dialog;
+-
+- save_dialog = gtk_file_chooser_dialog_new("Save File", g->window,
+- GTK_FILE_CHOOSER_ACTION_SAVE,
+- GTK_STOCK_CANCEL, GTK_RESPONSE_CANCEL,
+- GTK_STOCK_SAVE, GTK_RESPONSE_ACCEPT,
+- NULL);
+-
+- gtk_file_chooser_set_current_folder(GTK_FILE_CHOOSER(save_dialog),
+- getenv("HOME") ? getenv("HOME") : "/");
+-
+- gtk_file_chooser_set_current_name(GTK_FILE_CHOOSER(save_dialog),
+- "domtree.txt");
+-
+- if (gtk_dialog_run(GTK_DIALOG(save_dialog)) == GTK_RESPONSE_ACCEPT) {
+- gchar *filename = gtk_file_chooser_get_filename(
+- GTK_FILE_CHOOSER(save_dialog));
+- FILE *fh;
+- LOG(("Saving dom tree to %s...\n", filename));
+-
+- fh = fopen((const char *) filename, "w");
+- if (fh == NULL) {
+- warn_user("Error saving box tree dump.",
+- "Unable to open file for writing.");
+- } else {
+- struct browser_window *bw;
+- bw = gui_window_get_browser_window(g->top_level);
+-
+- if (bw->current_content &&
+- content_get_type(bw->current_content) ==
+- CONTENT_HTML) {
+- xmlDebugDumpDocument(fh,
+- html_get_document(bw->current_content));
+- }
+-
+- fclose(fh);
+- }
+-
+- g_free(filename);
+- }
+-
+- gtk_widget_destroy(save_dialog);
+-
+- return TRUE;
++ return FALSE;
+ }
+
+
diff --git a/recipes/netsurf/netsurf-fb/fix_makefile.patch b/recipes/netsurf/netsurf-fb/fix_makefile.patch
new file mode 100644
index 0000000000..a8cea0f34f
--- /dev/null
+++ b/recipes/netsurf/netsurf-fb/fix_makefile.patch
@@ -0,0 +1,12 @@
+diff -ru netsurf-old/Makefile netsurf/Makefile
+--- netsurf-old/Makefile 2010-09-21 22:35:54.000000000 +0300
++++ netsurf/Makefile 2010-11-18 18:13:37.793334209 +0200
+@@ -842,7 +842,7 @@
+ @cp -RL gtk/res/toolbarIndices $(DESTDIR)$(NETSURF_GTK_RESOURCES)
+ @cp -RL gtk/res/Aliases $(DESTDIR)$(NETSURF_GTK_RESOURCES)
+ @cp -RL gtk/res/SearchEngines $(DESTDIR)$(NETSURF_GTK_RESOURCES)
+- @cp -RL gtk/res/docs $(DESTDIR)$(NETSURF_GTK_RESOURCES)
++# @cp -RL gtk/res/docs $(DESTDIR)$(NETSURF_GTK_RESOURCES)
+ @cp -RL gtk/res/themes $(DESTDIR)$(NETSURF_GTK_RESOURCES)
+ @# Install translations
+ @cp -RL gtk/res/C $(DESTDIR)$(NETSURF_GTK_RESOURCES)
diff --git a/recipes/netsurf/netsurf-fb_svn.bb b/recipes/netsurf/netsurf-fb_svn.bb
new file mode 100644
index 0000000000..3d384be1ba
--- /dev/null
+++ b/recipes/netsurf/netsurf-fb_svn.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "NetSurf is a lightweight, multi-platform web browser."
+HOMEPAGE = "http://www.netsurf-browser.org/"
+SECTION = "x11/network"
+LICENSE = "GPLv2"
+SRCREV = "10946"
+PV = "2.6+svnr${SRCPV}"
+PR = "r0"
+
+DEPENDS = "virtual/libsdl lemon-native re2c-native jpeg openssl curl \
+ libxml2 hubbub libcss libnsfb libnsgif libnsbmp lcms"
+
+RDEPENDS_${PN} = "ttf-dejavu-sans ttf-dejavu-serif ttf-dejavu-sans-mono"
+
+SRC_URI = "svn://svn.netsurf-browser.org/trunk;module=netsurf \
+ file://fix_makefile.patch \
+ file://debugxml_fix.patch \
+ file://Makefile.config"
+
+S = "${WORKDIR}/netsurf"
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix}"
+
+FILES_${PN} += " /usr/share/netsurf "
+
+do_configure() {
+ cp ${WORKDIR}/Makefile.config ${S}/
+}
+
+do_install() {
+ oe_runmake TARGET=framebuffer install
+}
diff --git a/recipes/netsurf/netsurf_2.6.bb b/recipes/netsurf/netsurf_2.6.bb
new file mode 100644
index 0000000000..d4b992326e
--- /dev/null
+++ b/recipes/netsurf/netsurf_2.6.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Lightweight web browser capable of handling many of the \
+web standards in use today."
+HOMEPAGE = "http://www.netsurf-browser.org/"
+SECTION = "x11/network"
+LICENSE = "GPLv2"
+
+SRC_URI = "http://www.netsurf-browser.org/downloads/releases/netsurf-${PV}-src.tar.gz \
+ file://fix_makefile.patch \
+ file://debugxml_fix.patch \
+ file://netsurf.png \
+ file://netsurf.desktop \
+ file://Makefile.config"
+
+PR = "r0"
+
+# Workaround for 2.6 tarball (unpacks into netsurf/, not netsurf-2.6/ )
+S = "${WORKDIR}/netsurf"
+
+DEPENDS = "gtk+ lemon-native re2c-native jpeg openssl curl libxml2 \
+ libglade hubbub libcss libnsgif libnsbmp lcms"
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix}"
+
+do_configure() {
+ cp ${WORKDIR}/Makefile.config ${S}/
+}
+
+do_install() {
+ oe_runmake install
+ install -d ${D}/${datadir}/applications
+ install -d ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/netsurf.png ${D}/${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/netsurf.desktop ${D}/${datadir}/applications/
+}
+
+SRC_URI[md5sum] = "8653789d2ede6dbbfe79882afc7538fc"
+SRC_URI[sha256sum] = "366ad15e1879776b54882fd6f3fa4e421a049644c029e4c14fc163b76c6fc190"