aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/netsurf
diff options
context:
space:
mode:
authorDmitry Artamonow <mad_soft@inbox.ru>2009-05-23 10:35:16 +0000
committerTom Rini <trini@embeddedalley.com>2009-05-30 12:32:44 -0400
commitf18439433c8795e31da60d20a2c49fb343db9dfb (patch)
treed98c243eec22d015688852ad3a8c3714a516a55f /recipes/netsurf
parent79d50d9115e5780660f54ae986a2857602503c8c (diff)
downloadopenembedded-f18439433c8795e31da60d20a2c49fb343db9dfb.tar.gz
libnsbmp: add recipe for version 0.0.1
libnsbmp is BMP and ICO decoding library. Currently only Netsurf browser is using it, so we build just static library. Signed-off-by: Dmitry Artamonow <mad_soft@inbox.ru> Acked-by: Tom Rini <trini@embeddedalley.com>
Diffstat (limited to 'recipes/netsurf')
-rw-r--r--recipes/netsurf/libnsbmp_0.0.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/netsurf/libnsbmp_0.0.1.bb b/recipes/netsurf/libnsbmp_0.0.1.bb
new file mode 100644
index 0000000000..a17cd31746
--- /dev/null
+++ b/recipes/netsurf/libnsbmp_0.0.1.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Libnsbmp is a decoding library for the BMP and ICO image file formats"
+HOMEPAGE = "http://www.netsurf-browser.org/projects/libnsbmp/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+
+SRC_URI = "http://www.netsurf-browser.org/projects/releases/libnsbmp-${PV}-src.tar.gz"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
+
+# NOTE: we're using default buildmode here, which results in building only
+# static libraries (.a) Not a problem as libnsbmp is only used by Netsurf
+# at the moment
+
+do_stage() {
+ oe_libinstall -a -C build-OE/ libnsbmp ${STAGING_LIBDIR}
+ install -m 0644 include/*.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ oe_runmake install
+}