aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nodejs
diff options
context:
space:
mode:
authorAJ ONeal <coolaj86+fastr@gmail.com>2010-09-15 07:05:32 +0000
committerCliff Brake <cbrake@bec-systems.com>2010-09-15 13:44:45 -0400
commite7a8e95df93c73a7c0114ee0dd937ea0d51ca908 (patch)
treebd98f9cf3a463cc9e216c3f786ff8e876c1faff1 /recipes/nodejs
parent1ab0da8b2b22938def057b223eeb1091024c31ca (diff)
downloadopenembedded-e7a8e95df93c73a7c0114ee0dd937ea0d51ca908.tar.gz
nodejs: replaced v0.2.0 with v0.2.1
* now includes node-waf and node-repl * updated pathname in libev-cross-cc and libev-cross-cc * removed patch which is no longer necessary (applied upstream) Signed-off-by: AJ ONeal <coolaj86@gmail.com>
Diffstat (limited to 'recipes/nodejs')
-rw-r--r--recipes/nodejs/files/libev-cross-cc.patch6
-rw-r--r--recipes/nodejs/files/node-cross-cc.patch8
-rw-r--r--recipes/nodejs/files/node-dont-include-hosts-usr-include.patch22
-rw-r--r--recipes/nodejs/nodejs_0.2.0.bb32
-rw-r--r--recipes/nodejs/nodejs_0.2.1.bb28
5 files changed, 35 insertions, 61 deletions
diff --git a/recipes/nodejs/files/libev-cross-cc.patch b/recipes/nodejs/files/libev-cross-cc.patch
index 446015b3cf..4dd34f4855 100644
--- a/recipes/nodejs/files/libev-cross-cc.patch
+++ b/recipes/nodejs/files/libev-cross-cc.patch
@@ -1,7 +1,7 @@
-diff --git node-v0.2.0/deps/libev/wscript.orig node-v0.2.0/deps/libev/wscript
+diff --git node-v0.2.1/deps/libev/wscript.orig node-v0.2.1/deps/libev/wscript
index 19e7bb2..f0a3d3b 100644
---- node-v0.2.0/deps/libev/wscript.orig
-+++ node-v0.2.0/deps/libev/wscript
+--- node-v0.2.1/deps/libev/wscript.orig
++++ node-v0.2.1/deps/libev/wscript
@@ -52,7 +52,12 @@ def configure(conf):
return 0;
}
diff --git a/recipes/nodejs/files/node-cross-cc.patch b/recipes/nodejs/files/node-cross-cc.patch
index 48a6226a4b..0d15afc28a 100644
--- a/recipes/nodejs/files/node-cross-cc.patch
+++ b/recipes/nodejs/files/node-cross-cc.patch
@@ -1,7 +1,7 @@
-diff --git node-v0.2.0/wscript.orig node-v0.2.0/wscript
-index df9ef53..a55d464 100644
---- node-v0.2.0/wscript.orig
-+++ node-v0.2.0/wscript
+diff --git node-v0.2.1/wscript.orig node-v0.2.1/wscript
+index 9c4243c..3cf6689 100644
+--- node-v0.2.1/wscript.orig
++++ node-v0.2.1/wscript
@@ -326,6 +326,9 @@ def v8_cmd(bld, variant):
arch = ""
if bld.env['DEST_CPU'] == 'x86_64':
diff --git a/recipes/nodejs/files/node-dont-include-hosts-usr-include.patch b/recipes/nodejs/files/node-dont-include-hosts-usr-include.patch
deleted file mode 100644
index edbf7c4671..0000000000
--- a/recipes/nodejs/files/node-dont-include-hosts-usr-include.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git node-v0.2.0/wscript.orig node-v0.2.0/wscript
-index 3c5ebc5..905bd58 100644
---- node-v0.2.0/wscript.orig
-+++ node-v0.2.0/wscript
-@@ -162,11 +162,12 @@ def configure(conf):
- if Options.options.efence:
- conf.check(lib='efence', libpath=['/usr/lib', '/usr/local/lib'], uselib_store='EFENCE')
-
-- if not conf.check(lib="execinfo", includes=['/usr/include', '/usr/local/include'], libpath=['/usr/lib', '/usr/local/lib'], uselib_store="EXECINFO"):
-- # Note on Darwin/OS X: This will fail, but will still be used as the
-- # execinfo stuff are part of the standard library.
-- if sys.platform.startswith("freebsd"):
-- conf.fatal("Install the libexecinfo port from /usr/ports/devel/libexecinfo.")
-+ # OpenEmbedded doesn't like us checking here
-+ #if not conf.check(lib="execinfo", includes=['/usr/include', '/usr/local/include'], libpath=['/usr/lib', '/usr/local/lib'], uselib_store="EXECINFO"):
-+ # # Note on Darwin/OS X: This will fail, but will still be used as the
-+ # # execinfo stuff are part of the standard library.
-+ # if sys.platform.startswith("freebsd"):
-+ # conf.fatal("Install the libexecinfo port from /usr/ports/devel/libexecinfo.")
-
- if not Options.options.without_ssl:
- if conf.check_cfg(package='openssl',
diff --git a/recipes/nodejs/nodejs_0.2.0.bb b/recipes/nodejs/nodejs_0.2.0.bb
deleted file mode 100644
index 7dfa04ef69..0000000000
--- a/recipes/nodejs/nodejs_0.2.0.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
-HOMEPAGE = "http://nodejs.org"
-LICENSE = "MIT"
-
-DEPENDS = "openssl"
-
-SRC_URI = " \
- http://nodejs.org/dist/node-v${PV}.tar.gz \
- file://node-cross-cc.patch \
- file://libev-cross-cc.patch \
- file://node-dont-include-hosts-usr-include.patch \
-"
-SRC_URI[md5sum] = "99a6dacc44b3f9c6ec376ccb446dd0b8"
-SRC_URI[sha256sum] = "3d3eff9287c9917af4044f3cef99ae5b17946710a71e83039de4fcb4b0a26631"
-
-S = "${WORKDIR}/node-v${PV}"
-
-# v8 errors out if you have set CCACHE
-CCACHE = ""
-
-do_configure () {
- ./configure --prefix=${prefix} --without-snapshot
-}
-
-do_compile () {
- make
-}
-
-do_install () {
- DESTDIR=${D} oe_runmake install
-}
-
diff --git a/recipes/nodejs/nodejs_0.2.1.bb b/recipes/nodejs/nodejs_0.2.1.bb
new file mode 100644
index 0000000000..5479118f8c
--- /dev/null
+++ b/recipes/nodejs/nodejs_0.2.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
+HOMEPAGE = "http://nodejs.org"
+LICENSE = "MIT"
+DEPENDS = "openssl"
+SRC_URI = " \
+ http://nodejs.org/dist/node-v${PV}.tar.gz \
+ file://libev-cross-cc.patch \
+ file://node-cross-cc.patch \
+"
+SRC_URI[md5sum] = "c6051dd216817bf0f95bea80c42cf262"
+SRC_URI[sha256sum] = "5bb7d084b2138ce43fcb34739ed894379c450a1dd569a1c710405bc39d2861c2"
+S = "${WORKDIR}/node-v${PV}"
+do_configure () {
+ ./configure --without-snapshot
+}
+do_compile () {
+ make
+}
+do_install () {
+ #oe_runmake install # doesn't install to correct location
+
+ # This works
+ install -d ${D}${bindir}/
+ install -m 0755 ${S}/build/default/node ${D}${bindir}/
+ install -m 0755 ${S}/bin/node-waf ${D}${bindir}/
+ install -m 0755 ${S}/bin/node-repl ${D}${bindir}/
+}
+FILES_${PN} = "${bindir}/node ${bindir}/node-repl ${bindir}/node-waf"