aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/docbook
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nonworking/docbook
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nonworking/docbook')
-rw-r--r--recipes/nonworking/docbook/docbook_4.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/nonworking/docbook/docbook_4.2.bb b/recipes/nonworking/docbook/docbook_4.2.bb
new file mode 100644
index 0000000000..ee1ab674cd
--- /dev/null
+++ b/recipes/nonworking/docbook/docbook_4.2.bb
@@ -0,0 +1,19 @@
+SRC_URI = http://www.oasis-open.org/docbook/sgml/${PV}/docbook-${PV}.zip
+S = ${WORKDIR}
+
+installfiles = calstblx.dtd ChangeLog dbgenent.mod dbnotnx.mod docbook.cat docbook.dtd README \
+catalog.xml dbcentx.mod dbhierx.mod dbpoolx.mod docbook.dcl docbookx.dtd soextblx.dtd
+
+do_stage () {
+ install -d ${STAGING_DATADIR}/sgml/docbook_${PV}
+ for i in ${installfiles}; do
+ install -m 0644 $i ${STAGING_DATADIR}/sgml/docbook_${PV}
+ done
+}
+
+do_install () {
+ install -d ${D}/${datadir}/sgml/docbook_${PV}
+ for i in ${installfiles}; do
+ install -m 0644 $i ${D}/${datadir}/sgml/docbook_${PV}
+ done
+}