aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/images
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-08-28 11:46:43 -0700
committerKhem Raj <raj.khem@gmail.com>2010-09-01 13:46:04 -0700
commit87350d079f980c84bba2bb4acdc3a598dc3de279 (patch)
tree12ef150c9c7b0cfa8d362495d9da5fd91986a754 /recipes/nonworking/images
parent4bbb807bf585dac8cd0d3f555c7344a09bbe5bea (diff)
downloadopenembedded-87350d079f980c84bba2bb4acdc3a598dc3de279.tar.gz
recipes: Move some recipes to nonworking for getting bitbake world.
* If a recipes has DEPENDS on another recipe which is nonworking then move the recipe in question to nonworking too. Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nonworking/images')
-rw-r--r--recipes/nonworking/images/maemo-image.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/nonworking/images/maemo-image.bb b/recipes/nonworking/images/maemo-image.bb
new file mode 100644
index 0000000000..c0498bb910
--- /dev/null
+++ b/recipes/nonworking/images/maemo-image.bb
@@ -0,0 +1,20 @@
+#
+# Meta package for maemo based system image
+#
+
+GUI_MACHINE_CLASS ?= "none"
+
+MAEMO_EXTRA_DEPENDS = "scap dosfstools"
+MAEMO_EXTRA_INSTALL = "osso-af-services osso-af-base-apps scap dosfstools"
+
+XSERVER ?= "xserver-kdrive-omap"
+
+DEPENDS = "${MACHINE_TASK_PROVIDER} \
+ meta-maemo \
+ ${MAEMO_EXTRA_DEPENDS}"
+
+IMAGE_INSTALL = "${MACHINE_TASK_PROVIDER} maemo-task-base maemo-task-theme \
+ maemo-task-apps ${MAEMO_EXTRA_INSTALL} \
+ ${XSERVER}"
+
+inherit image