aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 10:39:50 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 20:16:13 +0200
commit16f464bd8cff6b6a27d9bfe691f7adc875d01ac2 (patch)
treed235ad1dba36225ca211cc7c606ecaab4ff883c5 /recipes/nonworking
parent44985d56bc556786812a0a02d6219afd31a7381d (diff)
downloadopenembedded-16f464bd8cff6b6a27d9bfe691f7adc875d01ac2.tar.gz
recipes: move checksums to recipes from checksums.ini, part 2 manual adjustement
* all: multiple checked items in SRC_URI (needs name= param) * other fixes like non-existent URL, checksums moved ot .inc or included .bb (ie for -native) * ... * tested with micro/micro-uclibc/Angstrom/SHR with SOURCE_MIRROR_FETCH="True" (ignoring COMPATIBLE_* * also tested -c fetch with s/SRC_URI_append_[^ ]*/SRC_URI_append/g and s/SRC_URI_[^ ]*/SRC_URI_append/g to catch all URLs used only for distro/machine/virtual override (see http://build.shr-project.org/tests/jama/SRC_URI.removeOverrides.patch) * in case I downloaded different checksum then what was in checksums.ini I used the old one from checksums.ini and put my checksum in comment * I'll send to ML list of recipes which cannot be downloaded (weren't converted) and where I got different checksums Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/nonworking')
-rw-r--r--recipes/nonworking/bogl/libbogl_0.1.9.bb12
-rw-r--r--recipes/nonworking/e2fsprogs/e2fsprogs_1.41.2.bb3
-rw-r--r--recipes/nonworking/gpe-contacts/gpe-contacts-hildon_0.40.bb3
-rw-r--r--recipes/nonworking/gpe-contacts/gpe-contacts-hildon_0.42.bb3
-rw-r--r--recipes/nonworking/gtk+/gtk+-directfb_2.10.14.bb3
-rw-r--r--recipes/nonworking/monotone-viz/monotone-viz_0.11.bb2
-rw-r--r--recipes/nonworking/php/php-native_4.4.4.bb3
-rw-r--r--recipes/nonworking/php/php_4.4.4.bb3
-rw-r--r--recipes/nonworking/unionfs/unionfs-modules_1.0.11.bb3
9 files changed, 28 insertions, 7 deletions
diff --git a/recipes/nonworking/bogl/libbogl_0.1.9.bb b/recipes/nonworking/bogl/libbogl_0.1.9.bb
index 43c155a967..c2425c7d8e 100644
--- a/recipes/nonworking/bogl/libbogl_0.1.9.bb
+++ b/recipes/nonworking/bogl/libbogl_0.1.9.bb
@@ -8,18 +8,18 @@ SRC_URI = "${DEBIAN_MIRROR}/main/b/bogl/bogl_${PV}-${PR}.tar.gz"
S = "${WORKDIR}/bogl"
do_compile() {
- ln -sf ${STAGING_BINDIR_NATIVE}/bdftobogl .
- ln -sf ${STAGING_BINDIR_NATIVE}/pngtobogl .
- oe_runmake libbogl.so.0.1 libbogl.a
+ln -sf ${STAGING_BINDIR_NATIVE}/bdftobogl .
+ln -sf ${STAGING_BINDIR_NATIVE}/pngtobogl .
+oe_runmake libbogl.so.0.1 libbogl.a
}
do_stage() {
- oe_soinstall libbogl.so.0.1 ${STAGING_LIBDIR}/
- install bogl*.h ${STAGING_INCDIR}/
+oe_soinstall libbogl.so.0.1 ${STAGING_LIBDIR}/
+install bogl*.h ${STAGING_INCDIR}/
}
do_install() {
- oe_soinstall libbogl.so.0.1 ${STAGING_LIBDIR}/
+oe_soinstall libbogl.so.0.1 ${STAGING_LIBDIR}/
}
SRC_URI[md5sum] = "644c4bc8d45b3be8132f120fd89bf72a"
diff --git a/recipes/nonworking/e2fsprogs/e2fsprogs_1.41.2.bb b/recipes/nonworking/e2fsprogs/e2fsprogs_1.41.2.bb
index 1b139d2a9c..cbfddb373d 100644
--- a/recipes/nonworking/e2fsprogs/e2fsprogs_1.41.2.bb
+++ b/recipes/nonworking/e2fsprogs/e2fsprogs_1.41.2.bb
@@ -85,3 +85,6 @@ pkg_prerm_e2fsprogs-mke2fs () {
update-alternatives --remove mkfs.ext3 mkfs.ext3.${PN}
}
+
+SRC_URI[md5sum] = "1c1c5177aea9a23b45b9b3f5b3241819"
+SRC_URI[sha256sum] = "635d6d07e5a4d615e599c051166af965baa754f9ff7435e746de1a5d2a5c0d56" \ No newline at end of file
diff --git a/recipes/nonworking/gpe-contacts/gpe-contacts-hildon_0.40.bb b/recipes/nonworking/gpe-contacts/gpe-contacts-hildon_0.40.bb
index e7eeaf0de0..240a678b47 100644
--- a/recipes/nonworking/gpe-contacts/gpe-contacts-hildon_0.40.bb
+++ b/recipes/nonworking/gpe-contacts/gpe-contacts-hildon_0.40.bb
@@ -10,3 +10,6 @@ EXTRA_OECONF += "--enable-hildon"
S = "${WORKDIR}/gpe-contacts-${PV}"
+
+SRC_URI[md5sum] = "bd846bb88824dc58c7919e4354ab9b11"
+SRC_URI[sha256sum] = "6fcbd13db6ee9c4b01504c4f7fcc940b5634775c71d61db98b8daf4ca71fff67" \ No newline at end of file
diff --git a/recipes/nonworking/gpe-contacts/gpe-contacts-hildon_0.42.bb b/recipes/nonworking/gpe-contacts/gpe-contacts-hildon_0.42.bb
index e7eeaf0de0..63a8864a29 100644
--- a/recipes/nonworking/gpe-contacts/gpe-contacts-hildon_0.42.bb
+++ b/recipes/nonworking/gpe-contacts/gpe-contacts-hildon_0.42.bb
@@ -10,3 +10,6 @@ EXTRA_OECONF += "--enable-hildon"
S = "${WORKDIR}/gpe-contacts-${PV}"
+
+SRC_URI[md5sum] = "3df07fc223f781fe7d6e3e9ec820ecd2"
+SRC_URI[sha256sum] = "e2c141aba89e8e0c88c2b4b7af3bf3a62d95a3e74d8564715e2175fd86706547" \ No newline at end of file
diff --git a/recipes/nonworking/gtk+/gtk+-directfb_2.10.14.bb b/recipes/nonworking/gtk+/gtk+-directfb_2.10.14.bb
index 6fcaf299dc..0ea6168028 100644
--- a/recipes/nonworking/gtk+/gtk+-directfb_2.10.14.bb
+++ b/recipes/nonworking/gtk+/gtk+-directfb_2.10.14.bb
@@ -51,3 +51,6 @@ EXTRA_OECONF =" \
"
GDKTARGET="directfb"
+
+SRC_URI[md5sum] = "018d7dd0fa7de01cfdb77c7c55e7ba26"
+SRC_URI[sha256sum] = "d02344239d048390ba02fcfd7de4f9efc0dfb51e7b06dfa46a6314d666ea4de2" \ No newline at end of file
diff --git a/recipes/nonworking/monotone-viz/monotone-viz_0.11.bb b/recipes/nonworking/monotone-viz/monotone-viz_0.11.bb
index 419fe9d0f4..0135403d11 100644
--- a/recipes/nonworking/monotone-viz/monotone-viz_0.11.bb
+++ b/recipes/nonworking/monotone-viz/monotone-viz_0.11.bb
@@ -5,7 +5,7 @@ RDEPENDS = "graphviz"
SRC_URI = "http://oandrieu.nerim.net/monotone-viz/monotone-viz-0.11.tar.gz"
-inherit autools
+inherit autotools
do_compile() {
make world.opt
diff --git a/recipes/nonworking/php/php-native_4.4.4.bb b/recipes/nonworking/php/php-native_4.4.4.bb
index 84d1c667b5..12d6bbe9ea 100644
--- a/recipes/nonworking/php/php-native_4.4.4.bb
+++ b/recipes/nonworking/php/php-native_4.4.4.bb
@@ -6,3 +6,6 @@ DEPENDS = "zlib-native"
PR = "r2"
S = "${WORKDIR}/php-${PV}"
+
+SRC_URI[md5sum] = "bc6fa8908e2ac36e93bab9f7d42cda3a"
+SRC_URI[sha256sum] = "9f0742fce014a255f8453c1264afee5de289a9e9dcd57c448c77b46978f6a76b" \ No newline at end of file
diff --git a/recipes/nonworking/php/php_4.4.4.bb b/recipes/nonworking/php/php_4.4.4.bb
index 3000ad1fb6..6f72e91365 100644
--- a/recipes/nonworking/php/php_4.4.4.bb
+++ b/recipes/nonworking/php/php_4.4.4.bb
@@ -6,3 +6,6 @@ SRC_URI = "http://museum.php.net/php4/php-${PV}.tar.bz2 \
file://${FILESDIR}/autotools.patch;patch=1 \
file://${FILESDIR}/pear.patch;patch=1"
+
+SRC_URI[md5sum] = "bc6fa8908e2ac36e93bab9f7d42cda3a"
+SRC_URI[sha256sum] = "9f0742fce014a255f8453c1264afee5de289a9e9dcd57c448c77b46978f6a76b" \ No newline at end of file
diff --git a/recipes/nonworking/unionfs/unionfs-modules_1.0.11.bb b/recipes/nonworking/unionfs/unionfs-modules_1.0.11.bb
index c9ca1d130d..dc40123660 100644
--- a/recipes/nonworking/unionfs/unionfs-modules_1.0.11.bb
+++ b/recipes/nonworking/unionfs/unionfs-modules_1.0.11.bb
@@ -2,3 +2,6 @@ require unionfs-modules.inc
require unionfs.inc
SRC_URI += "file://make.patch;patch=1"
+
+SRC_URI[md5sum] = "494651fe0cf724c093b4be80e35e857f"
+SRC_URI[sha256sum] = "f1df81423a65590ffd20df43f5cd0be14cf6746437eb40c2c924f5f58a6e18a7" \ No newline at end of file