aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-10-03 14:06:00 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-10-03 14:25:57 +0200
commit776ce56e0504cb647b955daa2aebee27dd9c2006 (patch)
treed9a1c49eaa6b98cdca51b74e836bcb081459e8d9 /recipes/nonworking
parent3729301629e5a60fcfd0add7deaed7c6ff28b8a5 (diff)
downloadopenembedded-776ce56e0504cb647b955daa2aebee27dd9c2006.tar.gz
task-openmoko-pim: remove dates2 tasks2 contacts2, because those are unfetchable now
* move their recipes to nonworking Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/nonworking')
-rw-r--r--recipes/nonworking/openmoko2/openmoko-contacts2_svn.bb14
-rw-r--r--recipes/nonworking/openmoko2/openmoko-dates2_svn.bb18
-rw-r--r--recipes/nonworking/openmoko2/openmoko-tasks2/openmoko-tasks.desktop12
-rw-r--r--recipes/nonworking/openmoko2/openmoko-tasks2/openmoko-tasks.pngbin0 -> 14517 bytes
-rw-r--r--recipes/nonworking/openmoko2/openmoko-tasks2_svn.bb24
5 files changed, 68 insertions, 0 deletions
diff --git a/recipes/nonworking/openmoko2/openmoko-contacts2_svn.bb b/recipes/nonworking/openmoko2/openmoko-contacts2_svn.bb
new file mode 100644
index 0000000000..31f202719e
--- /dev/null
+++ b/recipes/nonworking/openmoko2/openmoko-contacts2_svn.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Legacy Om address book application."
+SECTION = "openmoko/pim"
+DEPENDS = "libmokoui2 libmokojournal2 dbus-glib"
+RDEPENDS_${PN} = "libedata-book"
+SRCREV = "419"
+PV = "0.1.0+svnr${SRCPV}"
+PR = "r7"
+
+inherit openmoko2
+
+SRC_URI = "svn://svn.o-hand.com/repos/contacts/branches;module=hito;proto=http"
+S = "${WORKDIR}/hito/"
+
+EXTRA_OECONF = "--disable-gnome-vfs --with-frontend=openmoko"
diff --git a/recipes/nonworking/openmoko2/openmoko-dates2_svn.bb b/recipes/nonworking/openmoko2/openmoko-dates2_svn.bb
new file mode 100644
index 0000000000..783f5a04de
--- /dev/null
+++ b/recipes/nonworking/openmoko2/openmoko-dates2_svn.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Legacy Om calendar application."
+SECTION = "openmoko/pim"
+DEPENDS = "libmokoui2 libmokojournal2 gtk+ libglade eds-dbus libjana"
+RDEPENDS_${PN} = "libedata-cal"
+SRCREV = "703"
+PV = "0.1.0+svnr${SRCPV}"
+PR = "r4"
+
+inherit openmoko2 pkgconfig
+
+SRC_URI = "svn://svn.o-hand.com/repos/dates/branches;module=openmoko2;proto=http"
+S = "${WORKDIR}/openmoko2/"
+
+EXTRA_OECONF = "--with-frontend=openmoko"
+
+do_configure_prepend() {
+ touch gtk-doc.make
+}
diff --git a/recipes/nonworking/openmoko2/openmoko-tasks2/openmoko-tasks.desktop b/recipes/nonworking/openmoko2/openmoko-tasks2/openmoko-tasks.desktop
new file mode 100644
index 0000000000..f9e813a734
--- /dev/null
+++ b/recipes/nonworking/openmoko2/openmoko-tasks2/openmoko-tasks.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Tasks
+Comment=What you need to do
+Exec=tasks
+Icon=openmoko-tasks
+Terminal=false
+Type=Application
+Categories=GTK;Application;PIM;Office
+MimeType=text/x-vcard;
+SingleInstance=true
+StartupNotify=true
diff --git a/recipes/nonworking/openmoko2/openmoko-tasks2/openmoko-tasks.png b/recipes/nonworking/openmoko2/openmoko-tasks2/openmoko-tasks.png
new file mode 100644
index 0000000000..f28d1ade99
--- /dev/null
+++ b/recipes/nonworking/openmoko2/openmoko-tasks2/openmoko-tasks.png
Binary files differ
diff --git a/recipes/nonworking/openmoko2/openmoko-tasks2_svn.bb b/recipes/nonworking/openmoko2/openmoko-tasks2_svn.bb
new file mode 100644
index 0000000000..0ef6fd7dce
--- /dev/null
+++ b/recipes/nonworking/openmoko2/openmoko-tasks2_svn.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "The Openmoko Agenda"
+SECTION = "openmoko/pim"
+DEPENDS = "dbus-glib eds-dbus libmokoui2"
+RDEPENDS_${PN} = "libedata-cal"
+SRCREV = "404"
+PV = "0.1.0+svnr${SRCPV}"
+PR = "r2"
+
+inherit openmoko2
+
+SRC_URI = "svn://svn.o-hand.com/repos/tasks/;module=trunk;proto=http \
+ file://openmoko-tasks.desktop \
+ file://openmoko-tasks.png"
+S = "${WORKDIR}/trunk"
+
+EXTRA_OECONF = "--enable-omoko --disable-gtk"
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 ${WORKDIR}/openmoko-tasks.desktop ${D}${datadir}/applications/tasks.desktop
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/openmoko-tasks.png ${D}${datadir}/pixmaps
+}
+