aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/notez
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/notez
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/notez')
-rw-r--r--recipes/notez/notez-1.1.0/fix-encoding.patch18
-rw-r--r--recipes/notez/notez-1.1.0/use-homedir.patch92
-rw-r--r--recipes/notez/notez_1.1.0.bb22
3 files changed, 132 insertions, 0 deletions
diff --git a/recipes/notez/notez-1.1.0/fix-encoding.patch b/recipes/notez/notez-1.1.0/fix-encoding.patch
new file mode 100644
index 0000000000..54e809b431
--- /dev/null
+++ b/recipes/notez/notez-1.1.0/fix-encoding.patch
@@ -0,0 +1,18 @@
+--- notez-1.1.0/editWindow.cpp.orig 2002-11-17 17:40:08 +0100
++++ notez-1.1.0/editWindow.cpp 2004-12-22 14:02:13 +0100
+@@ -32,6 +32,7 @@
+ } else {
+
+ QTextStream inStream(&datei);
++ inStream.setEncoding(QTextStream::UnicodeUTF8);
+ editArea->setText(inStream.read());
+ datei.close();
+
+@@ -53,6 +54,7 @@
+ } else {
+
+ QTextStream outStream(&datei);
++ outStream.setEncoding(QTextStream::UnicodeUTF8);
+ outStream << editArea->text();
+ datei.close();
+ this->accept();
diff --git a/recipes/notez/notez-1.1.0/use-homedir.patch b/recipes/notez/notez-1.1.0/use-homedir.patch
new file mode 100644
index 0000000000..375b15449f
--- /dev/null
+++ b/recipes/notez/notez-1.1.0/use-homedir.patch
@@ -0,0 +1,92 @@
+--- notez-1.1.0/mainWindow.cpp.orig 2002-11-17 19:43:34 +0100
++++ notez-1.1.0/mainWindow.cpp 2004-11-21 22:55:06 +0100
+@@ -7,11 +7,11 @@
+
+ // check if the directory plain exists, if not
+ // create it
+- QString d1("Documents/text");
++ QString d1(QDir::homeDirPath() + "/Documents/text");
+ QDir pd1(d1);
+ if (!pd1.exists())
+ {
+- QDir pd1("Documents");
++ QDir pd1(QDir::homeDirPath() + "/Documents");
+ if (!pd1.mkdir("text", FALSE))
+ {
+ QMessageBox::critical( 0, "noteZ",
+@@ -22,11 +22,11 @@
+ }
+ }
+
+- QString d2("Documents/text/plain");
++ QString d2(QDir::homeDirPath() + "/Documents/text/plain");
+ QDir pd2(d2);
+ if (!pd2.exists())
+ {
+- QDir pd2("Documents/text");
++ QDir pd2(QDir::homeDirPath() + "/Documents/text");
+ if (!pd2.mkdir("plain", FALSE))
+ {
+ QMessageBox::critical( 0, "noteZ",
+@@ -40,14 +40,14 @@
+
+ unsigned int item, convertCount = 0;
+ QString strippedName;
+- QDir moveDir("Documents/text");
++ QDir moveDir(QDir::homeDirPath() + "/Documents/text");
+ moveDir.setFilter(QDir::Files);
+ moveDir.setNameFilter("[0-9]*-[0-9]*-[0-9]*-[0-9]*-[0-9]*-[0-9]*.txt");
+
+ for (item = 0; item < moveDir.count(); item++) {
+ strippedName = moveDir[item].left(moveDir[item].find("."));
+- QFile oldFile("Documents/text/" + moveDir[item]);
+- QFile newFile("Documents/text/plain/" + strippedName + ".ntz");
++ QFile oldFile(QDir::homeDirPath() + "/Documents/text/" + moveDir[item]);
++ QFile newFile(QDir::homeDirPath() + "/Documents/text/plain/" + strippedName + ".ntz");
+ if (!oldFile.open(IO_ReadOnly))
+ QMessageBox::warning(0, "File i/o error", "Could not read\nDocuments/text/" + moveDir[item] + "\nfor conversion.");
+
+@@ -104,7 +104,7 @@
+
+ case QMessageBox::Yes:
+ this->selected = notesList->currentItem();
+- QFile::remove("Documents/text/plain/" + fileList[notesList->currentItem()]);
++ QFile::remove(QDir::homeDirPath() + "/Documents/text/plain/" + fileList[notesList->currentItem()]);
+ refreshList(notesList);
+ break;
+
+@@ -146,7 +146,7 @@
+ QDate today(QDate::currentDate());
+ QTime now(QTime::currentTime());
+ QString name;
+- this->editFile(name.sprintf("Documents/text/plain/%4i-%02i-%02i-%02i-%02i-%02i.ntz", today.year(), today.month(), today.day(), now.hour(), now.minute(), now.second()),
++ this->editFile(name.sprintf(QDir::homeDirPath() + "/Documents/text/plain/%4i-%02i-%02i-%02i-%02i-%02i.ntz", today.year(), today.month(), today.day(), now.hour(), now.minute(), now.second()),
+ true );
+
+ }
+@@ -159,7 +159,7 @@
+ if( notesList->count() > 0 )
+ {
+ this->selected = number;
+- this->editFile("Documents/text/plain/" + fileList[number],
++ this->editFile(QDir::homeDirPath() + "/Documents/text/plain/" + fileList[number],
+ false);
+ }
+
+@@ -173,14 +173,14 @@
+
+ liste->clear();
+
+- fileList.setPath("Documents/text/plain/");
++ fileList.setPath(QDir::homeDirPath() + "/Documents/text/plain/");
+ fileList.setFilter(QDir::Files);
+ fileList.setSorting(QDir::Name);
+ fileList.setNameFilter("*.ntz");
+
+ for (item = 0; item < fileList.count(); item++) {
+
+- QFile datei("Documents/text/plain/" + fileList[item]);
++ QFile datei(QDir::homeDirPath() + "/Documents/text/plain/" + fileList[item]);
+
+ if (!datei.open(IO_ReadOnly)) {
+
diff --git a/recipes/notez/notez_1.1.0.bb b/recipes/notez/notez_1.1.0.bb
new file mode 100644
index 0000000000..9b82b1adad
--- /dev/null
+++ b/recipes/notez/notez_1.1.0.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "simple note-taking application"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "Henning Holtschneider <hh@holtschneider.com>"
+HOMEPAGE = "http://www.holtschneider.com/notez/"
+APPNAME = "notez"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+PR = "r1"
+
+SRC_URI = "http://www.holtschneider.com/notez/notez-${PV}.tar.gz \
+file://use-homedir.patch;patch=1 \
+file://fix-encoding.patch;patch=1"
+
+inherit opie
+
+do_install () {
+ install -d ${D}${palmtopdir}/pics/
+ install -m 0644 notez.png ${D}${palmtopdir}/pics/noteZ.png
+}
+