aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nylon
diff options
context:
space:
mode:
authorMartin Dietze <di@fh-wedel.de>2009-05-20 00:36:25 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-20 10:16:06 +0200
commitcb70efeb71b3a1e5e8786d3488e4ec3a1580d45a (patch)
tree107d51ea437c6dea9543b984cdec70f3b6f34245 /recipes/nylon
parent24db351c88feaa1b7ef23dd20a95d2ce78fb5bd4 (diff)
downloadopenembedded-cb70efeb71b3a1e5e8786d3488e4ec3a1580d45a.tar.gz
various nylon stuff: Updates to nylon-only code, needed to work with the current OE.
Diffstat (limited to 'recipes/nylon')
-rw-r--r--recipes/nylon/files/firewall-bash.diff8
-rw-r--r--recipes/nylon/files/simple-firewall-bash.diff8
-rw-r--r--recipes/nylon/nylon-config.bb41
-rw-r--r--recipes/nylon/nylon-scripts_cvs.bb6
-rw-r--r--recipes/nylon/nylon-statistics.bb5
-rw-r--r--recipes/nylon/simple-firewall.bb18
-rw-r--r--recipes/nylon/yamonenv.bb5
7 files changed, 85 insertions, 6 deletions
diff --git a/recipes/nylon/files/firewall-bash.diff b/recipes/nylon/files/firewall-bash.diff
new file mode 100644
index 0000000000..044f8d813c
--- /dev/null
+++ b/recipes/nylon/files/firewall-bash.diff
@@ -0,0 +1,8 @@
+--- nylon-scripts/etc/init.d/firewall-orig 2009-04-25 13:46:25.000000000 +0200
++++ nylon-scripts/etc/init.d/firewall 2009-04-25 13:46:28.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/bash
+
+ # this is a meta firewall start script:
+ # it either starts a local firewall script or shorewall
diff --git a/recipes/nylon/files/simple-firewall-bash.diff b/recipes/nylon/files/simple-firewall-bash.diff
new file mode 100644
index 0000000000..dc6cf0dd87
--- /dev/null
+++ b/recipes/nylon/files/simple-firewall-bash.diff
@@ -0,0 +1,8 @@
+--- simple-firewall/etc/init.d/simple-firewall-orig 2009-04-25 13:42:10.000000000 +0200
++++ simple-firewall/etc/init.d/simple-firewall 2009-04-25 13:42:16.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/bash
+ #$HeadURL: http://gruen.4g/svn/branches/stable-1.0/application/simple-firewall/etc/init.d/simple-firewall $ $Rev: 2593 $
+
+ if [ -f /etc/firewall/firewall.conf ]; then
diff --git a/recipes/nylon/nylon-config.bb b/recipes/nylon/nylon-config.bb
new file mode 100644
index 0000000000..76f78a97f7
--- /dev/null
+++ b/recipes/nylon/nylon-config.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "nylon preliminary web configuration interface"
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+LICENSE = "closed"
+DEPENDS = "perl virtual/kernel hostap-daemon busybox"
+RDEPENDS = "perl perl-module-exporter perl-module-posix perl-module-autoloader perl-module-strict perl-module-xsloader perl-module-data-dumper perl-module-carp perl-module-bytes perl-module-overload perl-module-warnings-register perl-module-warnings kernel-module-aes madwifi-modules hostap-daemon simple-firewall wlan-ng-utils busybox-httpd"
+CVSDATE = "20051026"
+PV = "cvs${CVSDATE}"
+
+SRC_URI = "http://br1.einfach.org/nylon/stable/sources/nylon-config_gruen.4g__20051026.tar.gz"
+S = "${WORKDIR}/${PN}"
+
+do_install() {
+ (cd ${S}; tar -c --exclude .svn -f - . ) | tar -C ${D} -xpf -
+ # chmod 600 ${D}/etc/certs/stunnel.key
+ chmod a+x ${D}/srv/www/cgi-bin/*
+}
+
+pkg_postinst() {
+#!/bin/sh
+if test "x$D" != "x"; then
+ exit 1
+fi
+
+# Create resolv.conf-link to ppp-file
+rm /etc/resolv.conf
+ln -s /etc/ppp/resolv.conf /etc/resolv.conf
+
+# enable factorydefaults
+update-rc.d factorydefaults start 90 2 .
+
+# "fix" /etc/network/interfaces
+perl -I /srv/www/cgi-bin -MConfig::IFace -e '$w=new Config::IFace(); $v = $w->read(); $v->{auto} = {0=>"lo",1=>eth0,2=>"wlan0",3=>"wlan1",4=>"ath0",5=>"ath1"}; $w->write($v)'
+
+update-rc.d busybox-httpd start 40 2 3 4 5 .
+/etc/init.d/busybox-httpd restart
+}
+
+FILES_${PN} += "/srv"
+
diff --git a/recipes/nylon/nylon-scripts_cvs.bb b/recipes/nylon/nylon-scripts_cvs.bb
index 650bd1a8e8..d87e2c11e1 100644
--- a/recipes/nylon/nylon-scripts_cvs.bb
+++ b/recipes/nylon/nylon-scripts_cvs.bb
@@ -4,12 +4,14 @@ DEPENDS = "hostap-utils"
SECTION = "base"
PRIORITY = "optional"
LICENSE = "GPLv2"
-SRCDATE = "20060923"
+#SRCDATE = "20060923"
+SRCDATE = "20051022"
PV = "1.0.0+cvs${SRCDATE}"
PR = "r2"
RDEPENDS = "bash"
-SRC_URI = "http://meshcube.org/download/${PN}_${SRCDATE}.tgz"
+SRC_URI = "http://download.berlin.freifunk.net/meshcube.org/nylon/stable/sources/${PN}_gruen.4g__${SRCDATE}.tar.gz \
+ file://firewall-bash.diff;patch=1"
S = "${WORKDIR}/${PN}"
INHIBIT_PACKAGE_STRIP = "1"
diff --git a/recipes/nylon/nylon-statistics.bb b/recipes/nylon/nylon-statistics.bb
index ef79bc6d31..c9b790cda0 100644
--- a/recipes/nylon/nylon-statistics.bb
+++ b/recipes/nylon/nylon-statistics.bb
@@ -3,11 +3,12 @@ RDEPENDS = "rrdtool"
SECTION = "base"
PRIORITY = "optional"
LICENSE = "GPLv2"
-SRCDATE = "20050909"
+#SRCDATE = "20050909"
+SRCDATE = "20051022"
PV = "1.0.0+cvs${SRCDATE}"
PR = "r1"
-SRC_URI = "http://meshcube.org/download/${PN}_${SRCDATE}.tgz"
+SRC_URI = "http://download.berlin.freifunk.net/meshcube.org/nylon/stable/sources/${PN}_gruen.4g__${SRCDATE}.tar.gz"
S = "${WORKDIR}/${PN}"
INHIBIT_PACKAGE_STRIP = "1"
diff --git a/recipes/nylon/simple-firewall.bb b/recipes/nylon/simple-firewall.bb
new file mode 100644
index 0000000000..d9e6974480
--- /dev/null
+++ b/recipes/nylon/simple-firewall.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "simple firewall configuratiopn script"
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Bruno Randolf <br1@einfach.org>"
+LICENSE = "GPL"
+DEPENDS = "virtual/kernel"
+# these kernel modules are needed if the functionality is not hard-built into the kernel:
+# kernel-module-ip-tables kernel-module-iptable-filter kernel-module-iptable-nat kernel-module-ipt-state kernel-module-ipt-reject kernel-module-ipt-masquerade
+RDEPENDS = "kernel-module-ipt-limit kernel-module-ipt-tcpmss"
+PV = "cvs20051022"
+
+SRC_URI = "http://br1.einfach.org/nylon/stable/sources/simple-firewall_gruen.4g__20051022.tar.gz \
+ file://simple-firewall-bash.diff;patch=1"
+S = "${WORKDIR}/${PN}"
+
+do_install() {
+ (cd ${S}; tar -c --exclude .svn -f - . ) | tar -C ${D} -xpf -
+}
diff --git a/recipes/nylon/yamonenv.bb b/recipes/nylon/yamonenv.bb
index e963d913ee..1db737f042 100644
--- a/recipes/nylon/yamonenv.bb
+++ b/recipes/nylon/yamonenv.bb
@@ -2,10 +2,11 @@ DESCRIPTION = "Reads YAMON environment-variables"
SECTION = "base"
PRIORITY = "optional"
LICENSE = "GPL"
-SRCDATE = "20050909"
+#SRCDATE = "20050909"
+SRCDATE = "20051022"
PV = "1.0.0+cvs${SRCDATE}"
-SRC_URI = "http://meshcube.org/download/${PN}_${SRCDATE}.tgz"
+SRC_URI = "http://download.berlin.freifunk.net/meshcube.org/nylon/stable/sources/${PN}_gruen.4g__${SRCDATE}.tar.gz"
S = "${WORKDIR}/${PN}"
do_install() {