aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nylon
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/nylon
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/nylon')
-rw-r--r--recipes/nylon/nylon-config.bb2
-rw-r--r--recipes/nylon/nylon-scripts_cvs.bb2
-rw-r--r--recipes/nylon/nylon-statistics.bb2
-rw-r--r--recipes/nylon/simple-firewall.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/recipes/nylon/nylon-config.bb b/recipes/nylon/nylon-config.bb
index 66e8e78f40..7228e83a22 100644
--- a/recipes/nylon/nylon-config.bb
+++ b/recipes/nylon/nylon-config.bb
@@ -4,7 +4,7 @@ PRIORITY = "optional"
MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
LICENSE = "closed"
DEPENDS = "perl virtual/kernel hostap-daemon busybox"
-RDEPENDS = "perl perl-module-exporter perl-module-posix perl-module-autoloader perl-module-strict perl-module-xsloader perl-module-data-dumper perl-module-carp perl-module-bytes perl-module-overload perl-module-warnings-register perl-module-warnings kernel-module-aes madwifi-modules hostap-daemon simple-firewall wlan-ng-utils busybox-httpd"
+RDEPENDS_${PN} = "perl perl-module-exporter perl-module-posix perl-module-autoloader perl-module-strict perl-module-xsloader perl-module-data-dumper perl-module-carp perl-module-bytes perl-module-overload perl-module-warnings-register perl-module-warnings kernel-module-aes madwifi-modules hostap-daemon simple-firewall wlan-ng-utils busybox-httpd"
CVSDATE = "20051026"
PV = "cvs${CVSDATE}"
diff --git a/recipes/nylon/nylon-scripts_cvs.bb b/recipes/nylon/nylon-scripts_cvs.bb
index 6a253a661f..e22be32a54 100644
--- a/recipes/nylon/nylon-scripts_cvs.bb
+++ b/recipes/nylon/nylon-scripts_cvs.bb
@@ -8,7 +8,7 @@ LICENSE = "GPLv2"
SRCDATE = "20051022"
PV = "1.0.0+cvs${SRCDATE}"
PR = "r2"
-RDEPENDS = "bash"
+RDEPENDS_${PN} = "bash"
SRC_URI = "http://download.berlin.freifunk.net/meshcube.org/nylon/stable/sources/${PN}_gruen.4g__${SRCDATE}.tar.gz \
file://firewall-bash.diff"
diff --git a/recipes/nylon/nylon-statistics.bb b/recipes/nylon/nylon-statistics.bb
index abed00596d..03cfe0c2d6 100644
--- a/recipes/nylon/nylon-statistics.bb
+++ b/recipes/nylon/nylon-statistics.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "statistics & graphing for nylon"
-RDEPENDS = "rrdtool"
+RDEPENDS_${PN} = "rrdtool"
SECTION = "base"
PRIORITY = "optional"
LICENSE = "GPLv2"
diff --git a/recipes/nylon/simple-firewall.bb b/recipes/nylon/simple-firewall.bb
index 8e34f3a475..f78002bcc6 100644
--- a/recipes/nylon/simple-firewall.bb
+++ b/recipes/nylon/simple-firewall.bb
@@ -6,7 +6,7 @@ LICENSE = "GPL"
DEPENDS = "virtual/kernel"
# these kernel modules are needed if the functionality is not hard-built into the kernel:
# kernel-module-ip-tables kernel-module-iptable-filter kernel-module-iptable-nat kernel-module-ipt-state kernel-module-ipt-reject kernel-module-ipt-masquerade
-RDEPENDS = "kernel-module-ipt-limit kernel-module-ipt-tcpmss"
+RDEPENDS_${PN} = "kernel-module-ipt-limit kernel-module-ipt-tcpmss"
PV = "cvs20051022"
SRC_URI = "http://br1.einfach.org/nylon/stable/sources/simple-firewall_gruen.4g__20051022.tar.gz \