aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nylon
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nylon
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nylon')
-rw-r--r--recipes/nylon/nylon-scripts_cvs.bb59
-rw-r--r--recipes/nylon/nylon-statistics.bb46
-rw-r--r--recipes/nylon/yamonenv.bb14
3 files changed, 119 insertions, 0 deletions
diff --git a/recipes/nylon/nylon-scripts_cvs.bb b/recipes/nylon/nylon-scripts_cvs.bb
new file mode 100644
index 0000000000..650bd1a8e8
--- /dev/null
+++ b/recipes/nylon/nylon-scripts_cvs.bb
@@ -0,0 +1,59 @@
+DESCRIPTION = "This package provides the nylon specific init and configuration scripts."
+HOMEPAGE = "http://meshcube.org/meshwiki/NyLon"
+DEPENDS = "hostap-utils"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+SRCDATE = "20060923"
+PV = "1.0.0+cvs${SRCDATE}"
+PR = "r2"
+RDEPENDS = "bash"
+
+SRC_URI = "http://meshcube.org/download/${PN}_${SRCDATE}.tgz"
+S = "${WORKDIR}/${PN}"
+INHIBIT_PACKAGE_STRIP = "1"
+
+do_install() {
+ install -d -m 755 ${D}
+ (cd ${S}; tar -c --exclude .svn -f - . ) | tar -C ${D} -xpf -
+}
+
+pkg_postinst() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ update-rc.d -s hostap defaults 14
+ update-rc.d -s firewall defaults 16
+ update-rc.d -s routing defaults 17
+ update-rc.d -s emergency-ip defaults 98
+ update-rc.d -s flash-backup start 38 S . stop 38 0 6 .
+ update-rc.d -s dummydate start 50 S . stop 50 0 6 .
+
+ if ! grep -q flash-backup /etc/cron/crontabs/root; then
+ echo "adding flash-backup crontab"
+ test -d /etc/cron/crontabs || mkdir -p /etc/cron/crontabs
+ echo "0 * * * * /etc/init.d/flash-backup backup" >> /etc/cron/crontabs/root
+ fi
+
+ if ! grep -q reset-wlan /etc/cron/crontabs/root; then
+ echo "adding reset-wlan crontab"
+ test -d /etc/cron/crontabs || mkdir -p /etc/cron/crontabs
+ echo "0 3 * * * /usr/sbin/reset-wlan" >> /etc/cron/crontabs/root
+ fi
+
+ update-rc.d -s busybox-cron defaults
+fi
+}
+
+pkg_postrm() {
+#!/bin/sh -e
+update-rc.d hostap remove
+update-rc.d firewall remove
+update-rc.d routing remove
+update-rc.d emergency-ip remove
+update-rc.d flash-backup remove
+update-rc.d dummydate remove
+}
+
+CONFFILES_${PN} = "/etc/nylon/backup.list /etc/nylon/hostap.conf /etc/nylon/check-process.list \
+ /etc/nylon/interfaces.conf /etc/nylon/route.list /etc/nylon/wds-bridge.conf"
diff --git a/recipes/nylon/nylon-statistics.bb b/recipes/nylon/nylon-statistics.bb
new file mode 100644
index 0000000000..ef79bc6d31
--- /dev/null
+++ b/recipes/nylon/nylon-statistics.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "statistics & graphing for nylon"
+RDEPENDS = "rrdtool"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+SRCDATE = "20050909"
+PV = "1.0.0+cvs${SRCDATE}"
+PR = "r1"
+
+SRC_URI = "http://meshcube.org/download/${PN}_${SRCDATE}.tgz"
+S = "${WORKDIR}/${PN}"
+INHIBIT_PACKAGE_STRIP = "1"
+
+do_install() {
+ install -d ${D}/srv/www/cgi-bin
+ install -d ${D}/${sbindir}
+ ln -s /var/tmp ${D}/srv/www/rrd-img
+ install -m 755 ${S}/*.html ${D}/srv/www/cgi-bin
+ ln -s /var/tmp/nav.inc.html ${D}/srv/www/cgi-bin
+ install -m 755 ${S}/collect.sh ${D}/${sbindir}
+}
+
+pkg_postinst() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ if ! grep -q collect.sh /etc/cron/crontabs/root; then
+ echo "adding crontab"
+ test -d /etc/cron/crontabs || mkdir -p /etc/cron/crontabs
+ echo "*/5 * * * * ${sbindir}/collect.sh" >> /etc/cron/crontabs/root
+ fi
+ update-rc.d -s busybox-cron defaults
+ /etc/init.d/busybox-cron reload
+ if [ ! -e /etc/httpd.conf ]; then
+ echo "A:*" > /etc/httpd.conf
+ fi
+ update-rc.d -s busybox-httpd defaults
+
+ if ! grep -q "/var/lib/rrd/" /etc/nylon/backup.list; then
+ echo "adding to backup list"
+ echo "/var/lib/rrd/" >> /etc/nylon/backup.list
+ fi
+fi
+}
+
+FILES_${PN} += "/srv"
diff --git a/recipes/nylon/yamonenv.bb b/recipes/nylon/yamonenv.bb
new file mode 100644
index 0000000000..e963d913ee
--- /dev/null
+++ b/recipes/nylon/yamonenv.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Reads YAMON environment-variables"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+SRCDATE = "20050909"
+PV = "1.0.0+cvs${SRCDATE}"
+
+SRC_URI = "http://meshcube.org/download/${PN}_${SRCDATE}.tgz"
+S = "${WORKDIR}/${PN}"
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 755 ${S}/src/yamonenv ${D}${sbindir}
+}