aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete/antlr/antlr_2.7.5.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/obsolete/antlr/antlr_2.7.5.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/obsolete/antlr/antlr_2.7.5.bb')
-rw-r--r--recipes/obsolete/antlr/antlr_2.7.5.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/obsolete/antlr/antlr_2.7.5.bb b/recipes/obsolete/antlr/antlr_2.7.5.bb
new file mode 100644
index 0000000000..f61b3a0b87
--- /dev/null
+++ b/recipes/obsolete/antlr/antlr_2.7.5.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "ANother Tool for Language Recognition, (formerly PCCTS) is a \
+language tool that provides a framework for constructing recognizers, \
+compilers, and translators from grammatical descriptions containing \
+Java, C#, C++, or Python actions."
+LICENSE = "PD"
+PRIORITY = "optional"
+SECTION = "devel"
+# DEPENDS += "virtual/java"
+RDEPENDS += "java-virtual-machine"
+
+SRC_URI = "http://www.antlr.org/download/antlr-${PV}.tar.gz \
+ file://install.patch;patch=1"
+S = "${WORKDIR}/antlr-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF += "--disable-java --enable-cxx \
+ --disable-python --disable-csharp \
+ --disable-verbose --disable-examples"
+
+do_configure () {
+ if [ ! -e acinclude.m4 ]; then
+ mv aclocal.m4 acinclude.m4
+ fi
+ autotools_do_configure
+}