aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete/tasks/task-bootstrap-unionroot.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/obsolete/tasks/task-bootstrap-unionroot.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/obsolete/tasks/task-bootstrap-unionroot.bb')
-rw-r--r--recipes/obsolete/tasks/task-bootstrap-unionroot.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/obsolete/tasks/task-bootstrap-unionroot.bb b/recipes/obsolete/tasks/task-bootstrap-unionroot.bb
new file mode 100644
index 0000000000..a4340eb4e8
--- /dev/null
+++ b/recipes/obsolete/tasks/task-bootstrap-unionroot.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Core packages required for a basic installation with unionroot"
+PROVIDES = "task-bootstrap"
+RPROVIDES = "task-bootstrap"
+PR = "r2"
+DEFAULT_PREFERENCE = "-1"
+
+# The BOOTSTRAP_EXTRA_ variables are often manipulated by the
+# MACHINE .conf files, so adjust PACKAGE_ARCH accordingly.
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+ALLOW_EMPTY = "1"
+
+MODUTILS ?= "24 26"
+
+require task-bootstrap.inc
+
+HOTPLUG ?= "linux-hotplug"
+
+RDEPENDS = 'base-files base-passwd busybox \
+ initscripts \
+ netbase sysvinit sysvinit-pidof tinylogin \
+ modutils-initscripts \
+ ${HOTPLUG} \
+ ${BOOTSTRAP_EXTRA_RDEPENDS} \
+ ${@bootstrap_modutils_rdepends(d)} \
+ unionfs-modules \
+ unionfs-utils \
+ unionroot \
+ unionroot-utils'
+
+RRECOMMENDS = 'dropbear portmap \
+ ${BOOTSTRAP_EXTRA_RRECOMMENDS}'
+LICENSE = "MIT"