aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-10-19 09:22:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-10-19 22:32:16 +0200
commit83847370bdcd13cc39adfbc1a1109584efc7fe00 (patch)
tree006ac8fae469825f5e14e69e93c67f13b2c0aa10 /recipes/obsolete
parenta8caf896c9000d9f09a445f622b765a835fc9baa (diff)
downloadopenembedded-83847370bdcd13cc39adfbc1a1109584efc7fe00.tar.gz
openmoko: obsolete tasks and images, openmoko as distribution was obsoleted on Aug 10, 2010.
Acked-by: Michael 'Mickey' Lauer <mickey@openmoko.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/obsolete')
-rw-r--r--recipes/obsolete/classes/openmoko-panel-plugin.bbclass6
-rw-r--r--recipes/obsolete/images/minimal-openmoko-image.bb21
-rw-r--r--recipes/obsolete/images/openmoko-devel-image.bb3
-rw-r--r--recipes/obsolete/images/openmoko-image.bb21
-rw-r--r--recipes/obsolete/images/openmoko-minimal-image.bb21
-rw-r--r--recipes/obsolete/images/openmoko-python-devel-image.bb7
-rw-r--r--recipes/obsolete/images/openmoko-sdk-image.bb3
-rw-r--r--recipes/obsolete/meta/meta-toolchain-openmoko.bb7
-rw-r--r--recipes/obsolete/meta/openmoko-feed.bb10
-rw-r--r--recipes/obsolete/openmoko-base/openmoko-session/session24
-rw-r--r--recipes/obsolete/openmoko-base/openmoko-session_svn.bb32
-rw-r--r--recipes/obsolete/openmoko-panel-plugins/openmoko-panel-battery_svn.bb7
-rw-r--r--recipes/obsolete/openmoko-panel-plugins/openmoko-panel-bt_svn.bb8
-rw-r--r--recipes/obsolete/openmoko-panel-plugins/openmoko-panel-clock_svn.bb6
-rw-r--r--recipes/obsolete/openmoko-panel-plugins/openmoko-panel-gps_svn.bb7
-rw-r--r--recipes/obsolete/openmoko-panel-plugins/openmoko-panel-gsm_svn.bb7
-rw-r--r--recipes/obsolete/openmoko-panel-plugins/openmoko-panel-mainmenu_svn.bb8
-rw-r--r--recipes/obsolete/openmoko-panel-plugins/openmoko-panel-memory_svn.bb8
-rw-r--r--recipes/obsolete/openmoko-panel-plugins/openmoko-panel-usb_svn.bb6
-rw-r--r--recipes/obsolete/openmoko-panel-plugins/openmoko-panel-wifi_svn.bb7
-rw-r--r--recipes/obsolete/openmoko2/openmoko-session2.bb53
-rwxr-xr-xrecipes/obsolete/openmoko2/openmoko-session2/etc/matchbox/session12
-rwxr-xr-xrecipes/obsolete/openmoko2/openmoko-session2/matchbox-session24
-rw-r--r--recipes/obsolete/tasks/task-openmoko-base.bb31
-rw-r--r--recipes/obsolete/tasks/task-openmoko-debug.bb38
-rw-r--r--recipes/obsolete/tasks/task-openmoko-examples.bb6
-rw-r--r--recipes/obsolete/tasks/task-openmoko-feed.bb157
-rw-r--r--recipes/obsolete/tasks/task-openmoko-games.bb15
-rw-r--r--recipes/obsolete/tasks/task-openmoko-linux.bb19
-rw-r--r--recipes/obsolete/tasks/task-openmoko-native-sdk.bb41
-rw-r--r--recipes/obsolete/tasks/task-openmoko-net.bb15
-rw-r--r--recipes/obsolete/tasks/task-openmoko-phone.bb19
-rw-r--r--recipes/obsolete/tasks/task-openmoko-pim.bb23
-rw-r--r--recipes/obsolete/tasks/task-openmoko-python-devel.bb11
-rw-r--r--recipes/obsolete/tasks/task-openmoko-toolchain-host.bb15
-rw-r--r--recipes/obsolete/tasks/task-openmoko-toolchain-target.bb23
-rw-r--r--recipes/obsolete/tasks/task-openmoko-ui.bb58
-rw-r--r--recipes/obsolete/tasks/task-openmoko.bb31
38 files changed, 810 insertions, 0 deletions
diff --git a/recipes/obsolete/classes/openmoko-panel-plugin.bbclass b/recipes/obsolete/classes/openmoko-panel-plugin.bbclass
new file mode 100644
index 0000000000..6a22a92ac8
--- /dev/null
+++ b/recipes/obsolete/classes/openmoko-panel-plugin.bbclass
@@ -0,0 +1,6 @@
+SECTION = "openmoko/panel-plugin"
+DEPENDS += "matchbox-panel-2 libmokopanelui2"
+
+inherit openmoko2
+
+FILES_${PN} = "${libdir}/matchbox-panel/lib*.so* ${datadir}"
diff --git a/recipes/obsolete/images/minimal-openmoko-image.bb b/recipes/obsolete/images/minimal-openmoko-image.bb
new file mode 100644
index 0000000000..70658fd86f
--- /dev/null
+++ b/recipes/obsolete/images/minimal-openmoko-image.bb
@@ -0,0 +1,21 @@
+#------------------------------------------------------
+# Minimal Openmoko Image Recipe
+# This should only have the base system + dialer
+# #------------------------------------------------------
+
+IMAGE_LINGUAS = ""
+ANGSTROM_EXTRA_INSTALL ?= ""
+
+IMAGE_INSTALL = "\
+ task-base \
+ ${ANGSTROM_EXTRA_INSTALL} \
+ task-openmoko-linux \
+ task-openmoko-net \
+ task-openmoko-ui \
+ task-openmoko-base \
+ task-openmoko-phone \
+ "
+
+inherit image
+
+ROOTFS_POSTPROCESS_COMMAND += 'date "+%m%d%H%M%Y" >${IMAGE_ROOTFS}/etc/timestamp'
diff --git a/recipes/obsolete/images/openmoko-devel-image.bb b/recipes/obsolete/images/openmoko-devel-image.bb
new file mode 100644
index 0000000000..3b2111eb34
--- /dev/null
+++ b/recipes/obsolete/images/openmoko-devel-image.bb
@@ -0,0 +1,3 @@
+require openmoko-image.bb
+
+IMAGE_INSTALL += "task-openmoko-debug"
diff --git a/recipes/obsolete/images/openmoko-image.bb b/recipes/obsolete/images/openmoko-image.bb
new file mode 100644
index 0000000000..48b0d7da4f
--- /dev/null
+++ b/recipes/obsolete/images/openmoko-image.bb
@@ -0,0 +1,21 @@
+#------------------------------------------------------
+# Openmoko Image Recipe
+#------------------------------------------------------
+
+require openmoko-minimal-image.bb
+
+IMAGE_INSTALL += "\
+ task-openmoko-net \
+ task-openmoko-ui \
+ task-openmoko-base \
+ task-openmoko-phone \
+ task-openmoko-games \
+ task-openmoko-pim \
+ "
+
+DEPENDS += "\
+ task-openmoko \
+ "
+
+inherit image
+
diff --git a/recipes/obsolete/images/openmoko-minimal-image.bb b/recipes/obsolete/images/openmoko-minimal-image.bb
new file mode 100644
index 0000000000..678400f756
--- /dev/null
+++ b/recipes/obsolete/images/openmoko-minimal-image.bb
@@ -0,0 +1,21 @@
+#------------------------------------------------------
+# Openmoko Minimal Image Recipe
+# other openmoko images should include this.
+# -----------------------------------------------------
+
+IMAGE_LINGUAS = ""
+
+IMAGE_INSTALL = "\
+ ${MACHINE_TASK_PROVIDER} \
+ task-openmoko-linux \
+ "
+
+DEPENDS = "\
+ ${MACHINE_TASK_PROVIDER} \
+ task-openmoko-linux \
+ "
+
+
+inherit image
+
+ROOTFS_POSTPROCESS_COMMAND += "rootfs_update_timestamp;"
diff --git a/recipes/obsolete/images/openmoko-python-devel-image.bb b/recipes/obsolete/images/openmoko-python-devel-image.bb
new file mode 100644
index 0000000000..615042f3b8
--- /dev/null
+++ b/recipes/obsolete/images/openmoko-python-devel-image.bb
@@ -0,0 +1,7 @@
+require openmoko-image.bb
+
+IMAGE_INSTALL += "\
+ task-openmoko-python-devel \
+ task-python-efl-examples \
+ edje-viewer \
+"
diff --git a/recipes/obsolete/images/openmoko-sdk-image.bb b/recipes/obsolete/images/openmoko-sdk-image.bb
new file mode 100644
index 0000000000..85958085ae
--- /dev/null
+++ b/recipes/obsolete/images/openmoko-sdk-image.bb
@@ -0,0 +1,3 @@
+require openmoko-devel-image.bb
+
+IMAGE_INSTALL += "task-openmoko-native-sdk"
diff --git a/recipes/obsolete/meta/meta-toolchain-openmoko.bb b/recipes/obsolete/meta/meta-toolchain-openmoko.bb
new file mode 100644
index 0000000000..b265615700
--- /dev/null
+++ b/recipes/obsolete/meta/meta-toolchain-openmoko.bb
@@ -0,0 +1,7 @@
+PR = "r2"
+
+TOOLCHAIN_TARGET_TASK = "task-openmoko-toolchain-target"
+TOOLCHAIN_HOST_TASK = "task-openmoko-toolchain-host"
+
+require meta-toolchain.bb
+SDK_SUFFIX = "toolchain-openmoko"
diff --git a/recipes/obsolete/meta/openmoko-feed.bb b/recipes/obsolete/meta/openmoko-feed.bb
new file mode 100644
index 0000000000..21bdbc625b
--- /dev/null
+++ b/recipes/obsolete/meta/openmoko-feed.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "Meta-package for Openmoko Misc. Feed Items"
+LICENSE = "MIT"
+
+RDEPENDS_${PN} = "\
+ task-openmoko-debug \
+ task-openmoko-native-sdk \
+ task-openmoko-feed \
+"
+
+inherit meta
diff --git a/recipes/obsolete/openmoko-base/openmoko-session/session b/recipes/obsolete/openmoko-base/openmoko-session/session
new file mode 100644
index 0000000000..c7a773efcb
--- /dev/null
+++ b/recipes/obsolete/openmoko-base/openmoko-session/session
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+export GTK_MODULES="libgtkstylus.so libgtkinput.so"
+SHOWCURSOR="no"
+
+matchbox-panel-2 \
+ --start-applets=openmoko-panel-mainmenu,systray,startup \
+ --end-applets=openmoko-panel-battery,openmoko-panel-gsm,openmoko-panel-gps,openmoko-panel-usb,openmoko-panel-bt,openmoko-panel-clock &
+
+# start old-style panel plugin to get a keyboard
+mbinputmgr &
+
+# set default alsa configuration
+alsactl restore 0 -f /etc/alsa/stereoout.state
+
+# start UI and dialer
+openmoko-footer &
+openmoko-today --desktop &
+openmoko-dialer &
+
+sleep 1
+
+exec matchbox-window-manager -use_titlebar no -use_cursor $SHOWCURSOR $@
+
diff --git a/recipes/obsolete/openmoko-base/openmoko-session_svn.bb b/recipes/obsolete/openmoko-base/openmoko-session_svn.bb
new file mode 100644
index 0000000000..05625a1c5a
--- /dev/null
+++ b/recipes/obsolete/openmoko-base/openmoko-session_svn.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Matchbox session files for Openmoko"
+SECTION = "openmoko/base"
+RDEPENDS_${PN} = "matchbox-panel-2 matchbox-wm openmoko-today2 gconf"
+PV = "0.1+svnr${SRCPV}"
+PR = "r1"
+
+inherit openmoko-base
+
+SRC_URI = "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE};module=etc;proto=http \
+ file://session"
+S = "${WORKDIR}"
+
+do_install() {
+ cp -R ${S}/etc ${D}/${sysconfdir}
+ rm -fR ${D}/${sysconfdir}/.svn
+ rm -fR ${D}/${sysconfdir}/matchbox/.svn
+ chmod -R 755 ${D}/${sysconfdir}
+ # DEMO only. Need to handle this differently in actual production images
+ install -m 0755 ${WORKDIR}/session ${D}/${sysconfdir}/matchbox/session
+}
+
+pkg_postinst_openmoko-session () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/openmoko/interface/theme openmoko-standard
+}
+
+PACKAGE_ARCH = "all"
+
diff --git a/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-battery_svn.bb b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-battery_svn.bb
new file mode 100644
index 0000000000..b4926affd6
--- /dev/null
+++ b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-battery_svn.bb
@@ -0,0 +1,7 @@
+DESCRIPTION = "Shows the battery/AC status in the Openmoko panel"
+DEPENDS = "apmd libnotify"
+SRCREV = "3360"
+PV = "0.1.1+svnr${SRCPV}"
+
+inherit openmoko-panel-plugin
+
diff --git a/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-bt_svn.bb b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-bt_svn.bb
new file mode 100644
index 0000000000..b9015a37da
--- /dev/null
+++ b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-bt_svn.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Shows the bluetooth status in the Openmoko panel"
+DEPENDS = "bluez-libs libnotify"
+SRCREV = "4331"
+PV = "0.1.0+svnr${SRCPV}"
+PR = "r1"
+
+inherit openmoko-panel-plugin
+
diff --git a/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-clock_svn.bb b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-clock_svn.bb
new file mode 100644
index 0000000000..90e5e92a73
--- /dev/null
+++ b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-clock_svn.bb
@@ -0,0 +1,6 @@
+DESCRIPTION = "Shows the current time in the Openmoko panel"
+SRCREV = "2567"
+PV = "0.1.0+svnr${SRCPV}"
+
+inherit openmoko-panel-plugin
+
diff --git a/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-gps_svn.bb b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-gps_svn.bb
new file mode 100644
index 0000000000..928a99379f
--- /dev/null
+++ b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-gps_svn.bb
@@ -0,0 +1,7 @@
+DESCRIPTION = "Shows the GPS status in the Openmoko panel"
+DEPENDS = "gpsd"
+SRCREV = "4330"
+PV = "0.1.0+svnr${SRCPV}"
+
+inherit openmoko-panel-plugin
+
diff --git a/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-gsm_svn.bb b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-gsm_svn.bb
new file mode 100644
index 0000000000..1ce27a6a1f
--- /dev/null
+++ b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-gsm_svn.bb
@@ -0,0 +1,7 @@
+DESCRIPTION = "Shows the GSM / GPRS status in the Openmoko panel"
+DEPENDS = "libmokogsmd2 libnotify"
+SRCREV = "4335"
+PV = "0.1.0+svnr${SRCPV}"
+PR = "r2"
+
+inherit openmoko-panel-plugin
diff --git a/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-mainmenu_svn.bb b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-mainmenu_svn.bb
new file mode 100644
index 0000000000..ebc041640b
--- /dev/null
+++ b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-mainmenu_svn.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Main menu applet for the Openmoko panel"
+DEPENDS += "pulseaudio startup-notification"
+SRCREV = "2567"
+PV = "0.1.0+svnr${SRCPV}"
+PR = "r1"
+
+inherit openmoko-panel-plugin
+
diff --git a/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-memory_svn.bb b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-memory_svn.bb
new file mode 100644
index 0000000000..767546f2d6
--- /dev/null
+++ b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-memory_svn.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Shows an out-of-memory warning in the Openmoko panel"
+DEPENDS = "libnotify"
+RDEPENDS_${PN} = "openmoko-dialer2"
+SRCREV = "3903"
+PV = "0.0.0+svnr${SRCPV}"
+PR = "r1"
+
+inherit openmoko-panel-plugin
diff --git a/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-usb_svn.bb b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-usb_svn.bb
new file mode 100644
index 0000000000..272df4c644
--- /dev/null
+++ b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-usb_svn.bb
@@ -0,0 +1,6 @@
+DESCRIPTION = "USB applet for the Openmoko panel"
+SRCREV = "3360"
+PV = "0.1.0+svnr${SRCPV}"
+
+inherit openmoko-panel-plugin
+
diff --git a/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-wifi_svn.bb b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-wifi_svn.bb
new file mode 100644
index 0000000000..ae8a6977ea
--- /dev/null
+++ b/recipes/obsolete/openmoko-panel-plugins/openmoko-panel-wifi_svn.bb
@@ -0,0 +1,7 @@
+DESCRIPTION = "Shows the wifi status in the Openmoko panel"
+DEPENDS = "libmokopanelui2"
+SRCREV = "4344"
+PV = "0.0.0+svnr${SRCPV}"
+
+inherit openmoko-panel-plugin
+
diff --git a/recipes/obsolete/openmoko2/openmoko-session2.bb b/recipes/obsolete/openmoko2/openmoko-session2.bb
new file mode 100644
index 0000000000..d0c3268e0c
--- /dev/null
+++ b/recipes/obsolete/openmoko2/openmoko-session2.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "Custom Matchbox session files for Openmoko"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS_${PN} = "matchbox-panel-2 openmoko-common2 openmoko-today2 openmoko-dialer2"
+RCONFLICTS_${PN} = "openmoko-session matchbox-common"
+PR = "r69"
+
+SRC_URI = "\
+ file://etc \
+ file://matchbox-session \
+"
+
+S = "${WORKDIR}"
+
+inherit update-alternatives
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0655 ${WORKDIR}/matchbox-session ${D}${bindir}
+ install -d ${D}${sysconfdir}
+ cp -R ${S}/etc/* ${D}${sysconfdir}
+ rm -fR ${D}${sysconfdir}/.svn
+ rm -fR ${D}${sysconfdir}/matchbox/.svn
+ chmod -R 755 ${D}${sysconfdir}/
+}
+
+PACKAGE_ARCH = "all"
+
+pkg_postinst_openmoko-session2 () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Moko
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme openmoko-standard
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 5"
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/wallpaper ${datadir}/pixmaps/wallpaper.png
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /desktop/poky/interface/digital_clock 1
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type int --set /desktop/poky/peripherals/mouse/drag_threshold 8
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type int --set /desktop/openmoko/neod/power_management 2
+# gstreamer audio settings
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct -t string --set /system/gstreamer/0.10/default/audiosink pulsesink
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct -t string --set /system/gstreamer/0.10/default/audiosrc pulsesrc
+
+}
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PRIORITY = "11"
+
+CONFFILES_${PN} = "${sysconfdir}/matchbox/session"
diff --git a/recipes/obsolete/openmoko2/openmoko-session2/etc/matchbox/session b/recipes/obsolete/openmoko2/openmoko-session2/etc/matchbox/session
new file mode 100755
index 0000000000..732cce9d3f
--- /dev/null
+++ b/recipes/obsolete/openmoko2/openmoko-session2/etc/matchbox/session
@@ -0,0 +1,12 @@
+#!/bin/sh
+SHOWCURSOR="no"
+
+openmoko-today &
+phone-kit &
+
+matchbox-window-manager -use_titlebar yes -use_desktop_mode decorated -theme Moko -use_cursor $SHOWCURSOR $@ &
+
+matchbox-panel-2 --start-applets systray,startup \
+ --end-applets openmoko-panel-battery,openmoko-panel-gsm,openmoko-panel-gps,openmoko-panel-usb,openmoko-panel-bt,openmoko-panel-memory,openmoko-panel-wifi --titlebar &
+
+exec neod
diff --git a/recipes/obsolete/openmoko2/openmoko-session2/matchbox-session b/recipes/obsolete/openmoko2/openmoko-session2/matchbox-session
new file mode 100755
index 0000000000..65f1ce72ca
--- /dev/null
+++ b/recipes/obsolete/openmoko2/openmoko-session2/matchbox-session
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# Very simple session manager for matchbox tools
+#
+
+# Uncomment below to enable parsing of debian menu entrys
+# export MB_USE_DEB_MENUS=1
+
+if [ -e $HOME/.matchbox/session ]
+then
+exec $HOME/.matchbox/session
+fi
+
+if [ -e /etc/matchbox/session ]
+then
+exec /etc/matchbox/session
+fi
+
+# Default files to run if $HOME/.matchbox/session or /etc/matchbox/session
+# dont exist.
+
+matchbox-desktop &
+matchbox-panel --orientation south &
+exec matchbox-window-manager $@
diff --git a/recipes/obsolete/tasks/task-openmoko-base.bb b/recipes/obsolete/tasks/task-openmoko-base.bb
new file mode 100644
index 0000000000..3c46c56f5e
--- /dev/null
+++ b/recipes/obsolete/tasks/task-openmoko-base.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Openmoko: Base Task for the Openmoko Linux Distribution"
+SECTION = "openmoko/base"
+LICENSE = "MIT"
+PR = "r74"
+
+inherit task
+
+#
+# task-openmoko-base
+#
+DESCRIPTION_task-openmoko-base = "Openmoko: Top Panel, Application Launcher, Application Manager"
+RDEPENDS_task-openmoko-base = "\
+ matchbox-panel-2 \
+# matchbox-panel-2-applets \
+# matchbox-keyboard-inputmethod \
+# matchbox-keyboard-im \
+# matchbox-keyboard-applet \
+ matchbox-stroke \
+ multitap-pad \
+ vala-terminal \
+# openmoko-keyboard \
+ openmoko-panel-battery \
+ openmoko-panel-clock \
+ openmoko-panel-usb \
+ ${@base_contains('MACHINE_FEATURES', 'bluetooth', 'openmoko-panel-bt', '', d)} \
+ ${@base_contains('MACHINE_FEATURES', 'gps', 'openmoko-panel-gps', '', d)} \
+ ${@base_contains('MACHINE_FEATURES', 'wifi', 'openmoko-panel-wifi', '', d)} \
+ \
+ openmoko-today2 \
+# openmoko-appmanager \
+"
diff --git a/recipes/obsolete/tasks/task-openmoko-debug.bb b/recipes/obsolete/tasks/task-openmoko-debug.bb
new file mode 100644
index 0000000000..f30a024824
--- /dev/null
+++ b/recipes/obsolete/tasks/task-openmoko-debug.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "Openmoko: Debugging and Benchmarking Tools"
+SECTION = "openmoko/base"
+LICENSE = "MIT"
+PR = "r59.01"
+
+inherit task
+
+RDEPENDS_task-openmoko-debug = "\
+ alsa-utils-amixer \
+ alsa-utils-aplay \
+ alsa-utils-aconnect \
+ alsa-utils-alsamixer \
+ alsa-utils-speakertest \
+ bonnie++ \
+ cu \
+ dbench \
+ fbgrab \
+ fbset \
+ fstests \
+ gdb \
+ gdbserver \
+ lrzsz \
+ lsof \
+ ltrace \
+ memtester \
+# sensors-i2cdetect sensors-i2cdump sensors-i2cset \
+ strace \
+ tcpdump \
+ tslib-calibrate \
+ tslib-tests \
+ udev-utils \
+ usbutils \
+ uucp \
+ vorbis-tools \
+ x11perf \
+ xev \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'madplay', d)} \
+"
diff --git a/recipes/obsolete/tasks/task-openmoko-examples.bb b/recipes/obsolete/tasks/task-openmoko-examples.bb
new file mode 100644
index 0000000000..7ebe32d725
--- /dev/null
+++ b/recipes/obsolete/tasks/task-openmoko-examples.bb
@@ -0,0 +1,6 @@
+DESCRIPTION = "Openmoko: Examples for the Openmoko Linux Distribution"
+SECTION = "openmoko/base"
+LICENSE = "MIT"
+PR = "r71"
+
+inherit task
diff --git a/recipes/obsolete/tasks/task-openmoko-feed.bb b/recipes/obsolete/tasks/task-openmoko-feed.bb
new file mode 100644
index 0000000000..66ddecd1cc
--- /dev/null
+++ b/recipes/obsolete/tasks/task-openmoko-feed.bb
@@ -0,0 +1,157 @@
+DESCRIPTION = "Openmoko: Misc. Feed Items"
+SECTION = "openmoko/base"
+LICENSE = "MIT"
+PR = "r62"
+
+inherit task
+
+RDEPENDS_task-openmoko-feed = "\
+ aspell enchant \
+ openmoko-agpsui \
+ gypsy \
+ fso-gsm0710muxd \
+ ppp \
+ bluez-hcidump \
+ bootchart \
+ eet evas ecore embryo edje efreet emotion epdf \
+ edje-viewer \
+ free42-vga \
+ gpe-filemanager gpe-gallery gpe-timesheet gpe-todo gpe-contacts \
+ leafpad abiword \
+ claws-mail claws-plugin-mailmbox claws-plugin-gtkhtml2-viewer claws-plugin-rssyl \
+ ipkg-link ipkg-utils \
+ joe \
+ kbdd \
+ kexec-tools \
+ midori \
+ dillo \
+ fennec \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'mplayer', d)} \
+ mtpaint \
+ mysql \
+ nano \
+ ntpclient ntp \
+ openssh openssh-scp openssh-ssh openssh-sshd openssh-sftp openssh-misc \
+ python python-pygtk python-pyserial python-gst python-pygame \
+# python-lightblue \
+ python-pybluez \
+ obexpush \
+ ruby \
+ libsdl-x11 libsdl-mixer libsdl-net libsdl-ttf \
+ settingsgui \
+ synergy \
+ tzdata \
+ tor \
+ vnc \
+ wxwidgets \
+ x11vnc \
+ libswt3.4-gtk-java \
+ cacao \
+ jamvm \
+ classpath \
+ gpsdrive \
+ gpsd \
+ asterisk \
+ gnash \
+ mono \
+ diversity-daemon \
+ om-maps-berlin \
+ om-maps-buenos-aires \
+ om-maps-hong-kong \
+ om-maps-london \
+ om-maps-low-levels \
+ om-maps-new-york \
+ om-maps-paris \
+ om-maps-providence \
+ om-maps-san-francisco \
+ om-maps-sydney \
+ om-maps-taipei \
+ tangogps \
+ pyefl-sudoku \
+ minicom \
+ iotop \
+ evince \
+ epdfview \
+ xprop \
+ xev \
+ xwininfo \
+ gpsd \
+ mc \
+ devmem2 \
+ bluez-utils-alsa \
+ tcpdump \
+ gdb \
+ lsof \
+ openmoko-set-root-password \
+# qtopia-phone-enable-debug \
+ git \
+ navit \
+ libnotify \
+ notification-daemon \
+ libxine \
+# subversion \
+ task-openmoko-games \
+ xournal \
+ openvpn \
+ python-pygame \
+ irssi \
+ zsh \
+ fbreader \
+ gzip \
+ zip \
+ firefox \
+ pidgin \
+ epdfview \
+ midori \
+ microcom \
+ zhone \
+ frameworkd \
+ emacs \
+ gpe-scap \
+# for werner \
+ net-tools \
+ iproute2 \
+ iputils \
+ psmisc \
+ debianutils \
+ tcptraceroute \
+ task-proper-tools \
+ wmiconfig \
+ netkit-telnet \
+ bind-utils \
+ font-adobe-100dpi \
+ font-adobe-75dpi \
+ font-adobe-utopia-100dpi \
+ font-adobe-utopia-75dpi \
+ font-adobe-utopia-type1 \
+ font-arabic-misc \
+ font-bh-100dpi \
+ font-bh-75dpi \
+ font-bh-lucidatypewriter-100dpi \
+ font-bh-lucidatypewriter-75dpi \
+ font-bh-ttf \
+ font-bh-type1 \
+ font-bitstream-100dpi \
+ font-bitstream-75dpi \
+ font-bitstream-speedo \
+ font-bitstream-type1 \
+ font-cronyx-cyrillic \
+ font-cursor-misc \
+ font-daewoo-misc \
+ font-dec-misc \
+ font-ibm-type1 \
+ font-isas-misc \
+ font-jis-misc \
+ font-micro-misc \
+ font-misc-cyrillic \
+ font-misc-ethiopic \
+ font-misc-meltho \
+ font-misc-misc \
+ font-mutt-misc \
+ font-schumacher-misc \
+ font-screen-cyrillic \
+ font-sony-misc \
+ font-sun-misc \
+ font-winitzki-cyrillic \
+ font-xfree86-type1 \
+"
diff --git a/recipes/obsolete/tasks/task-openmoko-games.bb b/recipes/obsolete/tasks/task-openmoko-games.bb
new file mode 100644
index 0000000000..c4aaa70779
--- /dev/null
+++ b/recipes/obsolete/tasks/task-openmoko-games.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Openmoko: Games for the Openmoko Linux Distribution"
+SECTION = "openmoko/base"
+LICENSE = "MIT"
+PR = "r72"
+
+inherit task
+
+#
+# task-openmoko-games
+#
+DESCRIPTION_task-openmoko-games = "Openmoko: Games"
+RDEPENDS_task-openmoko-games = "\
+ oh-puzzles \
+ kobodeluxe \
+"
diff --git a/recipes/obsolete/tasks/task-openmoko-linux.bb b/recipes/obsolete/tasks/task-openmoko-linux.bb
new file mode 100644
index 0000000000..dbd3a72c45
--- /dev/null
+++ b/recipes/obsolete/tasks/task-openmoko-linux.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Openmoko: Core system for the Openmoko Linux Distribution"
+SECTION = "openmoko/base"
+LICENSE = "MIT"
+PR = "r72"
+
+inherit task
+
+#
+# task-openmoko-core
+#
+DESCRIPTION_task-openmoko-linux = "Openmoko: Linux Core Services"
+RDEPENDS_task-openmoko-linux = "\
+ task-base \
+ udev-static-devices \
+ rsync \
+ screen \
+ fbset \
+ fbset-modes \
+"
diff --git a/recipes/obsolete/tasks/task-openmoko-native-sdk.bb b/recipes/obsolete/tasks/task-openmoko-native-sdk.bb
new file mode 100644
index 0000000000..56f6824df4
--- /dev/null
+++ b/recipes/obsolete/tasks/task-openmoko-native-sdk.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Openmoko: Native SDK"
+SECTION = "openmoko/base"
+LICENSE = "MIT"
+PR = "r58"
+
+inherit task
+
+RDEPENDS_task-openmoko-native-sdk = "\
+ binutils \
+ binutils-symlinks \
+ gcc \
+ gcc-symlinks \
+ cpp \
+ cpp-symlinks \
+ cvs \
+ libc6-dev \
+ libgcc-dev \
+ glibc-utils \
+ ldd \
+ g++ \
+ g++-symlinks \
+ libstdc++-dev \
+ \
+ make \
+ flex \
+ flex-dev \
+ bison \
+ gawk \
+ grep \
+ sed \
+ automake \
+ autoconf \
+ patch \
+ patchutils \
+ diffstat \
+ diffutils \
+ libtool \
+ pkgconfig \
+ \
+ xoo \
+"
diff --git a/recipes/obsolete/tasks/task-openmoko-net.bb b/recipes/obsolete/tasks/task-openmoko-net.bb
new file mode 100644
index 0000000000..d58b05aa62
--- /dev/null
+++ b/recipes/obsolete/tasks/task-openmoko-net.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Openmoko: Networking for the Openmoko Linux Distribution"
+SECTION = "openmoko/base"
+LICENSE = "MIT"
+PR = "r71"
+
+inherit task
+
+#
+# task-openmoko-net
+#
+DESCRIPTION_task-openmoko-net = "Openmoko: Linux Advanced Networking"
+RDEPENDS_task-openmoko-net = "\
+ bluez-utils \
+ bridge-utils \
+"
diff --git a/recipes/obsolete/tasks/task-openmoko-phone.bb b/recipes/obsolete/tasks/task-openmoko-phone.bb
new file mode 100644
index 0000000000..306ff058dd
--- /dev/null
+++ b/recipes/obsolete/tasks/task-openmoko-phone.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Openmoko: Tasks for the Openmoko Linux Distribution"
+SECTION = "openmoko/base"
+LICENSE = "MIT"
+PR = "r73"
+
+inherit task
+
+#
+# task-openmoko-phone
+#
+DESCRIPTION_task-openmoko-phone = "Openmoko: GSM and GPRS Phone Services"
+RDEPENDS_task-openmoko-phone = "\
+ gsmd \
+ libgsmd-tools \
+ openmoko-dialer2 \
+ openmoko-panel-gsm \
+ openmoko-panel-memory \
+# ppp \
+"
diff --git a/recipes/obsolete/tasks/task-openmoko-pim.bb b/recipes/obsolete/tasks/task-openmoko-pim.bb
new file mode 100644
index 0000000000..ba2ced56f6
--- /dev/null
+++ b/recipes/obsolete/tasks/task-openmoko-pim.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Openmoko: PIM for the Openmoko Linux Distribution"
+SECTION = "openmoko/base"
+LICENSE = "MIT"
+PR = "r72"
+
+inherit task
+
+#
+# task-openmoko-pim
+#
+DESCRIPTION_task-openmoko-pim = "Openmoko: Personal Information Management Suite"
+RDEPENDS_task-openmoko-pim = "\
+ eds-dbus \
+ openmoko-calculator2 \
+# openmoko-contacts2 \
+# openmoko-dates2 \
+# openmoko-feedreader2 \
+ openmoko-browser2 \
+ openmoko-appmanager2 \
+# openmoko-tasks2 \
+ openmoko-mediaplayer2 \
+ openmoko-messages2 \
+"
diff --git a/recipes/obsolete/tasks/task-openmoko-python-devel.bb b/recipes/obsolete/tasks/task-openmoko-python-devel.bb
new file mode 100644
index 0000000000..7b375c0617
--- /dev/null
+++ b/recipes/obsolete/tasks/task-openmoko-python-devel.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Openmoko: Python Development Tools"
+SECTION = "openmoko/devel"
+LICENSE = "MIT"
+PR = "r3"
+
+inherit task
+
+RDEPENDS_task-openmoko-python-devel = "\
+ task-python-efl \
+ python-pygtk \
+"
diff --git a/recipes/obsolete/tasks/task-openmoko-toolchain-host.bb b/recipes/obsolete/tasks/task-openmoko-toolchain-host.bb
new file mode 100644
index 0000000000..7d4398b201
--- /dev/null
+++ b/recipes/obsolete/tasks/task-openmoko-toolchain-host.bb
@@ -0,0 +1,15 @@
+require task-sdk-host.bb
+
+DESCRIPTION = "Packages for a standalone Openmoko SDK or external toolchain"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+
+PR = "r2"
+
+PACKAGES = "${PN}"
+
+RDEPENDS_${PN} += "\
+ openmoko-sample2-src \
+ openmoko-toolchain-scripts \
+ edje-sdk \
+"
diff --git a/recipes/obsolete/tasks/task-openmoko-toolchain-target.bb b/recipes/obsolete/tasks/task-openmoko-toolchain-target.bb
new file mode 100644
index 0000000000..6d4ee6254f
--- /dev/null
+++ b/recipes/obsolete/tasks/task-openmoko-toolchain-target.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Packages for a standalone Openmoko SDK or external toolchain"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+
+PR = "r3"
+
+PACKAGES = "${PN}"
+
+RDEPENDS_${PN} = "\
+ glibc \
+ glibc-dbg \
+ glibc-dev \
+ glibc-utils \
+ libsegfault \
+ glibc-thread-db \
+ glibc-localedata-i18n \
+ glibc-gconv-ibm850 \
+ glibc-gconv-cp1252 \
+ glibc-gconv-iso8859-1 \
+ glibc-gconv-iso8859-15 \
+ libgcc \
+ libstdc++ \
+"
diff --git a/recipes/obsolete/tasks/task-openmoko-ui.bb b/recipes/obsolete/tasks/task-openmoko-ui.bb
new file mode 100644
index 0000000000..71020afef6
--- /dev/null
+++ b/recipes/obsolete/tasks/task-openmoko-ui.bb
@@ -0,0 +1,58 @@
+DESCRIPTION = "Openmoko: GUI for the Openmoko Linux Distribution"
+SECTION = "openmoko/base"
+LICENSE = "MIT"
+PR = "r73"
+
+inherit task
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+#
+# task-openmoko-ui
+#
+DESCRIPTION_task-openmoko-ui = "Openmoko: The X11/Gtk+2 based native User Interface"
+PACKAGE_ARCH_task-openmoko-ui = "${MACHINE_ARCH}"
+RDEPENDS_task-openmoko-ui = "\
+ gdk-pixbuf-loader-png \
+ gdk-pixbuf-loader-gif \
+ gdk-pixbuf-loader-xpm \
+ gdk-pixbuf-loader-jpeg \
+ pango-module-basic-x \
+ pango-module-basic-fc \
+ gtk+ \
+ matchbox-wm \
+ ${XSERVER} \
+ xserver-kdrive-common \
+ xserver-nodm-init \
+ xauth \
+ xhost \
+ xset \
+ xrandr \
+ \
+ settings-daemon \
+ notification-daemon \
+ neod \
+ libnotify \
+ \
+ openmoko-session2 \
+ openmoko-sound-system2 \
+ openmoko-sound-theme-standard2 \
+ \
+ gpe-scap \
+"
+
+# Handle theming. FIXME: properly use machine database in a smart way,
+# taking into account not only size but also PPI! Ultimately this might
+# need recomputing some theme files and images on-the-fly :/ SVG and logical
+# theme description anyone? Or simply Edje to the rescue! :D
+THEMES = "openmoko-icon-theme-standard2 moko-gtk-engine"
+THEMES_a780 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_e680 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_a1200 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_rokre2 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_rokre6 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_magician = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_chumby = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_htcblueangel = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+
+RDEPENDS_task-openmoko-ui += "${THEMES}"
diff --git a/recipes/obsolete/tasks/task-openmoko.bb b/recipes/obsolete/tasks/task-openmoko.bb
new file mode 100644
index 0000000000..6c195ba078
--- /dev/null
+++ b/recipes/obsolete/tasks/task-openmoko.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Openmoko: Tasks for the Openmoko Linux Distribution"
+SECTION = "openmoko/base"
+LICENSE = "MIT"
+PROVIDES = "task-openmoko-everything"
+PR = "r71"
+
+inherit task
+
+PACKAGES += "\
+ task-openmoko-everything \
+"
+
+RDEPENDS_task-openmoko-everything := "\
+ task-openmoko-linux \
+ task-openmoko-ui \
+ task-openmoko-base \
+ task-openmoko-phone \
+ task-openmoko-pim \
+ task-openmoko-net \
+ task-openmoko-games \
+ task-openmoko-examples \
+ task-openmoko-debug \
+ task-openmoko-native-sdk \
+"
+
+
+
+
+
+
+