aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openbmap
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-03-29 15:01:28 +0200
committerStefan Schmidt <stefan@datenfreihafen.org>2009-03-29 15:01:28 +0200
commit6374461dcf746df93e72d0b46de09f3442542b39 (patch)
tree3872b07ffec3fb2d5c6c00a354c827d9db7e3645 /recipes/openbmap
parent2c722ec1d6e055423234bf821db84e1e666dd9d0 (diff)
downloadopenembedded-6374461dcf746df93e72d0b46de09f3442542b39.tar.gz
openbmap: Add version 0.2.0
Diffstat (limited to 'recipes/openbmap')
-rw-r--r--recipes/openbmap/openbmap-logger_0.2.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/openbmap/openbmap-logger_0.2.0.bb b/recipes/openbmap/openbmap-logger_0.2.0.bb
new file mode 100644
index 0000000000..72e66441da
--- /dev/null
+++ b/recipes/openbmap/openbmap-logger_0.2.0.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "openBmap logger and uploader of GPS/GSM data"
+SECTION = "x11/utils"
+DEPENDS = "python python-dbus python-pygobject python-pygtk libglade"
+RDEPENDS = "python-subprocess python-netclient python-math python-core python-io"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/myposition/openbmap-logger-${PV}.tar.gz"
+
+FILES_${PN} += "${datadir}/openBmap/* ${libdir}/python2.6/site-packages/openbmap/*"
+
+do_configure () {
+ :
+}
+
+do_compile () {
+ :
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 openBmapGTK ${D}${bindir}/
+ install -d ${D}${libdir}/python2.6/site-packages/openbmap/
+ install -m 0644 openbmap/__init__.py ${D}${libdir}/python2.6/site-packages/openbmap/
+ install -m 0644 openbmap/logger.py ${D}${libdir}/python2.6/site-packages/openbmap/
+ install -m 0644 openbmap/Upload.py ${D}${libdir}/python2.6/site-packages/openbmap/
+ install -d ${D}${datadir}/pixmaps
+ install -d ${D}${datadir}/applications
+ install -d ${D}${datadir}/openBmap
+ install -m 0644 openBmap.desktop ${D}${datadir}/applications/openBmap.desktop
+ install -m 0644 openBmap-desktop.png ${D}${datadir}/pixmaps/openBmap-desktop.png
+ install -m 0644 ExitButton.png ${D}${datadir}/openBmap/ExitButton.png
+ install -m 0644 GenerateButton.png ${D}${datadir}/openBmap/GenerateButton.png
+ install -m 0644 StopButton.png ${D}${datadir}/openBmap/StopButton.png
+ install -m 0644 UploadButton.png ${D}${datadir}/openBmap/UploadButton.png
+ install -m 0644 Main.glade ${D}${datadir}/openBmap/Main.glade
+}
+