aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openbmap
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-23 15:20:19 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-25 09:28:26 +0300
commit658ae76b938a90ac3587909f6b8525559fe57b56 (patch)
tree9216406ea230a65552429cb71c190c0e00d04c2d /recipes/openbmap
parente0f9409803d6edc14608828967c0c52b5a2d182e (diff)
downloadopenembedded-658ae76b938a90ac3587909f6b8525559fe57b56.tar.gz
use PYTHON_SITEPACKAGES_DIR
Converted most of python site-packages references to PYTHON_SITEPACKAGES_DIR. Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/openbmap')
-rw-r--r--recipes/openbmap/openbmap-logger_0.2.0.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/recipes/openbmap/openbmap-logger_0.2.0.bb b/recipes/openbmap/openbmap-logger_0.2.0.bb
index 72e66441da..f2fff6ea2d 100644
--- a/recipes/openbmap/openbmap-logger_0.2.0.bb
+++ b/recipes/openbmap/openbmap-logger_0.2.0.bb
@@ -4,9 +4,11 @@ DEPENDS = "python python-dbus python-pygobject python-pygtk libglade"
RDEPENDS = "python-subprocess python-netclient python-math python-core python-io"
PR = "r1"
+inherit python-dir
+
SRC_URI = "${SOURCEFORGE_MIRROR}/myposition/openbmap-logger-${PV}.tar.gz"
-FILES_${PN} += "${datadir}/openBmap/* ${libdir}/python2.6/site-packages/openbmap/*"
+FILES_${PN} += "${datadir}/openBmap/* ${PYTHON_SITEPACKAGES_DIR}/openbmap/*"
do_configure () {
:
@@ -19,10 +21,10 @@ do_compile () {
do_install () {
install -d ${D}${bindir}
install -m 0755 openBmapGTK ${D}${bindir}/
- install -d ${D}${libdir}/python2.6/site-packages/openbmap/
- install -m 0644 openbmap/__init__.py ${D}${libdir}/python2.6/site-packages/openbmap/
- install -m 0644 openbmap/logger.py ${D}${libdir}/python2.6/site-packages/openbmap/
- install -m 0644 openbmap/Upload.py ${D}${libdir}/python2.6/site-packages/openbmap/
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}/openbmap/
+ install -m 0644 openbmap/__init__.py ${D}${PYTHON_SITEPACKAGES_DIR}/openbmap/
+ install -m 0644 openbmap/logger.py ${D}${PYTHON_SITEPACKAGES_DIR}/openbmap/
+ install -m 0644 openbmap/Upload.py ${D}${PYTHON_SITEPACKAGES_DIR}/openbmap/
install -d ${D}${datadir}/pixmaps
install -d ${D}${datadir}/applications
install -d ${D}${datadir}/openBmap