aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openchrome/configure.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/openchrome/configure.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/openchrome/configure.patch')
-rw-r--r--recipes/openchrome/configure.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/openchrome/configure.patch b/recipes/openchrome/configure.patch
new file mode 100644
index 0000000000..a2f236470d
--- /dev/null
+++ b/recipes/openchrome/configure.patch
@@ -0,0 +1,42 @@
+--- trunk/configure.ac 2007-01-16 16:58:44.000000000 +0000
++++ trunk/configure.ac 2007-01-16 18:09:26.000000000 +0000
+@@ -69,11 +69,11 @@
+ AC_HEADER_STDC
+
+ if test "$DRI" != no; then
+- AC_CHECK_FILE([${sdkdir}/dri.h],
++ AC_CHECK_BUILD_FILE([${sdkdir}/dri.h],
+ [have_dri_h="yes"], [have_dri_h="no"])
+- AC_CHECK_FILE([${sdkdir}/sarea.h],
++ AC_CHECK_BUILD_FILE([${sdkdir}/sarea.h],
+ [have_sarea_h="yes"], [have_sarea_h="no"])
+- AC_CHECK_FILE([${sdkdir}/dristruct.h],
++ AC_CHECK_BUILD_FILE([${sdkdir}/dristruct.h],
+ [have_dristruct_h="yes"], [have_dristruct_h="no"])
+ fi
+
+@@ -113,7 +113,7 @@
+
+ AM_CONDITIONAL(XVMC, test x$XVMC = xyes)
+
+-AC_CHECK_FILE([${sdkdir}/xf86Module.h],
++AC_CHECK_BUILD_FILE([${sdkdir}/xf86Module.h],
+ [have_xf86Module_h="yes"], [have_xf86Module_h="no"])
+
+ # Check the ABI_VIDEODRV_VERSION
+--- /dev/null 2003-09-15 14:40:47.000000000 +0100
++++ trunk/m4/check-build.m4 2007-01-16 18:07:37.000000000 +0000
+@@ -0,0 +1,13 @@
++# Check for the existence of FILE.
++AC_DEFUN([AC_CHECK_BUILD_FILE],
++[AS_VAR_PUSHDEF([ac_File], [ac_cv_file_$1])dnl
++AC_CACHE_CHECK([for $1], ac_File,
++[if test -r "$1"; then
++ AS_VAR_SET(ac_File, yes)
++else
++ AS_VAR_SET(ac_File, no)
++fi])
++AS_IF([test AS_VAR_GET(ac_File) = yes], [$2], [$3])[]dnl
++AS_VAR_POPDEF([ac_File])dnl
++])# AC_CHECK_BUILD_FILE
++