aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openh323
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/openh323
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/openh323')
-rw-r--r--recipes/openh323/openh323/fixes.patch111
-rw-r--r--recipes/openh323/openh323_1.13.5.4.bb50
2 files changed, 161 insertions, 0 deletions
diff --git a/recipes/openh323/openh323/fixes.patch b/recipes/openh323/openh323/fixes.patch
new file mode 100644
index 0000000000..81409f30a7
--- /dev/null
+++ b/recipes/openh323/openh323/fixes.patch
@@ -0,0 +1,111 @@
+--- openh323/configure.in 2004-01-31 00:37:15.000000000 -0700
++++ openh323.new/configure.in 2005-01-06 10:17:31.576277416 -0700
+@@ -36,62 +36,12 @@
+
+ echo "OpenH323 version is ${OPENH323_VERSION}"
+
+-AC_DEFINE_UNQUOTED(OPENH323_MAJOR, $MAJOR_VERSION)
+-AC_DEFINE_UNQUOTED(OPENH323_MINOR, $MINOR_VERSION)
+-AC_DEFINE_UNQUOTED(OPENH323_BUILD, $BUILD_NUMBER)
+-AC_DEFINE_UNQUOTED(OPENH323_VERSION, "$OPENH323_VERSION")
+-
+-dnl ########################################################################
+-dnl look for ptlib, use a preference order of explicit PWLIBDIR, directory
+-dnl at same level, home directory, /usr/local or /usr.
+-
+-if test "${PWLIBDIR:-unset}" != "unset" ; then
+- AC_CHECK_FILE(${PWLIBDIR}/version.h, HAS_PTLIB=1)
+-fi
+-if test "${HAS_PTLIB:-unset}" = "unset" ; then
+- AC_CHECK_FILE(${OPENH323DIR}/../pwlib/version.h, HAS_PTLIB=1)
+- if test "${HAS_PTLIB:-unset}" != "unset" ; then
+- PWLIBDIR="${OPENH323DIR}/../pwlib"
+- else
+- AC_CHECK_FILE(${HOME}/pwlib/include/ptlib.h, HAS_PTLIB=1)
+- if test "${HAS_PTLIB:-unset}" != "unset" ; then
+- PWLIBDIR="${HOME}/pwlib"
+- else
+- AC_CHECK_FILE(/usr/local/include/ptlib.h, HAS_PTLIB=1)
+- if test "${HAS_PTLIB:-unset}" != "unset" ; then
+- AC_PATH_PROG(PTLIB_CONFIG, ptlib-config, , /usr/local/bin)
+- else
+- AC_CHECK_FILE(/usr/include/ptlib.h, HAS_PTLIB=1)
+- if test "${HAS_PTLIB:-unset}" != "unset" ; then
+- AC_PATH_PROG(PTLIB_CONFIG, ptlib-config, , /usr/share/pwlib/make/)
+- fi
+- fi
+- fi
+- fi
+-fi
+-
+-if test "${HAS_PTLIB:-unset}" = "unset" ; then
+- echo "Cannot find pwlib - please install or set PWLIBDIR and try again"
+- exit
+-fi
+-
+-if test "${PWLIBDIR:-unset}" = "unset" ; then
+- if test "${PTLIB_CONFIG:-unset}" = "unset" ; then
+- echo "Cannot find ptlib-config - please install and try again"
+- exit
+- fi
+- PWLIBDIR=`$PTLIB_CONFIG --prefix`
+-fi
+-
+-if test "x$PWLIBDIR" = "x/usr" -o "x$PWLIBDIR" = "x/usr/"; then
+- PWLIBDIR="/usr/share/pwlib/"
+-fi
+-if test "xPWLIBDIR" = "x/usr/local" -o "x$PWLIBDIR" = "x/usr/"; then
+- PWLIBDIR="/usr/local/share/pwlib/"
+-fi
++AC_DEFINE_UNQUOTED(OPENH323_MAJOR, $MAJOR_VERSION,[THis is the build major])
++AC_DEFINE_UNQUOTED(OPENH323_MINOR, $MINOR_VERSION,[This is the build minor])
++AC_DEFINE_UNQUOTED(OPENH323_BUILD, $BUILD_NUMBER,[THis is the build version])
++AC_DEFINE_UNQUOTED(OPENH323_VERSION, "$OPENH323_VERSION", [THis is the build number])
+
+ echo "PWLib prefix set to.... $PWLIBDIR"
+-
+ AC_SUBST(PWLIBDIR)
+
+
+@@ -103,8 +53,8 @@
+
+ dnl MSWIN_DISPLAY video,Video System
+ dnl MSWIN_DEFINE video,H323_VIDEO
+-AC_DEFINE(H323_AUDIO_CODECS,1)
+-AC_DEFINE(H323_VIDEO,1)
++AC_DEFINE(H323_AUDIO_CODECS,1,[Define this if you are using audio codecs])
++AC_DEFINE(H323_VIDEO,1,[Define this if you are using video])
+
+
+ dnl ########################################################################
+@@ -197,7 +147,7 @@
+ AC_MSG_NOTICE(Forcing use of local Speex sources)
+ elif test "${localspeex}" = "no" ; then
+ AC_MSG_NOTICE(Forcing use of system Speex library)
+- AC_DEFINE(H323_SYSTEM_SPEEX, 1)
++ AC_DEFINE(H323_SYSTEM_SPEEX, 1, [Define this if you are using the system Speex])
+ AC_SUBST(H323_SYSTEM_SPEEX, 1)
+ else
+ AC_CHECK_LIB(speex, speex_encoder_destroy, SPEEX=1)
+@@ -272,9 +222,9 @@
+ dnl MSWIN_DISPLAY ixj,Quicknet Internet xJACK cards
+ dnl MSWIN_DEFINE ixj,HAS_IXJ
+
+-AC_CHECK_HEADERS(linux/telephony.h sys/telephony.h /usr/local/include/sys/telephony.h, HAS_IXJ=1)
++AC_CHECK_HEADERS(linux/telephony.h, HAS_IXJ=1)
+ if test "x$HAS_IXJ" != "x" ; then
+- AC_DEFINE(HAS_IXJ, 1)
++ AC_DEFINE(HAS_IXJ, 1,[Define this if you are using Quicknet])
+ fi
+
+ dnl ########################################################################
+--- openh323/include/gkserver.h 2004-08-07 05:11:52.000000000 -0700
++++ openh323.new/include/gkserver.h 2005-01-05 19:11:45.000000000 -0700
+@@ -405,7 +405,6 @@
+ H225_GatekeeperConfirm & gcf;
+ H225_GatekeeperReject & grj;
+
+- protected:
+ virtual Response OnHandlePDU();
+ };
+
diff --git a/recipes/openh323/openh323_1.13.5.4.bb b/recipes/openh323/openh323_1.13.5.4.bb
new file mode 100644
index 0000000000..8a3aaee941
--- /dev/null
+++ b/recipes/openh323/openh323_1.13.5.4.bb
@@ -0,0 +1,50 @@
+# openh323 .bb build file
+# Copyright (C) 2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see /COPYING)
+
+HOMEPAGE="http://www.openh323.org/"
+DESCRIPTION="Open Soure ITU-T H.323 teleconferencing protocol implementation."
+LICENSE = "GPL"
+
+SRC_URI="http://http.us.debian.org/debian/pool/main/o/${PN}/${PN}_${PV}.orig.tar.gz \
+ file://fixes.patch;patch=1"
+
+S="${WORKDIR}/${PN}"
+DEPENDS="pwlib openssl"
+
+export PWLIBDIR= "${STAGING_DATADIR}/pwlib"
+export PTLIB_CONFIG= "${STAGING_DATADIR}/pwlib/make/ptlib-config"
+export OPENH323DIR= "${S}"
+
+export OPENSSLFLAG= "1"
+export OPENSSLDIR= "${STAGING_LIBDIR}"
+export OPENSSLLIBS="-lssl -lcrypt"
+export MACHTYPE="x86"
+export OSTYPE="linux"
+export OSRELEASE="openembedded"
+export CPLUS="${CXX}"
+
+inherit autotools
+EXTRA_OECONF="--enable-localspeex"
+
+FILES_${PN} = "/usr/lib"
+FILES_${PN}-dev += "/usr/share"
+
+do_compile() {
+ oe_runmake opt
+}
+
+HEADERS="QTIoctl.h channels.h codecs.h cu30codec.h dynacodec.h ffh263codec.h g7231codec.h g726codec.h g729codec.h gccpdu.h gkclient.h gkserver.h gsmcodec.h guid.h h225.h h225ras.h h235.h h235auth.h h245.h h248.h h261codec.h h263codec.h h323.h h323annexg.h h323caps.h h323con.h h323ep.h h323neg.h h323pdu.h h323rtp.h h323t120.h h323t38.h h323trans.h h4501.h h45010.h h45011.h h4502.h h4504.h h4505.h h4506.h h4507.h h4508.h h4509.h h450pdu.h h501.h h501pdu.h ilbccodec.h ixjDefs.h ixjidb.h ixjlid.h jitter.h lid.h lpc10codec.h mcspdu.h mediafmt.h mscodecs.h opalvxml.h opalwavfile.h openh323buildopts.h openh323buildopts.h.in peclient.h q931.h rfc2833.h rtp.h rtp2wav.h speexcodec.h svcctrl.h t120proto.h t38.h t38proto.h transports.h vblasterlid.h vpblid.h x224.h x880.h"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/openh323
+ for file in ${HEADERS}; do
+ install -m 0644 include/$file ${STAGING_INCDIR}/openh323
+ done
+
+ oe_libinstall -C lib libh323_linux_x86_r ${STAGING_LIBDIR}
+ ln -sf ${STAGING_LIBDIR}/libh323_linux_x86_r.so ${STAGING_LIBDIR}/libopenh323.so
+
+ install -d ${STAGING_DATADIR}/openh323
+ install -m 0644 openh323u.mak ${STAGING_DATADIR}/openh323
+}