aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openjade
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/openjade
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/openjade')
-rw-r--r--recipes/openjade/openjade-1.3.2/configure.patch70
-rw-r--r--recipes/openjade/openjade-1.3.2/oj-native-libosp-fix.patch12
-rw-r--r--recipes/openjade/openjade-native_1.3.2.bb50
-rw-r--r--recipes/openjade/openjade_1.3.2.bb30
4 files changed, 162 insertions, 0 deletions
diff --git a/recipes/openjade/openjade-1.3.2/configure.patch b/recipes/openjade/openjade-1.3.2/configure.patch
new file mode 100644
index 0000000000..c6cd78745a
--- /dev/null
+++ b/recipes/openjade/openjade-1.3.2/configure.patch
@@ -0,0 +1,70 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- /dev/null 2003-09-23 18:19:32.000000000 -0400
++++ openjade-1.3.2/config/acinclude.m4 2004-01-20 14:39:20.000000000 -0500
+@@ -0,0 +1,62 @@
++dnl
++dnl Examine size_t and define SIZE_T_IS_UINT, if size_t is an unsigned int
++dnl
++AC_DEFUN(OJ_SIZE_T_IS_UINT,[
++ AC_REQUIRE([AC_TYPE_SIZE_T])
++ AC_MSG_CHECKING(whether size_t is unsigned int)
++ ac_cv_size_t_is_uint=no
++ AC_LANG_SAVE
++ AC_LANG_CPLUSPLUS
++ AC_TRY_COMPILE([#include <unistd.h>
++
++ template<class T> class foo { };
++
++ ], [
++ foo<size_t> x;
++ foo<unsigned int> y;
++ x = y;
++ ],ac_cv_size_t_is_uint=yes)
++ AC_LANG_RESTORE
++ AC_MSG_RESULT($ac_cv_size_t_is_uint)
++ test "$ac_cv_size_t_is_uint" = "yes" && AC_DEFINE(SIZE_T_IS_UINT)
++])
++
++dnl Configure-time switch with default
++dnl
++dnl Each switch defines an --enable-FOO and --disable-FOO option in
++dnl the resulting configure script.
++dnl
++dnl Usage:
++dnl smr_SWITCH(name, description, default, pos-def, neg-def)
++dnl
++dnl where:
++dnl
++dnl name name of switch; generates --enable-name & --disable-name
++dnl options
++dnl description help string is set to this prefixed by "enable" or
++dnl "disable", whichever is the non-default value
++dnl default either "on" or "off"; specifies default if neither
++dnl --enable-name nor --disable-name is specified
++dnl pos-def a symbol to AC_DEFINE if switch is on (optional)
++dnl neg-def a symbol to AC_DEFINE if switch is off (optional)
++dnl
++AC_DEFUN(smr_SWITCH, [
++ AC_MSG_CHECKING(whether to enable $2)
++ AC_ARG_ENABLE(
++ $1,
++ ifelse($3, on,
++ [ --disable-[$1] disable [$2]],
++ [ --enable-[$1] enable [$2]]),
++ [ if test "$enableval" = yes; then
++ AC_MSG_RESULT(yes)
++ ifelse($4, , , AC_DEFINE($4))
++ else
++ AC_MSG_RESULT(no)
++ ifelse($5, , , AC_DEFINE($5))
++ fi ],
++ ifelse($3, on,
++ [ AC_MSG_RESULT(yes)
++ ifelse($4, , , AC_DEFINE($4)) ],
++ [ AC_MSG_RESULT(no)
++ ifelse($5, , , AC_DEFINE($5))]))])
++
diff --git a/recipes/openjade/openjade-1.3.2/oj-native-libosp-fix.patch b/recipes/openjade/openjade-1.3.2/oj-native-libosp-fix.patch
new file mode 100644
index 0000000000..c82320b7fd
--- /dev/null
+++ b/recipes/openjade/openjade-1.3.2/oj-native-libosp-fix.patch
@@ -0,0 +1,12 @@
+Index: openjade-1.3.2/Makefile.prog.in
+===================================================================
+--- openjade-1.3.2.orig/Makefile.prog.in 2007-12-21 14:48:00.000000000 +0100
++++ openjade-1.3.2/Makefile.prog.in 2007-12-21 14:50:12.000000000 +0100
+@@ -13,6 +13,7 @@
+ ALL_LIBS = $(XLIBS) $(LIBS)
+ Makefile.lt:
+ echo 'LT_LIBS='`echo $(ALL_LIBS)|sed 's/\.a/.la/g'` >Makefile.lt
++ sed -i -e "s|libosp.la|libosp.so|" Makefile.lt
+
+ PROG:=$(shell echo "$(PROG)" | sed '@program_transform_name@')
+
diff --git a/recipes/openjade/openjade-native_1.3.2.bb b/recipes/openjade/openjade-native_1.3.2.bb
new file mode 100644
index 0000000000..822c47dd3b
--- /dev/null
+++ b/recipes/openjade/openjade-native_1.3.2.bb
@@ -0,0 +1,50 @@
+SECTION = "unknown"
+DEPENDS = "opensp-native sgml-common-native"
+LICENSE = "MIT"
+SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/openjade-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://oj-native-libosp-fix.patch;patch=1;pnum=1"
+S = "${WORKDIR}/openjade-${PV}"
+
+inherit autotools native
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/openjade-${PV}"
+PACKAGES = ""
+
+EXTRA_OECONF = "--enable-spincludedir=${STAGING_INCDIR}/OpenSP \
+ --enable-splibdir=${STAGING_LIBDIR} \
+ --enable-default-catalog=${sysconfdir}/sgml/catalog \
+ --enable-default-search-path=${datadir}/sgml"
+
+acpaths = "-I ${S}/config"
+
+# Trailing whitespace is important. Otherwise compiler arguments will be messed
+# up, resulting in a fail in do_configure.
+CFLAGS_prepend = "-I${S}/include "
+
+do_configure () {
+ mv config/configure.in .
+ gnu-configize
+ oe_runconf
+}
+
+do_stage () {
+ # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/openjade.html
+ # for details.
+ install -m 0755 ${S}/jade/.libs/openjade ${STAGING_BINDIR_NATIVE}/openjade
+ ln -sf openjade ${STAGING_BINDIR_NATIVE}/jade
+
+ oe_libinstall -a -so -C style libostyle ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C spgrove libospgrove ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C grove libogrove ${STAGING_LIBDIR}
+
+ install -d ${STAGING_DATADIR}/sgml/openjade-${PV}
+ install -m 644 dsssl/catalog ${STAGING_DATADIR}/sgml/openjade-${PV}
+ install -m 644 dsssl/*.{dtd,dsl,sgm} ${STAGING_DATADIR}/sgml/openjade-${PV}
+
+ install-catalog --add ${sysconfdir}/sgml/openjade-${PV}.cat \
+ ${STAGING_DATADIR}/sgml/openjade-${PV}/catalog
+
+ install-catalog --add ${sysconfdir}/sgml/sgml-docbook.cat \
+ ${sysconfdir}/sgml/openjade-${PV}.cat
+}
diff --git a/recipes/openjade/openjade_1.3.2.bb b/recipes/openjade/openjade_1.3.2.bb
new file mode 100644
index 0000000000..dcbfd886a0
--- /dev/null
+++ b/recipes/openjade/openjade_1.3.2.bb
@@ -0,0 +1,30 @@
+SECTION = "unknown"
+DEPENDS = "opensp"
+RDEPENDS = "sgml-common"
+DESCRIPTION = "OpenJade is a suite of tools for validating, \
+processing, and applying DSSSL (Document Style Semantics and \
+Specification Language) stylesheets to SGML and XML documents."
+LICENSE = "BSD"
+SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/openjade-${PV}.tar.gz \
+ file://configure.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-spincludedir=${STAGING_INCDIR}/OpenSP \
+ --enable-splibdir=${STAGING_LIBDIR}"
+
+acpaths = "-I ${S}/config"
+
+# Trailing whitespace is important. Otherwise compiler arguments will be messed
+# up, resulting in a fail in do_configure.
+CFLAGS_prepend = "-I${S}/include "
+
+do_configure_prepend () {
+ mv config/configure.in .
+}
+
+do_stage () {
+ oe_libinstall -a -so -C style libostyle ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C spgrove libospgrove ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C grove libogrove ${STAGING_LIBDIR}
+}