aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openldap
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-10-17 14:04:58 -0700
committerKhem Raj <raj.khem@gmail.com>2010-10-17 14:07:25 -0700
commit980a1ea8d5bbe2c0c6e4b8f79883b0f294de979b (patch)
tree63bf693bad8b6f0462a55a2c84bf8a2f6b635902 /recipes/openldap
parent54edb574ee2f981634fdca2c2df348fbe275400d (diff)
downloadopenembedded-980a1ea8d5bbe2c0c6e4b8f79883b0f294de979b.tar.gz
openldap_2.4.23.bb: Fix build when using libtool 2.4
* It uses a prebuilt version of libtool which does not know about sysroot and worse it does not use automake and autoconf in such a way that one could use autoreconf to regenerate stuff. So we regenerate the things needed for libtool macros. It should work with any version of libtool now. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/openldap')
-rw-r--r--recipes/openldap/openldap_2.4.23.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/openldap/openldap_2.4.23.bb b/recipes/openldap/openldap_2.4.23.bb
index c7248fd49f..94ed5eb65c 100644
--- a/recipes/openldap/openldap_2.4.23.bb
+++ b/recipes/openldap/openldap_2.4.23.bb
@@ -12,7 +12,7 @@ LICENSE = "OpenLDAP"
SECTION = "libs"
LDAP_VER = "${@'.'.join(bb.data.getVar('PV',d,1).split('.')[0:2])}"
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/${P}.tgz"
SRC_URI += "file://openldap-m4-pthread.patch"
@@ -188,7 +188,12 @@ DEPENDS += "${OPENLDAP_DEPENDS}"
CPPFLAGS_append = " -D_GNU_SOURCE"
do_configure() {
+ cp ${STAGING_DATADIR}/libtool/ltmain.sh ${S}/build
+ rm -f ${S}/libtool
+ aclocal
+ libtoolize --force --copy
gnu-configize
+ autoconf
oe_runconf
}