aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmax
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2011-01-17 23:50:33 +0100
committerKhem Raj <raj.khem@gmail.com>2011-01-22 09:23:09 -0800
commit0e8eaa0a6784a4160d6db474b33caf37dd351543 (patch)
treede172fd1dbf29d0a710f845400567aa1abcdf19e /recipes/openmax
parentb0a51470836434aa70a8c30a0eb0b0b15089418b (diff)
downloadopenembedded-0e8eaa0a6784a4160d6db474b33caf37dd351543.tar.gz
libomxil-bellagio_{0.9.2.1, git}: add patch: remove `-Werror` from `CFLAGS` to fix build with GCC 4.5
Am Montag, den 17.01.2011, 12:45 +0100 schrieb Paul Menzel: > Build tested with `angstrom-2008.1` for `MACHINE = "beagleboard"`. With `angstrom-2010.x` it fails with the following error. > > arm-angstrom-linux-gnueabi-libtool: compile: arm-angstrom-linux-gnueabi-gcc -march=armv7-a -mtune=cortex-a8 -mfpu=neon -mfloat-abi=softfp -mthumb-interwork -mno-thumb -DHAVE_CONFIG_H -I. -I../.. -isystem/oe/build-angstrom-next/angstrom-dev/sysroots/armv7a-angstrom-linux-gnueabi/usr/include -I../../include -I../../src -isystem/oe/build-angstrom-next/angstrom-dev/sysroots/armv7a-angstrom-linux-gnueabi/usr/include -fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2 -ggdb2 -Wall -Werror -DCONFIG_DEBUG_LEVEL=0 -MT libomxbase_la-omx_base_component.lo -MD -MP -MF .deps/libomxbase_la-omx_base_component.Tpo -c omx_base_component.c -fPIC -DPIC -o .libs/libomxbase_la-omx_base_component.o > cc1: warnings being treated as errors > omx_base_component.c: In function 'omx_base_component_GetParameter': > omx_base_component.c:991:3: error: case value '2130706435' not in enumerated type 'OMX_INDEXTYPE' > omx_base_component.c:918:3: error: case value '2130706436' not in enumerated type 'OMX_INDEXTYPE' > make[3]: *** [libomxbase_la-omx_base_component.lo] Error 1 > make[3]: Leaving directory `/oe/build-angstrom-next/angstrom-dev/work/armv7a-angstrom-linux-gnueabi/libomxil-bellagio-0.9.2.1+gitr0+772f0eca88b242ffb5469e8e381c63ce1f7cd3e1-r7.0/git/src/base' Upstream advised to remove `-Werror` and is looking into it [1]. OpenBricks is applying the same patch [2]. A similar patch would make 0.9.2 compile, but this one here does not apply there (`CFLAGS="${CFLAGS} -Werror"` instead of `CFLAGS="${CFLAGS} -Wall -Werror"`). [1] http://sourceforge.net/mailarchive/message.php?msg_id=26911808 [2] http://hg.openbricks.org/openbricks/rev/4f4ed3a596f2 Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/openmax')
-rw-r--r--recipes/openmax/libomxil-bellagio/0001-configure.ac-remove-Werror-from-CFLAGS.patch32
-rw-r--r--recipes/openmax/libomxil-bellagio_0.9.2.1.bb4
-rw-r--r--recipes/openmax/libomxil-bellagio_git.bb3
3 files changed, 39 insertions, 0 deletions
diff --git a/recipes/openmax/libomxil-bellagio/0001-configure.ac-remove-Werror-from-CFLAGS.patch b/recipes/openmax/libomxil-bellagio/0001-configure.ac-remove-Werror-from-CFLAGS.patch
new file mode 100644
index 0000000000..1df2b262fd
--- /dev/null
+++ b/recipes/openmax/libomxil-bellagio/0001-configure.ac-remove-Werror-from-CFLAGS.patch
@@ -0,0 +1,32 @@
+From 85a2b9666ba2b65920f4ad0e2216405dc14340d4 Mon Sep 17 00:00:00 2001
+From: Paul Menzel <paulepanter@users.sourceforge.net>
+Date: Mon, 17 Jan 2011 23:35:18 +0100
+Subject: [PATCH] configure.ac: remove `-Werror` from `CFLAGS`
+
+These options should be set when compiling the program and passed by an environment variable. Or there should be an option to turn these restrictive options off.
+
+Currently the build fails at least with GCC 4.5. It is known to work with GCC 4.3.3 [1].
+
+[1] http://sourceforge.net/mailarchive/message.php?msg_id=26911808
+
+Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
+---
+ configure.ac | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index d6e0bc9..fb5c8c8 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -5,7 +5,7 @@ AM_INIT_AUTOMAKE()
+ AC_PREREQ([2.59])
+
+ AC_CONFIG_HEADERS([config.h])
+-CFLAGS="${CFLAGS} -Wall -Werror"
++CFLAGS="${CFLAGS} -Wall"
+
+ ################################################################################
+ # Set the shared versioning info, according to section 6.3 of the libtool info #
+--
+1.7.2.3
+
diff --git a/recipes/openmax/libomxil-bellagio_0.9.2.1.bb b/recipes/openmax/libomxil-bellagio_0.9.2.1.bb
index f21c731fcb..89f521af03 100644
--- a/recipes/openmax/libomxil-bellagio_0.9.2.1.bb
+++ b/recipes/openmax/libomxil-bellagio_0.9.2.1.bb
@@ -2,5 +2,9 @@ require ${PN}.inc
PR = "${INC_PR}.0"
+SRC_URI += " \
+ file://0001-configure.ac-remove-Werror-from-CFLAGS.patch \
+"
+
SRC_URI[md5sum] = "323049db668ab260870fd7ecd2ec4156"
SRC_URI[sha256sum] = "75cf8d3b5cac2764420ae2cc7846b9bb12a47d2ca04c96e5821309b0124ddc72"
diff --git a/recipes/openmax/libomxil-bellagio_git.bb b/recipes/openmax/libomxil-bellagio_git.bb
index 4e28251f75..f58adf4d2a 100644
--- a/recipes/openmax/libomxil-bellagio_git.bb
+++ b/recipes/openmax/libomxil-bellagio_git.bb
@@ -4,6 +4,9 @@ PR = "${INC_PR}.0"
SRCREV = "772f0eca88b242ffb5469e8e381c63ce1f7cd3e1"
SRC_URI = "git://omxil.git.sourceforge.net/gitroot/omxil/omxil;protocol=git"
+SRC_URI += " \
+ file://0001-configure.ac-remove-Werror-from-CFLAGS.patch \
+"
PV = "0.9.2.1"
PR = "${INC_PR}.0"
PR_append = "+gitr${SRCPV}"